summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2019-04-24 22:20:19 +0000
committerDaniel Bermond2019-04-24 22:20:19 +0000
commit902a2471431f879cc7edcdf2c4a3a1096de129e5 (patch)
tree0f403200e82111743171b787d24671f6994ad5b8
parentf7683968506fd93e1431cf5cd1e92db774577413 (diff)
downloadaur-902a2471431f879cc7edcdf2c4a3a1096de129e5.tar.gz
Updated to version 430.09
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD13
-rw-r--r--linux-4.16.patch33
3 files changed, 8 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f833ad40287..aca82e7fb14e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,19 @@
pkgbase = nvidia-beta
pkgdesc = NVIDIA drivers for Arch's official 'linux' package (beta version)
- pkgver = 418.56
+ pkgver = 430.09
pkgrel = 1
url = https://www.nvidia.com/
arch = x86_64
license = custom:NVIDIA
makedepends = linux-headers
depends = linux
- depends = nvidia-utils-beta>=418.56
+ depends = nvidia-utils-beta>=430.09
depends = libgl
- provides = nvidia=418.56
+ provides = nvidia=430.09
conflicts = nvidia
options = !strip
- source = https://us.download.nvidia.com/XFree86/Linux-x86_64/418.56/NVIDIA-Linux-x86_64-418.56-no-compat32.run
- source = linux-4.16.patch
- sha256sums = 5e5cfcc6a392ceee156d3a55fc1c1cdebd5831b371163c6028fe409cefbf9d43
- sha256sums = 622ac792ec200b2239cb663c0010392118b78c9904973d82cd261165c16d6385
+ source = https://us.download.nvidia.com/XFree86/Linux-x86_64/430.09/NVIDIA-Linux-x86_64-430.09-no-compat32.run
+ sha256sums = 247e127fcf1f1902193104f22ca69e1974f834b3c4502a0eba42312b8d6c88b9
pkgname = nvidia-beta
diff --git a/PKGBUILD b/PKGBUILD
index d1261a44aced..5449f68ce2fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Based on [extra]'s nvidia: https://www.archlinux.org/packages/extra/x86_64/nvidia/
pkgname=nvidia-beta
-pkgver=418.56
+pkgver=430.09
pkgrel=1
pkgdesc="NVIDIA drivers for Arch's official 'linux' package (beta version)"
arch=('x86_64')
@@ -17,10 +17,8 @@ provides=("nvidia=${pkgver}")
conflicts=('nvidia')
options=('!strip')
_pkg="NVIDIA-Linux-${CARCH}-${pkgver}-no-compat32"
-source=("https://us.download.nvidia.com/XFree86/Linux-${CARCH}/${pkgver}/${_pkg}.run"
- 'linux-4.16.patch')
-sha256sums=('5e5cfcc6a392ceee156d3a55fc1c1cdebd5831b371163c6028fe409cefbf9d43'
- '622ac792ec200b2239cb663c0010392118b78c9904973d82cd261165c16d6385')
+source=("https://us.download.nvidia.com/XFree86/Linux-${CARCH}/${pkgver}/${_pkg}.run")
+sha256sums=('247e127fcf1f1902193104f22ca69e1974f834b3c4502a0eba42312b8d6c88b9')
_extramodules=extramodules-ARCH
prepare() {
@@ -28,11 +26,6 @@ prepare() {
[ -d "$_pkg" ] && rm -rf "$_pkg"
printf '%s\n' " -> Self-Extracting ${_pkg}.run..."
sh "${_pkg}.run" --extract-only
-
- # restore phys_to_dma support
- # https://bugs.archlinux.org/task/58074
- cd "$_pkg"
- patch -Np1 -i "${srcdir}/linux-4.16.patch"
}
build() {
diff --git a/linux-4.16.patch b/linux-4.16.patch
deleted file mode 100644
index 67172815ff69..000000000000
--- a/linux-4.16.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff --git a/kernel/common/inc/nv-linux.h b/kernel/common/inc/nv-linux.h
-index 10fc418..22ef968 100644
---- a/kernel/common/inc/nv-linux.h
-+++ b/kernel/common/inc/nv-linux.h
-@@ -175,7 +175,11 @@ static inline uid_t __kuid_val(kuid_t uid)
-
- #if defined(NV_VM_INSERT_PAGE_PRESENT)
- #include <linux/pagemap.h>
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 16, 0)
- #include <linux/dma-mapping.h>
-+#else
-+#include <linux/dma-direct.h>
-+#endif
- #endif
-
- #if defined(CONFIG_SWIOTLB) && defined(NVCPU_AARCH64)
-diff --git a/kernel/conftest.sh b/kernel/conftest.sh
-index b23dbb4..42dc576 100755
---- a/kernel/conftest.sh
-+++ b/kernel/conftest.sh
-@@ -1906,7 +1906,12 @@ compile_test() {
- # Determine if the phys_to_dma function is present.
- #
- CODE="
-+ #include <linux/version.h>
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 16, 0)
- #include <linux/dma-mapping.h>
-+#else
-+ #include <linux/dma-direct.h>
-+#endif
- void conftest_phys_to_dma(void) {
- phys_to_dma();
- }"