summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulie Shapiro2022-07-26 13:14:10 -0500
committerJulie Shapiro2022-07-26 13:14:10 -0500
commit7dc1bfba3364b375f2c6faa847c2b2f5c53cb236 (patch)
treeac8cff311b467f4a5b52411ba3885d60b52f2974
parent0c7a8ea4b2a2615ec99fa8ebf62c77b4e19f817c (diff)
downloadaur-7dc1bfba3364b375f2c6faa847c2b2f5c53cb236.tar.gz
fix linking issue from LDFLAGS
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 99708d2b1ad8..73d1d48ab9c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nvidia-container-runtime
pkgdesc = NVIDIA opencontainer runtime fork to expose GPU devices to containers.
pkgver = 3.10.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/NVIDIA/nvidia-container-toolkit
arch = x86_64
license = APACHE
@@ -9,7 +9,7 @@ pkgbase = nvidia-container-runtime
depends = libseccomp
depends = nvidia-container-toolkit>=1.9.0
options = !lto
- source = v3.10.0-1.tar.gz::https://github.com/NVIDIA/nvidia-container-toolkit/archive/v1.10.0.tar.gz
+ source = v3.10.0-2.tar.gz::https://github.com/NVIDIA/nvidia-container-toolkit/archive/v1.10.0.tar.gz
sha256sums = 7c88e6b16df92feac9a14f7ca7f2960409c71760b2563fea29c57c8799930db3
pkgname = nvidia-container-runtime
diff --git a/PKGBUILD b/PKGBUILD
index 95af9d70b687..c5393267050f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ pkgname=nvidia-container-runtime
# identical to nvidia-container-toolkit's PKGBUILD.
pkgver=3.10.0
-pkgrel=1
+pkgrel=2
toolkit_ver=1.10.0
@@ -36,15 +36,18 @@ build() {
GO111MODULE=auto \
GOPATH="${srcdir}/gopath" \
+ GOOS=linux \
go build -v \
-modcacherw \
-buildmode=pie \
-gcflags "all=-trimpath=${PWD}" \
-asmflags "all=-trimpath=${PWD}" \
- -ldflags "-s -w -extldflags ${LDFLAGS}" \
-o bin \
"./..."
- # -trimpath \ # only go > 1.13
+ # using LDFLAGS is busted because -Wl breaks linking to cuDriver* for some reason :(
+ #-ldflags "-s -w -extldflags \"${LDFLAGS}\"" \
+ # only go > 1.13
+ # -trimpath \
# go leaves a bunch of local stuff with 0400, making it break future `makepkg -C` _grumble grumble_
GO111MODULE=auto \