summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRóbert Csordás2019-06-09 18:53:22 +0200
committerRóbert Csordás2019-06-09 18:53:22 +0200
commitc419a328e814bc4a8ac09ad3c541281339aae2f7 (patch)
tree12f523a567b82cfa1d751694d49d241151940000
downloadaur-nvidia-gpu-switch.tar.gz
Create package for my gpu switching tool
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ea54984cfba1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = nvidia-gpu-switch
+ pkgdesc = Tool to switch on/off Nvidia laptop GPU for compute, without optirun.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/xdever/linux_gpu_switch
+ arch = any
+ license = Apache
+ depends = nvidia
+ depends = bbswitch
+ source = git+https://github.com/xdever/linux_gpu_switch#commit=aa6ea2c52e1c83fcb633cd3f26a8bde47b5ced07
+ md5sums = SKIP
+
+pkgname = nvidia-gpu-switch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43c4309aaba4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Robert Csordas <xdever@gmail.com>
+pkgname=nvidia-gpu-switch
+_gitsha="aa6ea2c52e1c83fcb633cd3f26a8bde47b5ced07"
+pkgver=1.0
+pkgrel=1
+epoch=
+arch=("any")
+url="https://github.com/xdever/linux_gpu_switch"
+groups=()
+depends=("nvidia" "bbswitch")
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+changelog=
+source=("git+https://github.com/xdever/linux_gpu_switch#commit=${_gitsha}")
+license=('Apache')
+md5sums=('SKIP')
+pkgdesc="Tool to switch on/off Nvidia laptop GPU for compute, without optirun."
+
+package () {
+ install -D -m755 ${srcdir}/linux_gpu_switch/gpu ${pkgdir}/usr/bin/gpu
+}