diff options
author | Daniel Bermond | 2024-02-17 13:53:18 -0300 |
---|---|---|
committer | Daniel Bermond | 2024-02-17 13:53:18 -0300 |
commit | 9bfef9d4e1e1a689d983af1166c3cc8a9e280a1b (patch) | |
tree | 90757bd817aa51e507897be37e22981e46f91e94 | |
parent | 05047a52e2a73b42f9e4ce6c20d21128f862df4f (diff) | |
download | aur-nvidia-vpf.tar.gz |
Remove dependency on ninja and python-ninja
python-ninja package does not exist anymore, and the python
implementation that exists now in ninja package does not
fulfill nvidia-vpf requirements, as it fails looking for
ninja dependency in python.
-rw-r--r-- | .SRCINFO | 8 | ||||
-rw-r--r-- | 010-nvidia-vpf-remove-unwanted-pip-build-deps.patch | 6 | ||||
-rw-r--r-- | PKGBUILD | 12 |
3 files changed, 14 insertions, 12 deletions
@@ -1,16 +1,14 @@ pkgbase = nvidia-vpf pkgdesc = NVIDIA Video Processing Framework pkgver = 2.0.0 - pkgrel = 1 + pkgrel = 2 url = https://github.com/NVIDIA/VideoProcessingFramework/ arch = x86_64 - license = Apache + license = Apache-2.0 makedepends = cmake - makedepends = ninja makedepends = python-build makedepends = python-scikit-build makedepends = python-installer - makedepends = python-ninja makedepends = python-pytorch-cuda makedepends = python-setuptools makedepends = python-wheel @@ -23,6 +21,6 @@ pkgbase = nvidia-vpf source = https://github.com/NVIDIA/VideoProcessingFramework/archive/v2.0.0/nvidia-vpf-2.0.0.tar.gz source = 010-nvidia-vpf-remove-unwanted-pip-build-deps.patch sha256sums = 09f50b12413caa0941c116bd507bb1bd5c0716d46138db7aff941226966bd6d0 - sha256sums = 334a11a45d2085b89a0780510ff2e26c6a57afc78fab7299ba1fee3e826b66a1 + sha256sums = 1188222edb0534e9385059a31c3c4f669223435b2a400ceadd28beadab0da3c5 pkgname = nvidia-vpf diff --git a/010-nvidia-vpf-remove-unwanted-pip-build-deps.patch b/010-nvidia-vpf-remove-unwanted-pip-build-deps.patch index 79635ba0785b..5184e992b677 100644 --- a/010-nvidia-vpf-remove-unwanted-pip-build-deps.patch +++ b/010-nvidia-vpf-remove-unwanted-pip-build-deps.patch @@ -1,11 +1,13 @@ --- a/pyproject.toml +++ b/pyproject.toml -@@ -33,7 +33,7 @@ requires = [ +@@ -33,8 +33,8 @@ requires = [ "setuptools>=42", "scikit-build", ## out-comment not install cmake/ninja via pip - "cmake>=3.21", +- "ninja; platform_system!='Windows'" + #"cmake>=3.21", - "ninja; platform_system!='Windows'" ++ #"ninja; platform_system!='Windows'" ] build-backend = "setuptools.build_meta" + @@ -2,25 +2,27 @@ pkgname=nvidia-vpf pkgver=2.0.0 -pkgrel=1 +pkgrel=2 pkgdesc='NVIDIA Video Processing Framework' arch=('x86_64') url='https://github.com/NVIDIA/VideoProcessingFramework/' -license=('Apache') +license=('Apache-2.0') depends=('cuda' 'nvidia-utils' 'ffmpeg' 'python' 'python-numpy') optdepends=('python-pytorch-cuda: for Torch extension (PytorchNvCodec)') -makedepends=('cmake' 'ninja' 'python-build' 'python-scikit-build' 'python-installer' - 'python-ninja' 'python-pytorch-cuda' 'python-setuptools' 'python-wheel') +makedepends=('cmake' 'python-build' 'python-scikit-build' 'python-installer' + 'python-pytorch-cuda' 'python-setuptools' 'python-wheel') source=("https://github.com/NVIDIA/VideoProcessingFramework/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz" '010-nvidia-vpf-remove-unwanted-pip-build-deps.patch') sha256sums=('09f50b12413caa0941c116bd507bb1bd5c0716d46138db7aff941226966bd6d0' - '334a11a45d2085b89a0780510ff2e26c6a57afc78fab7299ba1fee3e826b66a1') + '1188222edb0534e9385059a31c3c4f669223435b2a400ceadd28beadab0da3c5') prepare() { patch -d "VideoProcessingFramework-${pkgver}" -Np1 -i "${srcdir}/010-nvidia-vpf-remove-unwanted-pip-build-deps.patch" } build() { + export CMAKE_GENERATOR='Unix Makefiles' + cd "VideoProcessingFramework-${pkgver}" python -m build --wheel --no-isolation |