summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2015-06-13 17:59:22 +0200
committerMuflone2015-06-13 17:59:22 +0200
commit5ecac8583bd04a2571a5ef61c60b1e7cc9cf4240 (patch)
tree1c9c8489f2fb426098c26963ff230936d1fe6e65
downloadaur-nx-all.tar.gz
Initial import
-rw-r--r--.SRCINFO45
-rw-r--r--PKGBUILD70
-rw-r--r--nx-all.install22
-rw-r--r--nxnode-arch.patch40
-rw-r--r--nxsensor.service9
-rw-r--r--nxserver-arch.patch42
-rw-r--r--nxserver.service11
7 files changed, 239 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7f9fd19c00f8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,45 @@
+pkgbase = nx-all
+ pkgdesc = NoMachine nxclient, nxnode, and nxserver in one package
+ pkgver = 3.5.0
+ pkgrel = 9
+ url = https://www.nomachine.com/
+ install = nx-all.install
+ arch = i686
+ arch = x86_64
+ license = custom:nomachine
+ makedepends = python-html2text
+ depends = libcups
+ depends = psmisc
+ optdepends = openssh: SSH server for NX server
+ optdepends = tigervnc: VNC (RFB) client support
+ optdepends = rdesktop: RDP client support
+ provides = nxclient
+ provides = nxnode
+ provides = nxserver
+ conflicts = freenx
+ conflicts = nxclient
+ source = license.html::https://www.nomachine.com/licensing-3-5
+ source = nxsensor.service
+ source = nxserver.service
+ source = nxnode-arch.patch
+ source = nxserver-arch.patch
+ sha256sums = SKIP
+ sha256sums = 5ffb4b9981b305ed1dbd2cc24589607d585ece95f8739d84026e05c6909e9a7a
+ sha256sums = 7e284776f876b5a65a478b7dca5e056284c6dcf31d070a970e2898de94df1100
+ sha256sums = e32ff6b79c5bace2faf63bf9e333f66b3c283e5641c08abaf55ffef5be83a997
+ sha256sums = 7efdf6c07dbb56b76608729849af866b3df60f9533e0e162b1bf2f2df270a5b2
+ source_i686 = https://dl.dropboxusercontent.com/u/99802211/External_Sources/NoMachine%20NX/nxclient-3.5.0-7.i386.tar.gz
+ source_i686 = https://dl.dropboxusercontent.com/u/99802211/External_Sources/NoMachine%20NX/nxnode-3.5.0-9.i386.tar.gz
+ source_i686 = https://dl.dropboxusercontent.com/u/99802211/External_Sources/NoMachine%20NX/nxserver-3.5.0-11.i386.tar.gz
+ sha256sums_i686 = 3e4c5882f07ea408b3cf0e96aba6a06745a8838cccead8914ef2c96ba6a19953
+ sha256sums_i686 = 93310cd78617ca3619fbf093d6760c00459367ebf824ec643c1c5f20202d8488
+ sha256sums_i686 = 860a5de07e247e38d951f77b87f4dae3eb338120d768f2098df6332e63910074
+ source_x86_64 = https://dl.dropboxusercontent.com/u/99802211/External_Sources/NoMachine%20NX/nxclient-3.5.0-7.x86_64.tar.gz
+ source_x86_64 = https://dl.dropboxusercontent.com/u/99802211/External_Sources/NoMachine%20NX/nxnode-3.5.0-9.x86_64.tar.gz
+ source_x86_64 = https://dl.dropboxusercontent.com/u/99802211/External_Sources/NoMachine%20NX/nxserver-3.5.0-11.x86_64.tar.gz
+ sha256sums_x86_64 = e1037f3bd5ccfaa376a6e6dca1c52d666bfd7ea813d3971e85a086e541141e71
+ sha256sums_x86_64 = 555ed1d18280825075c617effec2cfdc83fd2d8be189b08b09288abefbe86238
+ sha256sums_x86_64 = 05b462bf6b888dbdd22246a521a0b6ed18ba5d55de673a53c5ae9d9c6dd68c63
+
+pkgname = nx-all
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35d22e6a9b2a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,70 @@
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
+# Contributor: Josh VanderLinden <arch@cloudlery.com>
+
+pkgname=nx-all
+pkgver=3.5.0
+pkgrel=9
+pkgdesc="NoMachine nxclient, nxnode, and nxserver in one package"
+arch=('i686' 'x86_64')
+url="https://www.nomachine.com/"
+license=('custom:nomachine')
+depends=('libcups' 'psmisc')
+makedepends=('python-html2text')
+optdepends=('openssh: SSH server for NX server'
+ 'tigervnc: VNC (RFB) client support'
+ 'rdesktop: RDP client support')
+provides=('nxclient' 'nxnode' 'nxserver')
+conflicts=('freenx' 'nxclient')
+install="${pkgname}.install"
+source=("license.html"::"https://www.nomachine.com/licensing-3-5"
+ "nxsensor.service"
+ "nxserver.service"
+ "nxnode-arch.patch"
+ "nxserver-arch.patch")
+source_i686=("https://dl.dropboxusercontent.com/u/99802211/External_Sources/NoMachine%20NX/nxclient-3.5.0-7.i386.tar.gz"
+ "https://dl.dropboxusercontent.com/u/99802211/External_Sources/NoMachine%20NX/nxnode-3.5.0-9.i386.tar.gz"
+ "https://dl.dropboxusercontent.com/u/99802211/External_Sources/NoMachine%20NX/nxserver-3.5.0-11.i386.tar.gz")
+source_x86_64=("https://dl.dropboxusercontent.com/u/99802211/External_Sources/NoMachine%20NX/nxclient-3.5.0-7.x86_64.tar.gz"
+ "https://dl.dropboxusercontent.com/u/99802211/External_Sources/NoMachine%20NX/nxnode-3.5.0-9.x86_64.tar.gz"
+ "https://dl.dropboxusercontent.com/u/99802211/External_Sources/NoMachine%20NX/nxserver-3.5.0-11.x86_64.tar.gz")
+sha256sums=('SKIP'
+ '5ffb4b9981b305ed1dbd2cc24589607d585ece95f8739d84026e05c6909e9a7a'
+ '7e284776f876b5a65a478b7dca5e056284c6dcf31d070a970e2898de94df1100'
+ 'e32ff6b79c5bace2faf63bf9e333f66b3c283e5641c08abaf55ffef5be83a997'
+ '7efdf6c07dbb56b76608729849af866b3df60f9533e0e162b1bf2f2df270a5b2')
+sha256sums_i686=('3e4c5882f07ea408b3cf0e96aba6a06745a8838cccead8914ef2c96ba6a19953'
+ '93310cd78617ca3619fbf093d6760c00459367ebf824ec643c1c5f20202d8488'
+ '860a5de07e247e38d951f77b87f4dae3eb338120d768f2098df6332e63910074')
+sha256sums_x86_64=('e1037f3bd5ccfaa376a6e6dca1c52d666bfd7ea813d3971e85a086e541141e71'
+ '555ed1d18280825075c617effec2cfdc83fd2d8be189b08b09288abefbe86238'
+ '05b462bf6b888dbdd22246a521a0b6ed18ba5d55de673a53c5ae9d9c6dd68c63')
+
+prepare() {
+ # Prepare license file
+ html2text --ignore-links --ignore-images --ignore-emphasis --body-width=80 < \
+ license.html | sed -n '/End-User License Agreement/,/for any updates/p' > LICENSE
+ # Patch nxnode and nxserver launchers
+ patch -Np2 -i "nxnode-arch.patch"
+ patch -Np2 -i "nxserver-arch.patch"
+ # Fix configuration files
+ cd "NX/etc"
+ install "node-debian.cfg.sample" "node-arch.cfg.sample"
+ sed -i 's,^CommandFuser =.*$,CommandFuser = "/usr/bin/fuser",' "node-arch.cfg.sample"
+ install "server-debian.cfg.sample" "server-arch.cfg.sample"
+ sed -i 's/^#SSHAuthorizedKeys = .*$/SSHAuthorizedKeys = "authorized_keys"/' "server-arch.cfg.sample"
+}
+
+package() {
+ install -m 755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m 644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
+
+ install -m 755 -d "${pkgdir}/usr/lib/systemd/system"
+ install -m 644 -t "${pkgdir}/usr/lib/systemd/system" "nxsensor.service" "nxserver.service"
+
+ install -m 755 -d "${pkgdir}/usr/NX"
+ cp -a "${srcdir}/NX" "${pkgdir}/usr/"
+ install -m 755 -d "${pkgdir}/usr/bin/"
+
+ ln -s -t "${pkgdir}/usr/bin/" /usr/NX/bin/{nxclient,nxkill,nxnode,nxprint,nxserver}
+}
+
diff --git a/nx-all.install b/nx-all.install
new file mode 100644
index 000000000000..6a1de5576d38
--- /dev/null
+++ b/nx-all.install
@@ -0,0 +1,22 @@
+post_install() {
+ /usr/NX/scripts/setup/nxnode --install arch
+ /usr/NX/scripts/setup/nxserver --install arch
+}
+
+pre_upgrade() {
+ /usr/NX/scripts/setup/nxserver --stop > /dev/null 2>&1
+ /usr/NX/scripts/setup/nxserver --broadcast "NX is being upgraded" > /dev/null 2>&1
+}
+
+post_upgrade() {
+ echo "post_upgrade"
+ /usr/NX/scripts/setup/nxserver --update arch
+ /usr/NX/scripts/setup/nxnode --update arch
+}
+
+pre_remove() {
+ pre_upgrade
+ /usr/NX/scripts/setup/nxserver --uninstall
+ /usr/NX/scripts/setup/nxnode --uninstall
+}
+
diff --git a/nxnode-arch.patch b/nxnode-arch.patch
new file mode 100644
index 000000000000..c20b106e841d
--- /dev/null
+++ b/nxnode-arch.patch
@@ -0,0 +1,40 @@
+--- a/usr/NX/scripts/setup/nxnode 2012-05-19 04:24:46.000000000 -0600
++++ b/usr/NX/scripts/setup/nxnode 2012-11-16 09:18:10.801770960 -0700
+@@ -1301,6 +1301,10 @@
+ }
+
+ removeNXinit () {
++ if [ "$system" = "arch" ]; then
++ systemctl disable nxsensor
++ return 0
++ fi
+
+ if [ "$system" = "fedora" ] || [ "$system" = "redhat" ] || [ "$system" = "suse" ];
+ then
+@@ -1505,6 +1509,10 @@
+
+
+ addNXinit () {
++ if [ "$system" = "arch" ]; then
++ systemctl enable nxsensor
++ return 0
++ fi
+
+ runCommand "cat $NODE_ROOT/scripts/init/nxsensor > /etc/init.d/nxsensor" "Unable to create: '/etc/init.d/nxsensor'" "warn"
+ runCommand "chmod +x /etc/init.d/nxsensor" "Cannot set permissions of '/etc/init.d/nxsensor' file" "warn"
+@@ -2479,6 +2487,7 @@
+ echo " debian Debian Woody 3.0, Unstable, Ubuntu, etc."
+ echo " solaris Sun Solaris 8.0, 9.0, 10.0, etc."
+ echo " fedora Fedora Core 1, 2, 3, 4, 5, etc. "
++ echo " arch Arch Linux"
+
+ echo "$errMsg"
+
+@@ -2589,6 +2598,7 @@
+ "fedora" ) ;;
+ "debian" ) ;;
+ "solaris" ) ;;
++ "arch" ) ;;
+ "" ) ARGS=-1 && errMsg="$PREFIX $ERROR ERROR: Unable to autodetect the operating system type, please specify it" ;;
+ * ) ARGS=-1 && errMsg="$PREFIX $ERROR ERROR: Unsupported operating system '$system'" ;;
+ esac
diff --git a/nxsensor.service b/nxsensor.service
new file mode 100644
index 000000000000..8a5700a7c7eb
--- /dev/null
+++ b/nxsensor.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=NoMachine nxsensor service
+
+[Service]
+ExecStart=/usr/NX/bin/nxsensor "-a" "127.0.0.1" "-a" "::ffff:127.0.0.1" "-P" "19250"
+Restart=always
+
+[Install]
+WantedBy=multi-user.target
diff --git a/nxserver-arch.patch b/nxserver-arch.patch
new file mode 100644
index 000000000000..ad42f17d4daf
--- /dev/null
+++ b/nxserver-arch.patch
@@ -0,0 +1,42 @@
+--- a/usr/NX/scripts/setup/nxserver 2012-05-19 03:45:03.000000000 -0600
++++ b/usr/NX/scripts/setup/nxserver 2012-11-16 09:44:04.615561778 -0700
+@@ -649,6 +649,11 @@
+
+ removeNXinit () {
+
++ if [ "$system" = "arch" ]; then
++ systemctl disable nxserver
++ return 0
++ fi
++
+ if [ "$system" = "fedora" ] || [ "$system" = "redhat" ] || [ "$system" = "suse" ];
+ then
+ if [ -f "/sbin/chkconfig" ];
+@@ -853,6 +858,11 @@
+
+ addNXinit () {
+
++ if [ "$system" = "arch" ]; then
++ systemctl enable nxserver
++ return 0
++ fi
++
+ runCommand "cat $NODE_ROOT/scripts/init/nxserver > /etc/init.d/nxserver" "Unable to create: '/etc/init.d/nxserver'" "warn"
+ runCommand "chmod +x /etc/init.d/nxserver" "Cannot set permissions of '/etc/init.d/nxserver' file" "warn"
+
+@@ -2600,6 +2610,7 @@
+ echo " debian Debian Woody 3.0, Unstable, Ubuntu, etc."
+ echo " solaris Sun Solaris 8.0, 9.0, 10.0, etc."
+ echo " fedora Fedora Core 1, 2, 3, 4, 5, etc. "
++ echo " arch Arch Linux"
+
+ echo "$errMsg"
+
+@@ -2714,6 +2725,7 @@
+ "fedora" ) ;;
+ "debian" ) ;;
+ "solaris" ) ;;
++ "arch" ) ;;
+ "" ) ARGS=-1 && errMsg="$PREFIX $ERROR ERROR: Unable to autodetect the operating system type, please specify it" ;;
+ * ) ARGS=-1 && errMsg="$PREFIX $ERROR ERROR: Unsupported operating system '$system'" ;;
+ esac
diff --git a/nxserver.service b/nxserver.service
new file mode 100644
index 000000000000..230518dc86c2
--- /dev/null
+++ b/nxserver.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=NoMachine NX Server
+
+[Service]
+ExecStart=/usr/NX/bin/nxserver --start
+ExecStop=/usr/NX/bin/nxserver --shutdown
+Type=oneshot
+RemainAfterExit=true
+
+[Install]
+WantedBy=multi-user.target