summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMithicSpirit2022-07-12 18:14:22 -0400
committerMithicSpirit2022-07-12 18:14:22 -0400
commit3c6a9ffb63f4efdb939c448dc119c75fc1a18100 (patch)
tree1f6dd1fcd21c409b41813e3058a306cd1e4783ea
parent1dbec4d4b7c24797dcf60c085e91fdd6ebd1ffaf (diff)
downloadaur-nyxt-browser-git.tar.gz
Update to be more in-line with nyxt package
Main change is that conflicts and provides were both changed to nyxt, though some other things also received minor changes. Also considering moving this package to nyxt-git in the near future. Please let me know if there are any issues with the changes.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 849af7b5f92b..45f5e65c7e3f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = nyxt-browser-git
- pkgdesc = Keyboard-oriented, Common Lisp extensible web-browser
+ pkgdesc = A keyboard-driven web browser designed for power users
pkgver = latest
pkgrel = 1
url = https://nyxt.atlas.engineer
@@ -20,9 +20,8 @@ pkgbase = nyxt-browser-git
optdepends = gst-plugins-good: for HTML5 audio/video
optdepends = gst-plugins-bad: for HTML5 audio/video
optdepends = gst-plugins-ugly: for HTML5 audio/video
- provides = nyxt-browser
- provides = next-browser
- conflicts = nyxt-browser
+ provides = nyxt
+ conflicts = nyxt
options = !strip
options = !makeflags
source = nyxt-browser::git+https://github.com/atlas-engineer/nyxt.git
diff --git a/PKGBUILD b/PKGBUILD
index 4e4482b35435..713472ea778f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,12 +6,12 @@ _pkgname=nyxt-browser
pkgname=$_pkgname-git
pkgver=latest
pkgrel=1
-pkgdesc="Keyboard-oriented, Common Lisp extensible web-browser"
+pkgdesc='A keyboard-driven web browser designed for power users'
arch=('i686' 'x86_64')
-url="https://nyxt.atlas.engineer"
+url='https://nyxt.atlas.engineer'
license=('custom:BSD')
-conflicts=('nyxt-browser')
-provides=('nyxt-browser' 'next-browser')
+conflicts=('nyxt')
+provides=('nyxt')
source=($_pkgname::git+https://github.com/atlas-engineer/nyxt.git)
sha256sums=('SKIP')
# If someday Next works with other Lisps, replace 'sbcl' with 'common-lisp'.
@@ -35,6 +35,12 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$srcdir/$_pkgname"
+ git submodule init
+ git submodule update
+}
+
build() {
cd "$srcdir/$_pkgname"
make all
@@ -42,7 +48,7 @@ build() {
package() {
cd "$srcdir/$_pkgname"
- make install PREFIX=/usr DESTDIR=${pkgdir}
+ make install PREFIX=/usr DESTDIR="${pkgdir}"
install -dm755 "$pkgdir"/usr/share/licenses/$pkgname/
install -m644 licenses/* "$pkgdir"/usr/share/licenses/$pkgname/
}