summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAli Molaei2022-09-09 16:34:12 +0430
committerAli Molaei2022-09-09 16:34:12 +0430
commit80437024a9888950b6dffadc4faa2ef7c94b3faa (patch)
treea2248a06b0272b9505b6c5019c1ea01eba310ba8
parente1a524b62b0f35efd9f5b7c242edfdb51a9eccbe (diff)
downloadaur-obfs4proxy-bin.tar.gz
Update to 0.0.14, Update upstream url
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD12
3 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a5a22470c72..248cc8d4a7a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = obfs4proxy-bin
pkgdesc = The obfourscator - A Pluggable Transport Proxy Written in Go (This package is built by myself for thoes who live in countries with tor censored that cannot download the source in obfs4proxy package
- pkgver = 0.0.13
- pkgrel = 2
- url = https://gitweb.torproject.org/pluggable-transports/obfs4.git/
+ pkgver = 0.0.14
+ pkgrel = 1
+ url = https://gitlab.com/yawning/obfs4
arch = x86_64
license = BSD
makedepends = glibc
optdepends = tor: you need tor to use this package
conflicts = obfs4proxy
- source = https://github.com/molaeiali/obfs4proxy-bin/raw/master/files.tar.xz
- sha512sums = 9b01700c89f5eb3f113bc51c9267af1f741c7254123f7b56cfb3871c915689538492871ae4d267d92c931aa8617211ec39b20bea70d298f35ddd60812c086a3c
+ source = files-0.0.14.tar.xz::https://github.com/molaeiali/obfs4proxy-bin/raw/master/files.tar.xz
+ sha512sums = 273078c03d954b8f6b1ac84b852397bd6c7434268c681083c3703fef2a94b34120b19e4386d1b3bac117d5b57294f7bf5e13fa620fa8d07ef70c13f3f678c058
pkgname = obfs4proxy-bin
diff --git a/.gitignore b/.gitignore
index f930bce9542a..7144f012fc09 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,4 +4,4 @@
/pkg/
pkg/
src/
-files.tar.xz
+files-*
diff --git a/PKGBUILD b/PKGBUILD
index 42c1dae4465b..920e6b6e4cbd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
# Maintainer: Ali Molaei <ali dot molaei at protonmail dot com>
pkgname=obfs4proxy-bin
-pkgver=0.0.13
-pkgrel=2
+pkgver=0.0.14
+pkgrel=1
pkgdesc='The obfourscator - A Pluggable Transport Proxy Written in Go (This package is built by myself for thoes who live in countries with tor censored that cannot download the source in obfs4proxy package'
arch=('x86_64')
-url='https://gitweb.torproject.org/pluggable-transports/obfs4.git/'
+url='https://gitlab.com/yawning/obfs4'
license=('BSD')
conflicts=("${pkgname%-bin}")
makedepends=('glibc')
optdepends=('tor: you need tor to use this package')
-source=('https://github.com/molaeiali/obfs4proxy-bin/raw/master/files.tar.xz')
-sha512sums=('9b01700c89f5eb3f113bc51c9267af1f741c7254123f7b56cfb3871c915689538492871ae4d267d92c931aa8617211ec39b20bea70d298f35ddd60812c086a3c')
+source=("files-${pkgver}.tar.xz::https://github.com/molaeiali/obfs4proxy-bin/raw/master/files.tar.xz")
+sha512sums=('273078c03d954b8f6b1ac84b852397bd6c7434268c681083c3703fef2a94b34120b19e4386d1b3bac117d5b57294f7bf5e13fa620fa8d07ef70c13f3f678c058')
prepare() {
cd "${srcdir}"
- tar -xvf "${srcdir}/files.tar.xz"
+ tar -xvf "${srcdir}/files-${pkgver}.tar.xz"
}
package() {