summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Garfias2021-03-08 20:22:40 -0600
committerDavid Garfias2021-03-08 20:22:40 -0600
commit5d646aeb36b1ea6d073d8771b6df26d39519bd44 (patch)
tree003eca1cb8736acd98ec5d0a0fdb44d7aaf7421a
parent3336817569693400617d59440aaa1bd30df44270 (diff)
downloadaur-5d646aeb36b1ea6d073d8771b6df26d39519bd44.tar.gz
Updated to v0.1.2
-rw-r--r--.SRCINFO8
-rw-r--r--CHANGELOG9
-rw-r--r--PKGBUILD6
3 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a091c0435c3..67eeff8e3a3b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-gnome-screencast
pkgdesc = GNOME Screen Cast OBS Studio plugin
- pkgver = 0.1.1
- pkgrel = 2
+ pkgver = 0.1.2
+ pkgrel = 1
url = https://github.com/fzwoch/obs-gnome-screencast
changelog = CHANGELOG
arch = x86_64
@@ -12,8 +12,8 @@ pkgbase = obs-gnome-screencast
depends = obs-studio
depends = gstreamer
depends = gst-plugins-base-libs
- source = https://github.com/fzwoch/obs-gnome-screencast/archive/v0.1.1.tar.gz
- sha256sums = a67e06a3473a4418ce5437e74aa82a55fe70a7f7d6d61d3e68047973b458db41
+ source = https://github.com/fzwoch/obs-gnome-screencast/archive/v0.1.2.tar.gz
+ sha256sums = a8ff8cbdb01c7c8e60f62a137eedc857bc44ffa3aa127fed269a8f2e5d1485f5
pkgname = obs-gnome-screencast
diff --git a/CHANGELOG b/CHANGELOG
index 57bdfc87978f..bff6fdcba065 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,8 +1,7 @@
v0.1.1
======
-- Removed dependency to GTK (in preparation to the GTK4 release as it removed some
-of the API being used)
-- Hopefully fixed a potential crash fix when the source was being removed while
-running
-- Some minor fixes..
+- create own thread with it's own main loop. let us not assume OBS comes with one, and if it does, try not to interfere with it.
+- always copy the video buffer. this comes with a performance penalty, but pipewire versions >= 0.21 seem to have issue if we don't.
+- don't leak the bus watch handle. this could have led to "too many files open" error in case of many stop/starts.
+
diff --git a/PKGBUILD b/PKGBUILD
index 9d7519e70737..3b1d0e48b4a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: schard <mail@richard.neumann.de>
pkgname='obs-gnome-screencast'
-pkgver='0.1.1'
-pkgrel='2'
+pkgver='0.1.2'
+pkgrel='1'
pkgdesc="GNOME Screen Cast OBS Studio plugin"
changelog='CHANGELOG'
arch=('x86_64')
@@ -13,7 +13,7 @@ license=('GPL2')
depends=('gnome-shell' 'obs-studio' 'gstreamer' 'gst-plugins-base-libs')
makedepends=('meson' 'git')
source=("${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('a67e06a3473a4418ce5437e74aa82a55fe70a7f7d6d61d3e68047973b458db41')
+sha256sums=('a8ff8cbdb01c7c8e60f62a137eedc857bc44ffa3aa127fed269a8f2e5d1485f5')
build() {
arch-meson "${pkgname}-${pkgver}" build