diff options
author | tytan652 | 2024-03-17 18:20:25 +0100 |
---|---|---|
committer | tytan652 | 2024-03-17 18:20:25 +0100 |
commit | f22aa8eeee1384605623e0ebc257bae196aae9d9 (patch) | |
tree | 389cbd4493cc4e8913b1c59e1e6d770ab086afe4 | |
parent | d9229d0ac7c30cc15fa43dc725ee7ac40dc0d44f (diff) | |
download | aur-obs-scene-notes-dock.tar.gz |
build: Allow deprecation for future-proofing
-rw-r--r-- | PKGBUILD | 9 |
1 files changed, 4 insertions, 5 deletions
@@ -6,7 +6,7 @@ pkgrel=2 pkgdesc="Plugin for OBS Studio allowing you to create a Dock for showing and editing notes for the current active scene" arch=("x86_64" "aarch64") url="https://obsproject.com/forum/resources/scene-notes-dock.1398/" -license=("GPL2") +license=("GPL-2.0-or-later") depends=("obs-studio>=28" "gcc-libs" "glibc" "qt6-base") makedepends=("cmake" "git") options=('debug') @@ -14,15 +14,14 @@ source=("$pkgname::git+https://github.com/exeldro/$pkgname#tag=$pkgver") sha256sums=("SKIP") build() { - # TODO: Next version will support 30 new API, update depends to require 30 - export CXXFLAGS+=" -Wno-error=deprecated-declarations" - cmake -B build -S $pkgname \ -DCMAKE_BUILD_TYPE=None \ -DCMAKE_INSTALL_PREFIX='/usr' \ -DCMAKE_INSTALL_LIBDIR=lib \ -DLINUX_PORTABLE=OFF \ - -DQT_VERSION=6 + -DQT_VERSION=6 \ + -DCMAKE_CXX_FLAGS="-Wno-error=deprecated-declarations" \ + -Wno-dev cmake --build build } |