summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbenklett2021-04-05 12:52:34 +0200
committerbenklett2021-04-05 12:53:43 +0200
commit6ba75aa19a2531812b49ae0cedbe8b84e7fe34c4 (patch)
treed2aa586494b51b2360e16ab08c816d649ca72c8a
parentbacfa936ab7378a2208df74cf0fa1428e280d587 (diff)
downloadaur-6ba75aa19a2531812b49ae0cedbe8b84e7fe34c4.tar.gz
Add xdg-dektop-portal for pipewire support
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c7b1cfcb3196..055345cfd008 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-studio-git
pkgdesc = Free and open source software for video recording and live streaming.
pkgver = 27.0.0.rc1.r9.g38d17acdb
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/obsproject/obs-studio
arch = i686
arch = x86_64
@@ -19,6 +19,7 @@ pkgbase = obs-studio-git
makedepends = wayland
makedepends = qt5-wayland
makedepends = pipewire
+ makedepends = xdg-desktop-portal
depends = ffmpeg
depends = jansson
depends = libxinerama
@@ -37,6 +38,8 @@ pkgbase = obs-studio-git
optdepends = luajit: Lua scripting
optdepends = python: Python scripting
optdepends = v4l2loopback-dkms: Virtual webcam
+ optdepends = pipewire: Pipewire capture
+ optdepends = xdg-desktop-portal: Pipewire capture
provides = obs-studio=27.0.0.rc1.r9.g38d17acdb
conflicts = obs-studio
source = obs-studio-git::git+https://github.com/obsproject/obs-studio.git#branch=master
diff --git a/PKGBUILD b/PKGBUILD
index 74ce04ff287d..a7f6e7c93c29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: ledti <antergist at gmail dot com>
pkgname=obs-studio-git
pkgver=27.0.0.rc1.r9.g38d17acdb
-pkgrel=1
+pkgrel=2
pkgdesc="Free and open source software for video recording and live streaming."
arch=("i686" "x86_64")
url="https://github.com/obsproject/obs-studio"
@@ -13,7 +13,7 @@ depends=("ffmpeg" "jansson" "libxinerama" "libxkbcommon-x11" "mbedtls"
"qt5-svg" "qt5-x11extras" "curl" "jack" "gtk-update-icon-cache")
makedepends=("cmake" "git" "libfdk-aac" "libxcomposite" "x264"
"vlc" "swig" "luajit" "python" "cef-minimal>=87.0.0" "wayland"
- "qt5-wayland" "pipewire")
+ "qt5-wayland" "pipewire" "xdg-desktop-portal")
optdepends=("libfdk-aac: FDK AAC codec support"
"libxcomposite: XComposite capture support"
"libva-intel-driver: hardware encoding"
@@ -21,7 +21,9 @@ optdepends=("libfdk-aac: FDK AAC codec support"
"vlc: VLC Media Source"
"luajit: Lua scripting"
"python: Python scripting"
- "v4l2loopback-dkms: Virtual webcam")
+ "v4l2loopback-dkms: Virtual webcam"
+ "pipewire: Pipewire capture"
+ "xdg-desktop-portal: Pipewire capture")
provides=("obs-studio=$pkgver")
conflicts=("obs-studio")
source=("$pkgname::git+https://github.com/obsproject/obs-studio.git#branch=master"