summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbenklett2023-04-02 23:09:34 +0200
committerbenklett2023-04-02 23:09:34 +0200
commitd377d6bb70bb03c2f3f069356603a023b01fd724 (patch)
tree78812aff2c151a73bd5d3f469b583acda0f493a4
parent9f1d398db9993327ee9a4c1ef5c140b3cd395b95 (diff)
downloadaur-d377d6bb70bb03c2f3f069356603a023b01fd724.tar.gz
Fix dependency changes in obs-websocket
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD20
2 files changed, 12 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 18f27e504399..aefc0cf3cb51 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = obs-studio-git
pkgdesc = Free and open source software for video recording and live streaming.
- pkgver = 28.1.0.beta1
- pkgrel = 2
+ pkgver = 29.1.0.beta1
+ pkgrel = 1
url = https://github.com/obsproject/obs-studio
arch = i686
arch = x86_64
license = GPL2
+ makedepends = asio
makedepends = cmake
makedepends = git
makedepends = libfdk-aac
@@ -14,9 +15,11 @@ pkgbase = obs-studio-git
makedepends = vlc
makedepends = swig
makedepends = luajit
+ makedepends = nlohmann-json
makedepends = python
makedepends = cef-minimal-obs-bin
makedepends = wayland
+ makedepends = websocketpp
makedepends = qt6-wayland
makedepends = pipewire
makedepends = xdg-desktop-portal
@@ -44,27 +47,19 @@ pkgbase = obs-studio-git
optdepends = pipewire: Pipewire capture
optdepends = pipewire-media-session: Pipewire capture
optdepends = xdg-desktop-portal: Pipewire capture
- provides = obs-studio=28.1.0.beta1
+ provides = obs-studio=29.1.0.beta1
conflicts = obs-studio
source = obs-studio-git::git+https://github.com/obsproject/obs-studio.git#branch=master
source = git+https://github.com/Mixer/ftl-sdk.git
source = git+https://github.com/obsproject/obs-browser.git
- source = git+https://github.com/obsproject/obs-vst.git
source = git+https://github.com/obsproject/obs-websocket.git
- source = git+https://github.com/chriskohlhoff/asio.git
- source = git+https://github.com/nlohmann/json.git
source = git+https://github.com/nayuki/QR-Code-generator.git
- source = git+https://github.com/zaphoyd/websocketpp.git
source = fix_python_binary_loading.patch
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
md5sums = 051b90f05e26bff99236b8fb1ad377d1
pkgname = obs-studio-git
diff --git a/PKGBUILD b/PKGBUILD
index ce49a60950bf..c27479800c70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: ArcticVanguard <LideEmily at gmail dot com>
# Contributor: ledti <antergist at gmail dot com>
pkgname=obs-studio-git
-pkgver=28.1.0.beta1
-pkgrel=2
+pkgver=29.1.0.beta1
+pkgrel=1
pkgdesc="Free and open source software for video recording and live streaming."
arch=("i686" "x86_64")
url="https://github.com/obsproject/obs-studio"
@@ -12,9 +12,9 @@ license=("GPL2")
depends=("ffmpeg" "jansson" "libxinerama" "libxkbcommon-x11" "mbedtls"
"qt6-svg" "curl" "jack" "gtk-update-icon-cache"
"speexdsp" "pciutils" "libajantv2" "librist")
-makedepends=("cmake" "git" "libfdk-aac" "libxcomposite" "x264"
- "vlc" "swig" "luajit" "python" "cef-minimal-obs-bin" "wayland"
- "qt6-wayland" "pipewire" "xdg-desktop-portal")
+makedepends=("asio" "cmake" "git" "libfdk-aac" "libxcomposite" "x264"
+ "vlc" "swig" "luajit" "nlohmann-json" "python" "cef-minimal-obs-bin" "wayland"
+ "websocketpp" "qt6-wayland" "pipewire" "xdg-desktop-portal")
optdepends=("libfdk-aac: FDK AAC codec support"
"libxcomposite: XComposite capture support"
"libva-intel-driver: hardware encoding"
@@ -31,14 +31,10 @@ conflicts=("obs-studio")
source=("$pkgname::git+https://github.com/obsproject/obs-studio.git#branch=master"
"git+https://github.com/Mixer/ftl-sdk.git"
"git+https://github.com/obsproject/obs-browser.git"
- "git+https://github.com/obsproject/obs-vst.git"
"git+https://github.com/obsproject/obs-websocket.git"
- "git+https://github.com/chriskohlhoff/asio.git"
- "git+https://github.com/nlohmann/json.git"
"git+https://github.com/nayuki/QR-Code-generator.git"
- "git+https://github.com/zaphoyd/websocketpp.git"
"fix_python_binary_loading.patch")
-md5sums=("SKIP" "SKIP" "SKIP" "SKIP" "SKIP" "SKIP" "SKIP" "SKIP" "SKIP"
+md5sums=("SKIP" "SKIP" "SKIP" "SKIP" "SKIP"
"051b90f05e26bff99236b8fb1ad377d1")
pkgver() {
@@ -53,15 +49,11 @@ prepare() {
patch -Np1 < "$srcdir"/fix_python_binary_loading.patch
git config submodule.plugins/obs-outputs/ftl-sdk.url $srcdir/ftl-sdk
git config submodule.plugins/obs-browser.url $srcdir/obs-browser
- git config submodule.plugins/obs-vst.url $srcdir/obs-vst
git config submodule.plugins/obs-websocket.url $srcdir/obs-websocket
git -c $gitconf submodule update
cd plugins/obs-websocket
- git config submodule.deps/asio.url $srcdir/asio
- git config submodule.deps/json.url $srcdir/json
git config submodule.deps/qr.url $srcdir/QR-Code-generator
- git config submodule.deps/websocketpp.url $srcdir/websocketpp
git -c $gitconf submodule update
}