summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522024-05-11 22:08:41 +0200
committertytan6522024-05-11 22:08:41 +0200
commitd6feb330264ef29ef2c17ca2afe17c2031b18c49 (patch)
tree0ebc31706d19febfd869adf6cff491d137d5c455
parent70f06292744abc17b3f9b8aa568c5d790bf37049 (diff)
downloadaur-obs-tuna.tar.gz
build: Update to version 1.9.8
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a6431d7e5fb..5bc8693ab0a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-tuna
pkgdesc = Get song info from right within obs
- pkgver = 1.9.7
- pkgrel = 3
+ pkgver = 1.9.8
+ pkgrel = 1
url = https://obsproject.com/forum/resources/tuna.843/
arch = x86_64
arch = aarch64
@@ -20,7 +20,7 @@ pkgbase = obs-tuna
conflicts = obs-plugin-tuna-bin
conflicts = obs-plugin-tuna-git
options = debug
- source = tuna::git+https://github.com/univrsal/tuna.git#tag=v1.9.7
+ source = tuna::git+https://github.com/univrsal/tuna.git#tag=v1.9.8
source = FindLibMPDClient.cmake
source = FindTaglib.cmake
source = deps_CMakeLists.txt
diff --git a/PKGBUILD b/PKGBUILD
index 95afe9b3406f..c6e824131ad9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,8 +11,8 @@ fi
_pluginname=tuna
pkgname=obs-$_pluginname
-pkgver=1.9.7
-pkgrel=3
+pkgver=1.9.8
+pkgrel=1
arch=("x86_64" "aarch64")
pkgdesc="Get song info from right within obs"
url="https://obsproject.com/forum/resources/tuna.843/"
@@ -39,15 +39,13 @@ sha256sums=(
prepare() {
cd $_pluginname
- git cherry-pick -n 723bd3c7b4e257cf0997611426e555068de77ae7
-
sed -i 's|.value()|.binaryData()|g' src/util/cover_tag_handler.cpp
cp $srcdir/FindLibMPDClient.cmake cmake/external/.
cp $srcdir/FindTaglib.cmake cmake/external/.
cp $srcdir/deps_CMakeLists.txt deps/CMakeLists.txt
- sed -i '13 a find_package(LibMPDClient REQUIRED)\nfind_package(Taglib REQUIRED)' CMakeLists.txt
+ sed -i '28 a find_package(LibMPDClient REQUIRED)\nfind_package(Taglib REQUIRED)' CMakeLists.txt
}
build() {
@@ -55,8 +53,6 @@ build() {
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX='/usr' \
-DCMAKE_INSTALL_LIBDIR=lib \
- -DLINUX_PORTABLE=OFF \
- -DQT_VERSION=6 \
-DCREDS="$SPOTIFY_TOKEN" \
-DLASTFM_CREDS="$LASTFM_KEY" \
-Wno-dev \