summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Fontenelle2021-07-24 08:43:48 -0300
committerRafael Fontenelle2021-07-24 08:43:48 -0300
commit5d1b6654b4f594fbfb75f236f1900e442e9d797e (patch)
tree6339227ba4f6fcddab5dd0cace2639aeb118494b
parent16dc88764234c7abf0087f92abb531270f12f27c (diff)
downloadaur-obs-xdg-portal-git.tar.gz
Fix build
- Replace the deleted obs-studio-wayland in favor of OBS >27 - Fix gs_texture_create_from_dmabuf call adding missing parameter
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD19
-rw-r--r--fix-gs_texture_create_from_dmabuf.patch25
3 files changed, 44 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b4d499ab9d5a..6c5321c320ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = obs-xdg-portal-git
pkgdesc = OBS Studio plugin using the Desktop portal for Wayland & X11 screencasting
- pkgver = 0.1.2.r21.g8430c46
+ pkgver = 0.1.2.r40.gee5241a
pkgrel = 1
url = https://gitlab.gnome.org/feaneron/obs-xdg-portal
arch = x86_64
license = GPL
makedepends = meson
makedepends = git
- depends = obs-studio-wayland
+ depends = obs-studio>=27
depends = xdg-desktop-portal
provides = obs-xdg-portal
conflicts = obs-xdg-portal
source = git+https://gitlab.gnome.org/feaneron/obs-xdg-portal
+ source = fix-gs_texture_create_from_dmabuf.patch
sha256sums = SKIP
+ sha256sums = 056fa69ca93b8203a72b7ee5d41ad7fca99fcb1af81a3c61e37b4d699961b18c
pkgname = obs-xdg-portal-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 6b7bfdf2be83..5d72eac92536 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,29 @@
# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
# Contributor: Davide Depau <davide@depau.eu>
pkgname="obs-xdg-portal-git"
-pkgver=0.1.2.r21.g8430c46
+pkgver=0.1.2.r40.gee5241a
pkgrel=1
pkgdesc="OBS Studio plugin using the Desktop portal for Wayland & X11 screencasting"
arch=(x86_64)
url="https://gitlab.gnome.org/feaneron/obs-xdg-portal"
license=('GPL')
-depends=('obs-studio-wayland' 'xdg-desktop-portal')
+depends=('obs-studio>=27' 'xdg-desktop-portal')
makedepends=('meson' 'git')
conflicts=("${pkgname%%-git}")
provides=("${pkgname%%-git}")
-source=("git+$url")
-sha256sums=('SKIP')
+source=("git+$url"
+ "fix-gs_texture_create_from_dmabuf.patch")
+sha256sums=('SKIP'
+ '056fa69ca93b8203a72b7ee5d41ad7fca99fcb1af81a3c61e37b4d699961b18c')
+
+prepare() {
+ cd ${pkgname%%-git}
+ # Add missing parameter to gs_texture_create_from_dmabuf function call
+ # to fix https://gitlab.gnome.org/feaneron/obs-xdg-portal/-/issues/30,
+ # see:
+ # https://gitlab.gnome.org/feaneron/obs-xdg-portal/-/merge_requests/15
+ git apply "$srcdir/fix-gs_texture_create_from_dmabuf.patch"
+}
pkgver() {
cd ${pkgname%%-git}
diff --git a/fix-gs_texture_create_from_dmabuf.patch b/fix-gs_texture_create_from_dmabuf.patch
new file mode 100644
index 000000000000..89afd79f3143
--- /dev/null
+++ b/fix-gs_texture_create_from_dmabuf.patch
@@ -0,0 +1,25 @@
+From db686257c41dfd0d7252271c5fe909352c994523 Mon Sep 17 00:00:00 2001
+From: Lucas Hazel <lucas@hazel.id.au>
+Date: Fri, 7 May 2021 15:29:12 +1000
+Subject: [PATCH] add missing parameter to gs_texture_create_from_dmabuf
+ function call
+
+---
+ pipewire.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/pipewire.c b/pipewire.c
+index 1898b1b..b592bb3 100644
+--- a/pipewire.c
++++ b/pipewire.c
+@@ -349,6 +349,7 @@ on_process_cb (void *user_data)
+ xdg->texture =
+ gs_texture_create_from_dmabuf (xdg->format.info.raw.size.width,
+ xdg->format.info.raw.size.height,
++ xdg->format.info.raw.format,
+ obs_format,
+ 1,
+ fds,
+--
+GitLab
+