summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarek Kubica2013-09-16 17:03:47 +0200
committerMarek Kubica2013-09-16 17:03:47 +0200
commit4243790d6c898316b9ea8ad39be57a9e3b2823ec (patch)
tree86c53487a0876260fc070cb8ca9bd3ef9b690f58
downloadaur-4243790d6c898316b9ea8ad39be57a9e3b2823ec.tar.gz
Initial import of 0.8.4-2 package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..24f7f5dc5e7d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ocaml-camomile
+ pkgdesc = Comprehensive Unicode library for OCaml
+ pkgver = 0.8.4
+ pkgrel = 2
+ url = https://github.com/yoriyuki/Camomile
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = ocaml
+ depends = ocaml-findlib>=1.2.3
+ options = !strip
+ options = !makeflags
+ source = https://github.com/downloads/yoriyuki/camomile/camomile-0.8.4.tar.bz2
+ md5sums = 389f1a7e5c2a634fbb3ea6f764d77bd3
+
+pkgname = ocaml-camomile
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91ba2076d407
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Serge Zirukin <ftrvxmtrx@gmail.com>
+pkgname=ocaml-camomile
+pkgver=0.8.4
+pkgrel=2
+pkgdesc="Comprehensive Unicode library for OCaml"
+arch=('i686' 'x86_64')
+url="https://github.com/yoriyuki/Camomile"
+license=('LGPL')
+depends=('ocaml' 'ocaml-findlib>=1.2.3')
+install=
+source=(https://github.com/downloads/yoriyuki/${pkgname/ocaml-}/${pkgname/ocaml-/}-$pkgver.tar.bz2)
+md5sums=('389f1a7e5c2a634fbb3ea6f764d77bd3')
+options=(!strip !makeflags)
+
+build() {
+ cd "$srcdir/${pkgname/ocaml-/}-$pkgver"
+
+ ./configure --prefix=/usr
+ mkdir -p $pkgdir$(ocamlfind printconf destdir) || return 1
+ mkdir -p $pkgdir/usr/bin
+ sed -i -e 's|ocamlfind install|ocamlfind install -destdir '$pkgdir$(ocamlfind printconf destdir)'|' Makefile || return 1
+ make || return 1
+ make DATADIR="$pkgdir/usr/share" BINDIR="$pkgdir/usr/bin" install
+ install -Dm 644 COPYING $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
+