summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2022-06-14 20:31:02 +0200
committerDaniel Peukert2022-06-14 20:31:02 +0200
commitee2a38ea0585c65b55d7d3293e69e79f3f06ac6e (patch)
tree7f1fb20edc6e76382f6c72fc3f2c368c2e7d1d2b
parentc9bc1e0600dba2fdc35eb23b80e483ca6b711d30 (diff)
downloadaur-ocaml-cinaps.tar.gz
Fix dun calls, sha256 -> sha512
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e62c37cdf604..6bb116a7e40c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-cinaps
pkgdesc = Trivial Metaprogramming tool using the OCaml toplevel
pkgver = 0.15.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/ocaml-ppx/cinaps
arch = x86_64
arch = i686
@@ -15,7 +15,7 @@ pkgbase = ocaml-cinaps
depends = ocaml>=4.04.0
depends = ocaml-re>=1.8.0
options = !strip
- source = ocaml-cinaps-0.15.1-2.tar.gz::https://github.com/ocaml-ppx/cinaps/archive/v0.15.1.tar.gz
- sha256sums = 1be18e70f5d8a6b03566c3619b62836a26094fc7208fde46ab7b32ee64116170
+ source = ocaml-cinaps-0.15.1-3.tar.gz::https://github.com/ocaml-ppx/cinaps/archive/v0.15.1.tar.gz
+ sha512sums = ca53a9da8aa71ce7cddf7e24778e9c4d3f3e5784209da85a5a6b2d5af83cd8ad769fbe3009d2757ebf4a25ca39d76af00ebc693b1b01c3b53c8775ea479123a5
pkgname = ocaml-cinaps
diff --git a/PKGBUILD b/PKGBUILD
index 12b4f4f7cdd7..9dc42319317d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_projectname='cinaps'
pkgname="ocaml-$_projectname"
pkgver='0.15.1'
-pkgrel='2'
+pkgrel='3'
pkgdesc='Trivial Metaprogramming tool using the OCaml toplevel'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/ocaml-ppx/$_projectname"
@@ -12,7 +12,7 @@ makedepends=('dune>=2.0.0')
checkdepends=('ocaml-ppx_jane')
options=('!strip')
source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('1be18e70f5d8a6b03566c3619b62836a26094fc7208fde46ab7b32ee64116170')
+sha512sums=('ca53a9da8aa71ce7cddf7e24778e9c4d3f3e5784209da85a5a6b2d5af83cd8ad769fbe3009d2757ebf4a25ca39d76af00ebc693b1b01c3b53c8775ea479123a5')
_sourcedirectory="$_projectname-$pkgver"
@@ -28,11 +28,7 @@ check() {
package() {
cd "$srcdir/$_sourcedirectory/"
- DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml' --release --verbose
-
- install -dm755 "$pkgdir/usr/share/doc/$pkgname"
- mv "$pkgdir/usr/doc/$_projectname/"* "$pkgdir/usr/share/doc/$pkgname/"
- rm -r "$pkgdir/usr/doc/"
+ DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir '/usr/lib/ocaml' --docdir '/usr/share/doc' --mandir '/usr/share/man' --release --verbose
install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"