summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Letan2024-01-21 16:47:55 +0100
committerThomas Letan2024-01-21 16:47:55 +0100
commiteb2d03238d2641c344c5cf01a7a44eb277d4ef20 (patch)
treea40198cf01be59e23b3165e6607fd9ec2d34e17b
downloadaur-ocaml-ezjsonm-encoding.tar.gz
ocaml-ezjsonm-encoding.2.0.0
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e752d025aaa3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ocaml-ezjsonm-encoding
+ pkgdesc = Encoding combinators a la Data_encoding for Ezjsonm
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/lthms/ezjsonm-encoding
+ arch = x86_64
+ license = MPL2
+ makedepends = dune
+ depends = ocaml
+ depends = ocaml-ezjsonm
+ options = !strip
+ source = ocaml-ezjsonm-encoding-2.0.0.tbz::https://github.com/lthms/ezjsonm-encoding/releases/download/2.0.0/ezjsonm-encoding-2.0.0.tbz
+ sha512sums = 6ed40eabfc335e4619873dae832c5ce0e35acd425014adc13f47e39d980c5972a2490c3781d4edfb4e4ed829f64a7831890a296ae13c8d0c208f5972e44a48d5
+
+pkgname = ocaml-ezjsonm-encoding
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f98a7e4d43b5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+ocaml-*.pkg.tar.zst
+ocaml-*.tbz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..339f9f8b903e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Thomas Letan <lthms@soap.coffee>
+
+_projectname=ezjsonm-encoding
+pkgname=ocaml-$_projectname
+pkgver=2.0.0
+pkgrel=1
+license=('MPL2')
+arch=('x86_64')
+pkgdesc="Encoding combinators a la Data_encoding for Ezjsonm"
+url="https://github.com/lthms/$_projectname"
+depends=('ocaml' 'ocaml-ezjsonm')
+makedepends=('dune')
+source=(
+ "$pkgname-$pkgver.tbz::https://github.com/lthms/$_projectname/releases/download/$pkgver/$_projectname-$pkgver.tbz"
+)
+options=('!strip')
+sha512sums=(
+ "6ed40eabfc335e4619873dae832c5ce0e35acd425014adc13f47e39d980c5972a2490c3781d4edfb4e4ed829f64a7831890a296ae13c8d0c208f5972e44a48d5"
+)
+
+build() {
+ cd "${srcdir}/$_projectname-${pkgver}"
+ # The "-p" flag is necessary for release builds, see the Dune manpage. Dune will complain if you forget some packages.
+ dune build -p $_projectname
+}
+
+package() {
+ cd "${srcdir}/$_projectname-${pkgver}"
+ DESTDIR="${pkgdir}" dune install $_projectname --prefix "/usr" --libdir "/usr/lib/ocaml" --docdir "/usr/share/doc"
+}