summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2022-10-29 10:42:54 +0200
committerDaniel Peukert2022-10-29 10:42:54 +0200
commit96393e372b118376ca3fdf10a229262102ffb0c7 (patch)
tree5f0fb22c6dae344956f0001d746703bac712d458
parent3c9142b742bf721dd57d11b8d4360001598b1038 (diff)
downloadaur-96393e372b118376ca3fdf10a229262102ffb0c7.tar.gz
Update ocaml-fileutils to 0.6.4
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD19
-rw-r--r--fix-ounit-name.diff10
3 files changed, 10 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d2890855bbf..5c19a477017c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-fileutils
pkgdesc = OCaml API to manipulate real files and filenames
- pkgver = 0.6.3
- pkgrel = 2
+ pkgver = 0.6.4
+ pkgrel = 1
url = https://github.com/gildor478/ocaml-fileutils
arch = x86_64
arch = i686
@@ -13,11 +13,10 @@ pkgbase = ocaml-fileutils
checkdepends = ocaml-ounit>=2.0.0
makedepends = dune>=1.11.0
depends = ocaml>=4.03.0
+ depends = ocaml-seq
depends = ocaml-stdlib-shims
options = !strip
- source = ocaml-fileutils-0.6.3-2.tar.gz::https://github.com/gildor478/ocaml-fileutils/archive/v0.6.3.tar.gz
- source = fix-ounit-name.diff
- sha512sums = 491c01347714b9caf69e184be7e031d82d3602b91ce52c5c995b25897090d9af79b2ae058ff92b91ab31b44dd1fdf15fbe1a428d2f3a50872d3f0f7689a64e8c
- sha512sums = e68fcb4cd54603573d7175579d7d78045d5b9faf6c3c3dc149f5d6908e301e6518bad41a8793df666b3441331d275040342e5bcb6012851e884b9eeca8f028d9
+ source = ocaml-fileutils-0.6.4-1.tar.gz::https://github.com/gildor478/ocaml-fileutils/archive/v0.6.4.tar.gz
+ sha512sums = fed41c0c98bd9a2dde18335f0c7fd721b609f936001424eff200bca058146af55134f1d245b143bd211ece37bc036b3308528b193a6b578735b27891181f07e1
pkgname = ocaml-fileutils
diff --git a/PKGBUILD b/PKGBUILD
index 9bdd59beeeaf..0367877af1ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,30 +6,21 @@
# Contributor: Thomas Pani <thomas.pani@gmail.com>
# Contributor: crave <crave@infinity>
pkgname='ocaml-fileutils'
-pkgver='0.6.3'
-pkgrel='2'
+pkgver='0.6.4'
+pkgrel='1'
pkgdesc='OCaml API to manipulate real files and filenames'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/gildor478/$pkgname"
license=('custom:LGPL2.1 with linking exception')
-depends=('ocaml>=4.03.0' 'ocaml-stdlib-shims')
+depends=('ocaml>=4.03.0' 'ocaml-seq' 'ocaml-stdlib-shims')
makedepends=('dune>=1.11.0')
checkdepends=('ocaml-ounit>=2.0.0')
options=('!strip')
-source=(
- "$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz"
- 'fix-ounit-name.diff'
-)
-sha512sums=('491c01347714b9caf69e184be7e031d82d3602b91ce52c5c995b25897090d9af79b2ae058ff92b91ab31b44dd1fdf15fbe1a428d2f3a50872d3f0f7689a64e8c'
- 'e68fcb4cd54603573d7175579d7d78045d5b9faf6c3c3dc149f5d6908e301e6518bad41a8793df666b3441331d275040342e5bcb6012851e884b9eeca8f028d9')
+source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha512sums=('fed41c0c98bd9a2dde18335f0c7fd721b609f936001424eff200bca058146af55134f1d245b143bd211ece37bc036b3308528b193a6b578735b27891181f07e1')
_sourcedirectory="$pkgname-$pkgver"
-prepare() {
- cd "$srcdir/$_sourcedirectory/"
- patch --forward -p1 < "$srcdir/fix-ounit-name.diff"
-}
-
build() {
cd "$srcdir/$_sourcedirectory/"
dune build --release --verbose
diff --git a/fix-ounit-name.diff b/fix-ounit-name.diff
deleted file mode 100644
index 658cd8b33cbf..000000000000
--- a/fix-ounit-name.diff
+++ /dev/null
@@ -1,10 +0,0 @@
-diff --git a/test/dune b/test/dune
-index 38ebc4e..eecfe54 100644
---- a/test/dune
-+++ b/test/dune
-@@ -6,4 +6,4 @@
- (test
- (name test)
- (modules test)
-- (libraries fileutils fileutils_str oUnit stdlib-shims))
-+ (libraries fileutils fileutils_str ounit2 stdlib-shims))