summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Letan2024-01-21 15:04:24 +0100
committerThomas Letan2024-01-21 15:04:24 +0100
commit8039981ee3e9221f9e63272307cfe66c9a7607a8 (patch)
tree726df46c1bc713ef31f1bf059bb8fa125896653b
downloadaur-ocaml-hex.tar.gz
ocaml-hex.1.5.0
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..433c8408705b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ocaml-hex
+ pkgdesc = Hexadecimal converter
+ pkgver = 1.5.0
+ pkgrel = 1
+ url = https://github.com/mirage/ocaml-hex
+ arch = x86_64
+ license = custom:ISC
+ makedepends = dune
+ depends = ocaml
+ depends = ocaml-cstruct
+ options = !strip
+ source = ocaml-hex-1.5.0.tbz::https://github.com/mirage/ocaml-hex/releases/download/v1.5.0/hex-1.5.0.tbz
+ sha512sums = baa09b47a90f0a54ad2becfb272f0674219e4fc0c03559deff26aaf13ccd59258b31bf98e56c44a5a8fa03437e3eba2bf5f0cd76e52d184d26cfb1170c490462
+
+pkgname = ocaml-hex
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b2570d3d538c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+ocaml-hex-*.pkg.tar.zst
+ocaml-hex-*.tbz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef06b89970ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Thomas Letan <lthms@soap.coffee>
+
+pkgname=ocaml-hex
+pkgver=1.5.0
+pkgrel=1
+license=('custom:ISC')
+arch=('x86_64')
+pkgdesc="Hexadecimal converter"
+url="https://github.com/mirage/ocaml-hex"
+depends=('ocaml' 'ocaml-cstruct')
+makedepends=('dune')
+source=(
+ "$pkgname-$pkgver.tbz::https://github.com/mirage/ocaml-hex/releases/download/v$pkgver/hex-$pkgver.tbz"
+)
+options=('!strip')
+sha512sums=(
+ "baa09b47a90f0a54ad2becfb272f0674219e4fc0c03559deff26aaf13ccd59258b31bf98e56c44a5a8fa03437e3eba2bf5f0cd76e52d184d26cfb1170c490462"
+)
+
+build() {
+ cd "${srcdir}/hex-${pkgver}"
+ # The "-p" flag is necessary for release builds, see the Dune manpage. Dune will complain if you forget some packages.
+ dune build -p hex
+}
+
+package() {
+ cd "${srcdir}/hex-${pkgver}"
+ DESTDIR="${pkgdir}" dune install hex --prefix "/usr" --libdir "/usr/lib/ocaml" --docdir "/usr/share/doc"
+}