summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2023-05-30 14:34:00 +0200
committerDaniel Peukert2023-05-30 14:34:00 +0200
commit35c2ee772aaa2b8f9214a0910539bdece6418a7c (patch)
tree7d0f4ad3df00ca49c845b65b422202350870ef6d
parent9ec9ecb8cad4312c7dfeb4d0e0065aa7305e2665 (diff)
downloadaur-35c2ee772aaa2b8f9214a0910539bdece6418a7c.tar.gz
Add lwt_domain subpackage to ocaml-lwt, add its dependencies
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
2 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82f7cccc9793..bb7b1de7a87d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-lwt
pkgdesc = A library for cooperative threads in OCaml
pkgver = 5.6.1
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/ocsigen/lwt
arch = x86_64
arch = aarch64
@@ -11,12 +11,15 @@ pkgbase = ocaml-lwt
depends = libev
depends = dune>=1.8.0
depends = ocaml>=4.08.0
+ depends = ocaml-domainslib>=0.5.0
depends = ocaml-luv
depends = ocaml-ocplib-endian
depends = ocaml-ppxlib>=0.16.0
depends = ocaml-react>=1.0.0
options = !strip
- source = ocaml-lwt-5.6.1-3.tar.gz::https://github.com/ocsigen/lwt/archive/5.6.1.tar.gz
+ source = ocaml-lwt-5.6.1-4.tar.gz::https://github.com/ocsigen/lwt/archive/5.6.1.tar.gz
+ source = ocaml-lwt-5.6.1-4-domainslib-compatibility.diff::https://github.com/ocsigen/lwt/commit/69bd080c843d457eb6543ab9e8a4c88da11f7939.diff
sha512sums = 698875bd3bfcd5baa47eb48e412f442d289f9972421321541860ebe110b9af1949c3fbc253768495726ec547fe4ba25483cd97ff39bc668496fba95b2ed9edd8
+ sha512sums = 3416dafee3913c71ec90fa3b966b2afb936188ba4cddc7590c36561336c72a0e997536f67651fe33ae1b7c7b5e05a82341fec1d60b9e089e426b6d95f66febc2
pkgname = ocaml-lwt
diff --git a/PKGBUILD b/PKGBUILD
index 374b6614785f..8f61839a6a41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,24 +6,31 @@
_projectname='lwt'
pkgname="ocaml-$_projectname"
pkgver='5.6.1'
-pkgrel='3'
+pkgrel='4'
pkgdesc='A library for cooperative threads in OCaml'
# If you're running on aarch64, you have to add it to the arch array of the cppo, ocaml-biniou, ocaml-easy-format and ocaml-yojson AUR dependencies
arch=('x86_64' 'aarch64')
url="https://github.com/ocsigen/$_projectname"
license=('MIT')
-depends=('libev' 'dune>=1.8.0' 'ocaml>=4.08.0' 'ocaml-luv' 'ocaml-ocplib-endian' 'ocaml-ppxlib>=0.16.0' 'ocaml-react>=1.0.0')
+depends=('libev' 'dune>=1.8.0' 'ocaml>=4.08.0' 'ocaml-domainslib>=0.5.0' 'ocaml-luv' 'ocaml-ocplib-endian' 'ocaml-ppxlib>=0.16.0' 'ocaml-react>=1.0.0')
makedepends=('cppo>=1.1.0')
checkdepends=('ocaml-ppx_let')
options=('!strip')
-source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz")
-sha512sums=('698875bd3bfcd5baa47eb48e412f442d289f9972421321541860ebe110b9af1949c3fbc253768495726ec547fe4ba25483cd97ff39bc668496fba95b2ed9edd8')
+source=(
+ "$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz"
+ "$pkgname-$pkgver-$pkgrel-domainslib-compatibility.diff::$url/commit/69bd080c843d457eb6543ab9e8a4c88da11f7939.diff"
+)
+sha512sums=('698875bd3bfcd5baa47eb48e412f442d289f9972421321541860ebe110b9af1949c3fbc253768495726ec547fe4ba25483cd97ff39bc668496fba95b2ed9edd8'
+ '3416dafee3913c71ec90fa3b966b2afb936188ba4cddc7590c36561336c72a0e997536f67651fe33ae1b7c7b5e05a82341fec1d60b9e089e426b6d95f66febc2')
_sourcedirectory="$_projectname-$pkgver"
prepare() {
cd "$srcdir/$_sourcedirectory/"
+ # Fix domainslib 0.5.0 compatibility
+ patch --forward -p1 < "../$pkgname-$pkgver-$pkgrel-domainslib-compatibility.diff"
+
# This test breaks for some people but not for others,
# see comments from oriba, crave and pha-qu on the AUR page
sed -i '/test_mcast "mcast-join-loop"/d' 'test/unix/test_mcast.ml'