summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-04-25 15:10:55 +0200
committerDaniel Peukert2020-04-25 15:10:55 +0200
commit500efa481c3f065ed1508af2b74ee7f5f38cd94f (patch)
tree3cb9a7180af281f8ac174dcc206edf7c4355bd41
parenta956880d2cd4720651e8c0966c6bdfa8a7ebba95 (diff)
downloadaur-500efa481c3f065ed1508af2b74ee7f5f38cd94f.tar.gz
Updated ocaml-lwt to 5.3.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
-rw-r--r--no-bisect_ppx.diff10
3 files changed, 12 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9adc1ca1500a..c947e141ed4f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-lwt
pkgdesc = A library for cooperative threads in OCaml
- pkgver = 5.2.0
- pkgrel = 2
+ pkgver = 5.3.0
+ pkgrel = 1
url = https://github.com/ocsigen/lwt
arch = x86_64
arch = i686
@@ -11,7 +11,8 @@ pkgbase = ocaml-lwt
arch = aarch64
license = MIT
makedepends = cppo>=1.1.0
- makedepends = dune>=1.7.0
+ makedepends = dune>=1.8.0
+ depends = dune-configurator
depends = libev
depends = ocaml>=4.02.0
depends = ocaml-mmap>=1.1.0
@@ -22,9 +23,7 @@ pkgbase = ocaml-lwt
depends = ocaml-ppx_tools_versioned>=5.3.0
depends = ocaml-react>=1.0.0
options = !strip
- source = ocaml-lwt-5.2.0-2.tar.gz::https://github.com/ocsigen/lwt/archive/5.2.0.tar.gz
- source = no-bisect_ppx.diff
- sha256sums = 97c12b3da3d0db019dbdb97950b72f6fd1226ded7519c36ebfe2787574a9b132
- sha256sums = 23de90bf80e7985b5749043c2dddd913bf9a1c3f08fe7a8a86b5e542aa46e279
+ source = ocaml-lwt-5.3.0-1.tar.gz::https://github.com/ocsigen/lwt/archive/5.3.0.tar.gz
+ sha256sums = 38ce928378a07b685f4606b60cbe37c26ef93ccb3e808c218e7d34ece9e659ad
pkgname = ocaml-lwt
diff --git a/PKGBUILD b/PKGBUILD
index d966b2a90348..85443312eac8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,32 +5,20 @@
# Contributor: serp <serp256 at gmail dot com>
_projectname='lwt'
pkgname="ocaml-$_projectname"
-pkgver='5.2.0'
-pkgrel='2'
+pkgver='5.3.0'
+pkgrel='1'
pkgdesc='A library for cooperative threads in OCaml'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/ocsigen/lwt"
license=('MIT')
-depends=('libev' 'ocaml>=4.02.0' 'ocaml-mmap>=1.1.0' 'ocaml-ocplib-endian' 'ocaml-result' 'ocaml-seq' 'ocaml-migrate-parsetree>=1.5.0' 'ocaml-ppx_tools_versioned>=5.3.0' 'ocaml-react>=1.0.0')
-makedepends=('cppo>=1.1.0' 'dune>=1.7.0')
+depends=('dune-configurator' 'libev' 'ocaml>=4.02.0' 'ocaml-mmap>=1.1.0' 'ocaml-ocplib-endian' 'ocaml-result' 'ocaml-seq' 'ocaml-migrate-parsetree>=1.5.0' 'ocaml-ppx_tools_versioned>=5.3.0' 'ocaml-react>=1.0.0')
+makedepends=('cppo>=1.1.0' 'dune>=1.8.0')
options=('!strip')
-source=(
- "$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz"
- 'no-bisect_ppx.diff'
-)
-sha256sums=('97c12b3da3d0db019dbdb97950b72f6fd1226ded7519c36ebfe2787574a9b132'
- '23de90bf80e7985b5749043c2dddd913bf9a1c3f08fe7a8a86b5e542aa46e279')
+source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('38ce928378a07b685f4606b60cbe37c26ef93ccb3e808c218e7d34ece9e659ad')
_sourcedirectory="$_projectname-$pkgver"
-prepare() {
- cd "$srcdir/$_sourcedirectory/"
- # This is currently the only way to not have a runtime bisect_ppx dep
- # https://github.com/aantron/bisect_ppx#dune
- # https://github.com/ocaml/dune/issues/57
- patch --forward -p1 < '../no-bisect_ppx.diff'
-}
-
build() {
cd "$srcdir/$_sourcedirectory/"
LWT_DISCOVER_ARGUMENTS='--use-libev true' dune build -p "$_projectname,${_projectname}_ppx,${_projectname}_react" --verbose
diff --git a/no-bisect_ppx.diff b/no-bisect_ppx.diff
deleted file mode 100644
index 86bd8c0b0ce5..000000000000
--- a/no-bisect_ppx.diff
+++ /dev/null
@@ -1,10 +0,0 @@
-diff --git a/src/react/dune b/src/react/dune
-index 318cb3c75..7d1680b6c 100644
---- a/src/react/dune
-+++ b/src/react/dune
-@@ -10,5 +10,4 @@
- (synopsis "Reactive programming helpers for Lwt")
- (wrapped false)
- (libraries lwt react)
-- (preprocess (pps bisect_ppx --conditional))
- (flags (:standard -w +A)))