summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2017-03-19 16:42:31 +0100
committerJakob Gahde2017-03-19 16:42:31 +0100
commit7c194cd0f588df4ce2734c18624ab3918e146ea4 (patch)
tree1d01ab75c96a64b4470756f1a8bf7940a5f5cba5
parent32cbe28267f457c2ae5e6a38bbb723171627567f (diff)
downloadaur-7c194cd0f588df4ce2734c18624ab3918e146ea4.tar.gz
ocaml-lwt 2.7.0-1: New version
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9bc6a59bddb4..051c05586c3b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,28 @@
# Generated by mksrcinfo v8
-# Sun Oct 30 09:59:53 UTC 2016
+# Sun Mar 19 15:40:02 UTC 2017
pkgbase = ocaml-lwt
pkgdesc = A library for cooperative threads in OCaml
- pkgver = 2.6.0
+ pkgver = 2.7.0
pkgrel = 1
url = http://ocsigen.org/lwt/
arch = i686
arch = x86_64
license = custom:LGPL with OpenSSL linking exception
+ makedepends = ocamlbuild
makedepends = ocaml-findlib
depends = ocaml
depends = camlp4
depends = ocaml-ppx_tools
depends = ocaml-react
+ depends = ocaml-result
depends = ocaml-ssl
depends = libev
depends = glib2
options = !strip
options = !makeflags
options = staticlibs
- source = https://github.com/ocsigen/lwt/archive/2.6.0.tar.gz
- sha256sums = bf7ff0d1c3aa8230f00f55cac149cd335a1a1183b4661c9b098ba8a2d0037cbd
+ source = https://github.com/ocsigen/lwt/archive/2.7.0.tar.gz
+ sha256sums = 00419834e0c5601b3fee6ca9efb0e10ab797a9ff8f695bf2434d89395b7252ec
pkgname = ocaml-lwt
diff --git a/PKGBUILD b/PKGBUILD
index c1ab711e74de..0b4ba3917f98 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,17 +5,17 @@
_pkgname=lwt
pkgname=ocaml-${_pkgname}
-pkgver=2.6.0
+pkgver=2.7.0
pkgrel=1
pkgdesc="A library for cooperative threads in OCaml"
arch=('i686' 'x86_64')
url="http://ocsigen.org/${_pkgname}/"
license=('custom:LGPL with OpenSSL linking exception')
-depends=('ocaml' 'camlp4' 'ocaml-ppx_tools' 'ocaml-react' 'ocaml-ssl' 'libev' 'glib2')
-makedepends=('ocaml-findlib')
-source=(https://github.com/ocsigen/${_pkgname}/archive/$pkgver.tar.gz)
-sha256sums=('bf7ff0d1c3aa8230f00f55cac149cd335a1a1183b4661c9b098ba8a2d0037cbd')
-options=(!strip !makeflags staticlibs)
+depends=('ocaml' 'camlp4' 'ocaml-ppx_tools' 'ocaml-react' 'ocaml-result' 'ocaml-ssl' 'libev' 'glib2')
+makedepends=('ocamlbuild' 'ocaml-findlib')
+source=("https://github.com/ocsigen/${_pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('00419834e0c5601b3fee6ca9efb0e10ab797a9ff8f695bf2434d89395b7252ec')
+options=('!strip' '!makeflags' 'staticlibs')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"