summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2023-08-22 00:46:51 +0200
committerDaniel Peukert2023-08-22 00:46:51 +0200
commit921805cf425477037348292fda494029d6771b37 (patch)
tree4c396e035411184c5f01f2310178b63953954658
parent35c2ee772aaa2b8f9214a0910539bdece6418a7c (diff)
downloadaur-921805cf425477037348292fda494029d6771b37.tar.gz
Update ocaml-lwt to 5.7.0, add ocaml-lwt_domain
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD27
2 files changed, 15 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb7b1de7a87d..91a731fe79ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-lwt
pkgdesc = A library for cooperative threads in OCaml
- pkgver = 5.6.1
- pkgrel = 4
+ pkgver = 5.7.0
+ pkgrel = 1
url = https://github.com/ocsigen/lwt
arch = x86_64
arch = aarch64
@@ -11,15 +11,11 @@ pkgbase = ocaml-lwt
depends = libev
depends = dune>=1.8.0
depends = ocaml>=4.08.0
- depends = ocaml-domainslib>=0.5.0
- depends = ocaml-luv
depends = ocaml-ocplib-endian
depends = ocaml-ppxlib>=0.16.0
depends = ocaml-react>=1.0.0
options = !strip
- source = ocaml-lwt-5.6.1-4.tar.gz::https://github.com/ocsigen/lwt/archive/5.6.1.tar.gz
- source = ocaml-lwt-5.6.1-4-domainslib-compatibility.diff::https://github.com/ocsigen/lwt/commit/69bd080c843d457eb6543ab9e8a4c88da11f7939.diff
- sha512sums = 698875bd3bfcd5baa47eb48e412f442d289f9972421321541860ebe110b9af1949c3fbc253768495726ec547fe4ba25483cd97ff39bc668496fba95b2ed9edd8
- sha512sums = 3416dafee3913c71ec90fa3b966b2afb936188ba4cddc7590c36561336c72a0e997536f67651fe33ae1b7c7b5e05a82341fec1d60b9e089e426b6d95f66febc2
+ source = ocaml-lwt-5.7.0.tar.gz::https://github.com/ocsigen/lwt/archive/5.7.0.tar.gz
+ sha512sums = 42e629920783428673b99c9d7a639237c9e6b35079b5d907bc67e7ea506acf9edadc48cec580bdcfd2410ed9412bf5e6bcc8b09de2fa7d35ce1490973d05ddd1
pkgname = ocaml-lwt
diff --git a/PKGBUILD b/PKGBUILD
index 8f61839a6a41..93537a62e6ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,40 +5,31 @@
# Contributor: serp <serp256 at gmail dot com>
_projectname='lwt'
pkgname="ocaml-$_projectname"
-pkgver='5.6.1'
-pkgrel='4'
+pkgver='5.7.0'
+pkgrel='1'
pkgdesc='A library for cooperative threads in OCaml'
-# If you're running on aarch64, you have to add it to the arch array of the cppo, ocaml-biniou, ocaml-easy-format and ocaml-yojson AUR dependencies
arch=('x86_64' 'aarch64')
url="https://github.com/ocsigen/$_projectname"
license=('MIT')
-depends=('libev' 'dune>=1.8.0' 'ocaml>=4.08.0' 'ocaml-domainslib>=0.5.0' 'ocaml-luv' 'ocaml-ocplib-endian' 'ocaml-ppxlib>=0.16.0' 'ocaml-react>=1.0.0')
+depends=('libev' 'dune>=1.8.0' 'ocaml>=4.08.0' 'ocaml-ocplib-endian' 'ocaml-ppxlib>=0.16.0' 'ocaml-react>=1.0.0')
makedepends=('cppo>=1.1.0')
checkdepends=('ocaml-ppx_let')
options=('!strip')
-source=(
- "$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz"
- "$pkgname-$pkgver-$pkgrel-domainslib-compatibility.diff::$url/commit/69bd080c843d457eb6543ab9e8a4c88da11f7939.diff"
-)
-sha512sums=('698875bd3bfcd5baa47eb48e412f442d289f9972421321541860ebe110b9af1949c3fbc253768495726ec547fe4ba25483cd97ff39bc668496fba95b2ed9edd8'
- '3416dafee3913c71ec90fa3b966b2afb936188ba4cddc7590c36561336c72a0e997536f67651fe33ae1b7c7b5e05a82341fec1d60b9e089e426b6d95f66febc2')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha512sums=('42e629920783428673b99c9d7a639237c9e6b35079b5d907bc67e7ea506acf9edadc48cec580bdcfd2410ed9412bf5e6bcc8b09de2fa7d35ce1490973d05ddd1')
_sourcedirectory="$_projectname-$pkgver"
prepare() {
cd "$srcdir/$_sourcedirectory/"
- # Fix domainslib 0.5.0 compatibility
- patch --forward -p1 < "../$pkgname-$pkgver-$pkgrel-domainslib-compatibility.diff"
-
- # This test breaks for some people but not for others,
- # see comments from oriba, crave and pha-qu on the AUR page
+ # This test breaks for some people but not for others, see comments from oriba, crave and pha-qu on the AUR page
sed -i '/test_mcast "mcast-join-loop"/d' 'test/unix/test_mcast.ml'
}
build() {
cd "$srcdir/$_sourcedirectory/"
- LWT_DISCOVER_ARGUMENTS='--use-libev true' dune build --release --verbose
+ LWT_DISCOVER_ARGUMENTS='--use-libev true --use-pthread true --libev-default true --verbose' dune build --release --verbose
}
check() {
@@ -50,6 +41,10 @@ package() {
cd "$srcdir/$_sourcedirectory/"
DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir '/usr/lib/ocaml' --docdir '/usr/share/doc' --mandir '/usr/share/man' --release --verbose
+ for _folder in "$pkgdir/usr/share/doc/"*; do
+ mv "$_folder" "$pkgdir/usr/share/doc/ocaml-$(basename "$_folder")"
+ done
+
install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
}