summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ5lx2015-07-03 16:25:00 +0200
committerJ5lx2015-07-03 16:25:00 +0200
commitfa4e9031375fcfbb001f77ce2c7357fc949f5023 (patch)
tree564bc0bf5f04ce33f3cbcafc05257e1492a494bd
downloadaur-fa4e9031375fcfbb001f77ce2c7357fc949f5023.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD48
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4ff46f3b5b13
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = ocaml-lwt
+ pkgdesc = A library for cooperative threads in OCaml
+ pkgver = 2.4.8
+ pkgrel = 2
+ url = http://ocsigen.org/lwt/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = ocaml-findlib
+ depends = ocaml
+ depends = camlp4
+ depends = ocaml-react
+ depends = ocaml-ssl
+ depends = libev
+ depends = glib2
+ options = !strip
+ options = !makeflags
+ options = staticlibs
+ source = https://github.com/ocsigen/lwt/archive/2.4.8.tar.gz
+ sha256sums = cada92a1c7ce9c678adc67dfa0a8c51f582358e99bbe839ece2decd6866cfa38
+
+pkgname = ocaml-lwt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..97e59817c2c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+# Contributor: Serge Zirukin <ftrvxmtrx@gmail.com>
+# Contributor: Sergei Lebedev <superbobry@gmail.com
+# Contributor: serp <serp256 at gmail dot com>
+
+_pkgname=lwt
+pkgname=ocaml-${_pkgname}
+pkgver=2.4.8
+pkgrel=2
+pkgdesc="A library for cooperative threads in OCaml"
+arch=('i686' 'x86_64')
+url="http://ocsigen.org/${_pkgname}/"
+license=('LGPL')
+depends=('ocaml' 'camlp4' 'ocaml-react' 'ocaml-ssl' 'libev' 'glib2')
+makedepends=('ocaml-findlib')
+source=(https://github.com/ocsigen/${_pkgname}/archive/$pkgver.tar.gz)
+sha256sums=('cada92a1c7ce9c678adc67dfa0a8c51f582358e99bbe839ece2decd6866cfa38')
+options=(!strip !makeflags staticlibs)
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ echo '<src/top/*.*>: use_compiler_libs' >> _tags
+ # What requires what?
+ # --enable-glib glib2
+ # --enable-react ocaml-react
+ # --enable-ssl ocaml-ssl
+
+ ./configure --enable-react \
+ --enable-glib \
+ --enable-ssl \
+ --enable-camlp4 \
+ --disable-debug \
+ --prefix /usr \
+ --destdir $pkgdir
+ make
+}
+
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ export OCAMLFIND_DESTDIR="${pkgdir}/$(ocamlfind printconf destdir)"
+ mkdir -p "$OCAMLFIND_DESTDIR/stublibs"
+
+ make install
+ install -Dm 644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}