summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2017-06-06 14:09:36 +0200
committerJakob Gahde2017-06-06 14:09:36 +0200
commit2e7d38d5866999dc1740e91800f34cae1fd5ff5c (patch)
tree210103804b370aaf1ba05919e9656e6b192b996f
parente166c33673e4d14671239d50b67d8506191f4899 (diff)
downloadaur-ocaml-pa_structural_sexp.tar.gz
ocaml-pa_structural_sexp 113.00.00-1: PKGBUILD formatting tweaks
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c17e2883beeb..c21a912683f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,3 +1,5 @@
+# Generated by mksrcinfo v8
+# Tue Jun 6 12:08:50 UTC 2017
pkgbase = ocaml-pa_structural_sexp
pkgdesc = Industrial strength alternative to OCaml's standard library
pkgver = 113.00.00
diff --git a/PKGBUILD b/PKGBUILD
index 03d0dd66f1b3..c62b84cdc24a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,26 +3,26 @@
pkgname=ocaml-pa_structural_sexp
pkgver=113.00.00
pkgrel=1
-license=('Apache')
-arch=('i686' 'x86_64')
pkgdesc="Industrial strength alternative to OCaml's standard library"
+arch=('i686' 'x86_64')
url="https://github.com/janestreet/core"
+license=('Apache')
depends=('ocaml' 'camlp4' 'ocaml-sexplib' 'ocaml-type_conv')
makedepends=('ocaml-findlib')
-source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-${pkgver}.tar.gz")
options=('!strip')
+source=("https://ocaml.janestreet.com/ocaml-core/$(echo ${pkgver} | grep -Po "^[0-9]+\.[0-9]+")/files/${pkgname#ocaml-}-${pkgver}.tar.gz")
md5sums=('288c81277d521d938a46514b8e3fb623')
build() {
cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
-
+
./configure --prefix /usr
make
}
package() {
cd "${srcdir}/${pkgname#ocaml-}-${pkgver}"
-
+
export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
mkdir -p "${OCAMLFIND_DESTDIR}"
make install