summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2024-01-28 00:10:15 +0100
committerDaniel Peukert2024-01-28 00:10:15 +0100
commit44d6ece1a28be3c5202cb9fb78f34f312c333d80 (patch)
treeddcd88ffe458c3bb4c1250eb885b0d3a23d1f5a2
parent70ec62590930b5e19c4e50dff5c757f37ffb4d27 (diff)
downloadaur-ocaml-ppx_custom_printf.tar.gz
Sync pkgbuilds repo with AUR
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore28
-rw-r--r--PKGBUILD5
3 files changed, 17 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29479a739faa..79e30854b1a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,7 +13,7 @@ pkgbase = ocaml-ppx_custom_printf
depends = ocaml-ppx_sexp_conv>=0.16.0
depends = ocaml-ppxlib>=0.28.0
options = !strip
- source = ocaml-ppx_custom_printf-1:0.16.0-1.tar.gz::https://github.com/janestreet/ppx_custom_printf/archive/v0.16.0.tar.gz
+ source = ocaml-ppx_custom_printf-0.16.0.tar.gz::https://github.com/janestreet/ppx_custom_printf/archive/v0.16.0.tar.gz
sha512sums = 9fc09f5434ca41681f2c8c749aa0c3bae051ee3645e820e0e8a16ab0c1ab630b0c9b0af86ef282eade7020635a066729abb9b7d8d91c1667b9e9f1770131f8b7
pkgname = ocaml-ppx_custom_printf
diff --git a/.gitignore b/.gitignore
index 82b3c183d5d4..076d904dd4ac 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,14 +1,14 @@
-# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
-*.tar
-*.tar.*
-*.rpm
-*.jar
-*.exe
-*.msi
-*.zip
-*.tgz
-*.log
-*.log.*
-*.sig
-
-*/
+# Only exclude files from the root of the package repo, as some AUR helpers download sources into the directory of the repo,
+# which causes the gitignore file to apply to them too, which breaks some builds
+# Based on https://github.com/github/gitignore/blob/main/ArchLinuxPackages.gitignore
+/*.tar
+/*.tar.*
+/*.rpm
+/*.jar
+/*.exe
+/*.msi
+/*.zip
+/*.tgz
+/*.log
+/*.log.*
+/*.sig
diff --git a/PKGBUILD b/PKGBUILD
index 71abb9f87aec..061274133273 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,14 +6,13 @@ pkgver='0.16.0'
pkgrel='1'
epoch='1'
pkgdesc='Printf-style format-strings for user-defined string conversion'
-# If you're running on aarch64, you have to add it to the arch array of the ocaml-biniou, ocaml-easy-format and ocaml-yojson AUR dependencies
arch=('x86_64' 'aarch64')
url="https://github.com/janestreet/$_projectname"
license=('MIT')
depends=('ocaml>=4.14.0' 'ocaml-base>=0.16.0' 'ocaml-ppx_sexp_conv>=0.16.0' 'ocaml-ppxlib>=0.28.0')
makedepends=('dune>=2.0.0')
options=('!strip')
-source=("$pkgname-$epoch:$pkgver-$pkgrel.tar.gz::$url/archive/v$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
sha512sums=('9fc09f5434ca41681f2c8c749aa0c3bae051ee3645e820e0e8a16ab0c1ab630b0c9b0af86ef282eade7020635a066729abb9b7d8d91c1667b9e9f1770131f8b7')
_sourcedirectory="$_projectname-$pkgver"
@@ -28,5 +27,5 @@ package() {
DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir '/usr/lib/ocaml' --docdir '/usr/share/doc' --mandir '/usr/share/man' --release --verbose
install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
- ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
+ ln -sf "/usr/share/doc/$pkgname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/MIT"
}