summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2023-06-18 16:25:54 +0200
committerFabioLolix2023-06-18 16:25:54 +0200
commit3023068324abc487564b0fa71c91341d5af9c3a8 (patch)
tree14439b611837f8969f0eaf9ebf1706669e320d39
downloadaur-ocaml4-camlp-streams.tar.gz
init
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..41bc3ae4b924
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ocaml4-camlp-streams
+ pkgdesc = The Stream and Genlex libraries for use with Camlp4 and Camlp5.
+ pkgver = 5.0.1
+ pkgrel = 1
+ url = https://github.com/ocaml/camlp-streams
+ arch = x86_64
+ license = BSD
+ makedepends = dune
+ depends = ocaml4
+ depends = ocaml4-compiler-libs
+ options = !strip
+ source = camlp-streams-5.0.1.tar.gz::https://github.com/ocaml/camlp-streams/archive/v5.0.1.tar.gz
+ sha256sums = ad71f62406e9bb4e7fb5d4593ede2af6c68f8b0d96f25574446e142c3eb0d9a4
+
+pkgname = ocaml4-camlp-streams
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a1ee480fbcb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Jürgen Hötzel
+
+pkgname=ocaml4-camlp-streams
+pkgver=5.0.1
+pkgrel=1
+pkgdesc="The Stream and Genlex libraries for use with Camlp4 and Camlp5."
+arch=(x86_64)
+url="https://github.com/ocaml/camlp-streams"
+license=(BSD)
+makedepends=(dune)
+depends=(ocaml4 ocaml4-compiler-libs)
+options=(!strip)
+source=("camlp-streams-${pkgver}.tar.gz::https://github.com/ocaml/camlp-streams/archive/v${pkgver}.tar.gz")
+sha256sums=('ad71f62406e9bb4e7fb5d4593ede2af6c68f8b0d96f25574446e142c3eb0d9a4')
+
+build() {
+ cd "${srcdir}/camlp-streams-${pkgver}"
+ dune build
+}
+
+package() {
+ cd "${srcdir}/camlp-streams-${pkgver}"
+ DESTDIR="${pkgdir}" dune install --prefix "/usr" --libdir="$(ocamlc -where)"
+
+ install -dm755 "${pkgdir}/usr/share/"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
+
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}