summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2023-06-18 16:26:35 +0200
committerFabioLolix2023-06-18 16:26:35 +0200
commit10fd147688c8c91d19dd38228c6d78b6113a523c (patch)
treeee850c66a51f1be38ce48dffc2cb50ec3b0e7f28
downloadaur-ocaml4-num.tar.gz
init
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0aec86003a04
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ocaml4-num
+ pkgdesc = Library for arbitrary-precision integer and rational arithmetic that used to be part of the OCaml core distribution
+ pkgver = 1.4
+ pkgrel = 1
+ url = https://github.com/ocaml/num
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = ocaml4-findlib
+ depends = ocaml4
+ options = !strip
+ options = !makeflags
+ source = ocaml4-num-1.4.tar.gz::https://github.com/ocaml/num/archive/v1.4.tar.gz
+ sha512sums = 0cc9be8ad95704bb683b4bf6698bada1ee9a40dc05924b72adc7b969685c33eeb68ccf174cc09f6a228c48c18fe94af06f28bebc086a24973a066da620db8e6f
+
+pkgname = ocaml4-num
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba579e154abc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Konstantin Gizdov <arch at kge dot pw>
+# Contributor: Baptiste Jonglez <archlinux at bitsofnetworks dot org>
+
+pkgname=ocaml4-num
+pkgver=1.4
+pkgrel=1
+pkgdesc="Library for arbitrary-precision integer and rational arithmetic that used to be part of the OCaml core distribution"
+arch=(x86_64)
+url="https://github.com/ocaml/num"
+license=(LGPL2.1)
+depends=(ocaml4)
+makedepends=(ocaml4-findlib)
+options=(!strip !makeflags)
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ocaml/num/archive/v${pkgver}.tar.gz")
+sha512sums=('0cc9be8ad95704bb683b4bf6698bada1ee9a40dc05924b72adc7b969685c33eeb68ccf174cc09f6a228c48c18fe94af06f28bebc086a24973a066da620db8e6f')
+
+build() {
+ cd "${srcdir}/num-${pkgver}"
+ make
+}
+
+package() {
+ cd "${srcdir}/num-${pkgver}"
+ local _destdir="${pkgdir}$(ocamlfind printconf destdir)"
+ install -d "${_destdir}/stublibs"
+
+ make OCAMLFIND_DESTDIR="${_destdir}" findlib-install
+}