summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoberto Valentini2018-01-24 11:10:33 +0100
committerRoberto Valentini2018-01-24 11:10:33 +0100
commit8a007cbd740738c1eed6809a6a301b3f21e734b1 (patch)
tree78cc2e5354dff7e3afb728aa0e1052424769eed7
downloadaur-occi-api.tar.gz
New occi-api
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD23
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..65cac3268386
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = occi-api
+ pkgdesc = This gem provides ready-to-use client classes to simplify the integration of OCCI into your application
+ pkgver = 4.3.15
+ pkgrel = 1
+ url = http://egi-fctf.github.io/rOCCI-api/
+ arch = i686
+ arch = x86_64
+ license = Apache
+ depends = ruby>=1.9.3
+ depends = ruby-httparty>=0.13.1
+ depends = ruby-httparty<1
+ depends = ruby-json>=1.8.1
+ depends = ruby-json<3
+ depends = occi-core>=4.3.6
+ depends = occi-core<5
+ noextract = occi-api-4.3.15.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/occi-api-4.3.15.gem
+ sha256sums = 1611fc08076e41c35b0d9769eebd589dbeab3e3b502637946aba326110532a8f
+
+pkgname = occi-api
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a07567fac84d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer Roberto Valentini <valantin89 [at] gmail [dot] com>
+
+pkgname=occi-api
+pkgver=4.3.15
+pkgrel=1
+pkgdesc='This gem provides ready-to-use client classes to simplify the integration of OCCI into your application'
+arch=(i686 x86_64)
+url='http://egi-fctf.github.io/rOCCI-api/'
+license=(Apache)
+depends=('ruby>=1.9.3'
+ 'ruby-httparty>=0.13.1' 'ruby-httparty<1'
+ 'ruby-json>=1.8.1' 'ruby-json<3'
+ 'occi-core>=4.3.6' 'occi-core<5')
+options=(!emptydirs)
+source=("https://rubygems.org/downloads/${pkgname}-${pkgver}.gem")
+noextract=($pkgname-$pkgver.gem)
+sha256sums=('1611fc08076e41c35b0d9769eebd589dbeab3e3b502637946aba326110532a8f')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install --no-document -i "${pkgdir}/${_gemdir}" -n "${pkgdir}/usr/bin" $pkgname-$pkgver.gem
+ rm "${pkgdir}/${_gemdir}/cache/${pkgname}-${pkgver}.gem"
+}