summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2016-01-18 12:59:53 +0000
committerGrey Christoforo2016-01-18 12:59:53 +0000
commit68c8050c1e0d0f61f968ab295dc0082679915b3c (patch)
tree709a5167e4514363c462deff3a4c8b8d4112103c
parentadcf38a8adbb6fd06885dc487c988a36ba593af3 (diff)
downloadaur-68c8050c1e0d0f61f968ab295dc0082679915b3c.tar.gz
allow the libs to be found
-rw-r--r--.SRCINFO2
-rw-r--r--.oce.sh.swpbin12288 -> 0 bytes
-rw-r--r--PKGBUILD3
-rw-r--r--oce.conf1
-rwxr-xr-xoce.sh3
5 files changed, 8 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1985b84c0ec..f1c683d0bd12 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Mon Jan 18 11:55:25 UTC 2016
+# Mon Jan 18 12:59:45 UTC 2016
pkgbase = oce
pkgdesc = Open CASCADE Community Edition: patches/improvements/experiments contributed by users over the official Open CASCADE library.
pkgver = 0.16.1
diff --git a/.oce.sh.swp b/.oce.sh.swp
deleted file mode 100644
index 2bdcf98d8485..000000000000
--- a/.oce.sh.swp
+++ /dev/null
Binary files differ
diff --git a/PKGBUILD b/PKGBUILD
index f411b08d0af1..fae57aaf66ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,6 +31,9 @@ package() {
make DESTDIR="${pkgdir}" install
install -Dm644 ${srcdir}/oce-OCE-${pkgver}/LICENSE_LGPL_21.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE_LGPL_21.txt"
install -Dm644 ${srcdir}/oce-OCE-${pkgver}/OCCT_LGPL_EXCEPTION.txt "$pkgdir/usr/share/licenses/$pkgname/OCCT_LGPL_EXCEPTION.txt"
+
+ install -D -m644 "${srcdir}/oce.conf" "${pkgdir}/etc/ld.so.conf.d/oce.conf"
+ install -D -m 755 "${srcdir}/oce.sh" "${pkgdir}/etc/profile.d/oce.sh"
}
# vim:set ts=2 sw=2 et:
diff --git a/oce.conf b/oce.conf
new file mode 100644
index 000000000000..d95fed1c07fc
--- /dev/null
+++ b/oce.conf
@@ -0,0 +1 @@
+/opt/oce/lib
diff --git a/oce.sh b/oce.sh
new file mode 100755
index 000000000000..76a398f5841e
--- /dev/null
+++ b/oce.sh
@@ -0,0 +1,3 @@
+#!/bin/sh -f
+
+export LD_LIBRARY_PATH="${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}/opt/oce/lib"