summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2017-08-24 09:41:55 +0100
committerGrey Christoforo2017-08-24 09:41:55 +0100
commita9a39f114a7a593acf066b5886e4d51c9fd5504e (patch)
treee786f2f3ff8974b035568e73682da288c1902c1b
parenta01b2c5141f7a299fec1e176eb2a6b6cc16c6488 (diff)
downloadaur-a9a39f114a7a593acf066b5886e4d51c9fd5504e.tar.gz
only patch out xlocale.h if it's not on the system
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6feaa4e1b6bf..8b05e7e59b0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,9 @@ md5sums=('6dfd68e459e2c62387579888a867281f'
'167a9f5c94a16d7855c3ac99e34a4506')
prepare() {
- sed -i 's, #include <xlocale.h>, #include <locale.h>,g' "oce-OCE-${pkgver}/src/Standard/Standard_CLocaleSentry.hxx"
+ if [ ! -e "/usr/include/xlocale.h" ]; then
+ sed -i 's, #include <xlocale.h>, #include <locale.h>,g' "oce-OCE-${pkgver}/src/Standard/Standard_CLocaleSentry.hxx"
+ fi
}
build() {