summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo Bargen2015-09-17 22:15:20 +0200
committerDanilo Bargen2015-09-17 22:15:20 +0200
commit8678b640f690ce75de73a544997883783f1039bb (patch)
tree0d6d57444dfcdb0ca9935e850233d670f38ca033
downloadaur-8678b640f690ce75de73a544997883783f1039bb.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD19
-rw-r--r--install15
4 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72798c6415ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ocr-fonts
+ pkgdesc = Free versions of OCR-friendly sans-serif monospace TTF/OTF fonts (OCR-A and OCR-B) described in 'ISO 1073-1' and 'ISO 1073-2' standards.
+ pkgver = 0.2
+ pkgrel = 1
+ url = http://ansuz.sooke.bc.ca/page/fonts#ocrb
+ install = install
+ arch = any
+ license = other
+ source = http://jaist.dl.sourceforge.jp/tsukurimashou/56948/ocr-0.2.zip
+ source = install
+ sha256sums = 39289c641520265ecedbade99f01600f316f8196ec57f71c8402d3ba09438666
+ sha256sums = 54113221c6134d94646647aa06931d73ff9f5bc5bb915f98f0fa7d70ca9bb31d
+
+pkgname = ocr-fonts
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e5895c78682e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.swp
+*.tar.xz
+src/
+pkg/
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..31a5a81793fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Danilo Bargen <mail at dbrgn dot ch>
+pkgname=ocr-fonts
+pkgver=0.2
+pkgrel=1
+pkgdesc="Free versions of OCR-friendly sans-serif monospace TTF/OTF fonts (OCR-A and OCR-B) described in 'ISO 1073-1' and 'ISO 1073-2' standards."
+arch=('any')
+license=('other')
+url="http://ansuz.sooke.bc.ca/page/fonts#ocrb"
+source=("http://jaist.dl.sourceforge.jp/tsukurimashou/56948/ocr-0.2.zip"
+ "install")
+install=install
+sha256sums=('39289c641520265ecedbade99f01600f316f8196ec57f71c8402d3ba09438666'
+ '54113221c6134d94646647aa06931d73ff9f5bc5bb915f98f0fa7d70ca9bb31d')
+
+package() {
+ mkdir -p ${pkgdir}/usr/share/fonts/{TTF,OTF}/ || return 1
+ install -m 644 -o root ${srcdir}/ocr-${pkgver}/OCR*.ttf ${pkgdir}/usr/share/fonts/TTF/
+ install -m 644 -o root ${srcdir}/ocr-${pkgver}/OCR*.otf ${pkgdir}/usr/share/fonts/OTF/
+}
diff --git a/install b/install
new file mode 100644
index 000000000000..b3ed3b613ce8
--- /dev/null
+++ b/install
@@ -0,0 +1,15 @@
+post_install() {
+ fc-cache -s -f > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ mkfontscale /usr/share/fonts/OTF
+ mkfontdir /usr/share/fonts/OTF
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}