summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Janeczko2017-03-23 22:30:28 +0100
committerJakub Janeczko2017-03-23 22:30:28 +0100
commit1174f0c7186aeec1ea9eee41ac4da899ce130e0c (patch)
treef7107e9887f009d5627491bb1d9c681bdc94456f
downloadaur-ofxstatement-polish-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..50600301d258
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ofxstatement-polish-git
+ pkgdesc = ofxstatement support for some Polish banks and financial institutions
+ pkgver = r3.d1e49d7
+ pkgrel = 1
+ url = https://github.com/yay6/ofxstatement-polish
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = ofxstatement
+ source = git+https://github.com/yay6/ofxstatement-polish
+ md5sums = SKIP
+
+pkgname = ofxstatement-polish-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01dbf48d08c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Jakub Janeczko <jjaneczk@gmail.com>
+pkgname=ofxstatement-polish-git
+pkgver=r3.d1e49d7
+pkgrel=1
+pkgdesc="ofxstatement support for some Polish banks and financial institutions"
+arch=('any')
+url="https://github.com/yay6/ofxstatement-polish"
+license=('GPL3')
+depends=('ofxstatement')
+makedepends=('git')
+source=('git+https://github.com/yay6/ofxstatement-polish')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ python setup.py install --root="$pkgdir" --optimize=1
+}