summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTércio Martins2022-08-13 03:47:42 -0300
committerTércio Martins2022-08-13 03:47:42 -0300
commitb10e8964dada2c64d1e70aacc5cf41ee7a351e4c (patch)
tree472da7b45e5f4c46e13d606e9685a25a1679e6b9
parent37b862fc4dfa545e98e29163123cb67a69607cbb (diff)
downloadaur-b10e8964dada2c64d1e70aacc5cf41ee7a351e4c.tar.gz
Search for ffmpeg4.4 during build
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec1ab2fc8c92..74714c1c73d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
pkgbase = olive
pkgdesc = Free non-linear video editor
pkgver = 0.1.2
- pkgrel = 2
+ pkgrel = 3
url = https://www.olivevideoeditor.org/
arch = i686
arch = pentium4
arch = x86_64
license = GPL3
makedepends = cmake
+ makedepends = doxygen
+ makedepends = graphviz
makedepends = qt5-tools
- depends = ffmpeg
+ depends = ffmpeg4.4
+ depends = frei0r-plugins
depends = qt5-multimedia
depends = qt5-svg
- optdepends = frei0r-plugins
optdepends = olive-community-effects-git
source = olive-0.1.2.tar.gz::https://github.com/olive-editor/olive/archive/0.1.2.tar.gz
source = olive-0.1.2-appdata-desktop.patch
@@ -34,4 +36,3 @@ pkgbase = olive
sha512sums = a1141acea989e6182c53b8a6532029ef8566c00565c1cfdeadc1eff0f1a84e96e233ae80eb80e0aad9e847c8e7638b2fbcbd14b895f77d54275fe79c6e22cf75
pkgname = olive
-
diff --git a/PKGBUILD b/PKGBUILD
index 7ae5a5ac9d07..3d96bfc8f4e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=olive
pkgver=0.1.2
-pkgrel=2
+pkgrel=3
arch=('i686' 'pentium4' 'x86_64')
pkgdesc="Free non-linear video editor"
url="https://www.olivevideoeditor.org/"
license=('GPL3')
-depends=('ffmpeg' 'qt5-multimedia' 'qt5-svg')
-makedepends=('cmake' 'qt5-tools')
-optdepends=('frei0r-plugins' 'olive-community-effects-git')
+depends=('ffmpeg4.4' 'frei0r-plugins' 'qt5-multimedia' 'qt5-svg')
+makedepends=('cmake' 'doxygen' 'graphviz' 'qt5-tools')
+optdepends=('olive-community-effects-git')
source=("$pkgname-$pkgver.tar.gz::https://github.com/olive-editor/olive/archive/$pkgver.tar.gz"
"olive-0.1.2-appdata-desktop.patch"
"olive-0.1.2-cacher.patch"
@@ -52,6 +52,7 @@ build() {
cd build
cmake -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_PREFIX_PATH="/usr/lib/ffmpeg4.4;/usr/include/ffmpeg4.4" \
../$pkgname-$pkgver
make
}