summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTércio Martins2023-02-05 18:51:25 -0300
committerTércio Martins2023-02-05 18:51:25 -0300
commit8acbe9d8f459f7c57fad5601c66286b285ed703a (patch)
tree450c9eced43087a8ee63dd97d4b0797b4bbb95dc
parent37f0cd10301ae1bddbbafa2b2b276dfbe505a673 (diff)
downloadaur-8acbe9d8f459f7c57fad5601c66286b285ed703a.tar.gz
Fix a problem with linking the Imath library, and insert new dependencies: "opentimelineio0.14" and "libolivecore-git"
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD20
2 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 60ed6743fcf1..d5f826c125b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = olive-git
pkgdesc = Free non-linear video editor
- pkgver = continuous.r2461.g4c00387ab
+ pkgver = continuous.r2477.gaa6b77f80
pkgrel = 1
url = https://www.olivevideoeditor.org/
arch = x86_64
@@ -10,8 +10,10 @@ pkgbase = olive-git
makedepends = ninja
makedepends = qt6-svg
makedepends = qt6-tools
- depends = ffmpeg
+ depends = ffmpeg4.4
+ depends = libolivecore
depends = openimageio
+ depends = opentimelineio0.14
depends = portaudio
depends = qt6-base
provides = olive
diff --git a/PKGBUILD b/PKGBUILD
index 02316c627ba9..0ed6e5a80d9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,13 @@
_pkgname=olive
pkgname=$_pkgname-git
-pkgver=continuous.r2461.g4c00387ab
+pkgver=continuous.r2477.gaa6b77f80
pkgrel=1
arch=('x86_64')
pkgdesc="Free non-linear video editor"
url="https://www.olivevideoeditor.org/"
license=('GPL3')
-#depends=('ffmpeg' 'openimageio' 'opentimelineio' 'portaudio' 'qt6-base')
-depends=('ffmpeg' 'openimageio' 'portaudio' 'qt6-base')
+depends=('ffmpeg4.4' 'libolivecore' 'openimageio' 'opentimelineio0.14' 'portaudio' 'qt6-base')
makedepends=('cmake' 'git' 'ninja' 'qt6-svg' 'qt6-tools')
# Temporarily, the "olive-git" package is incompatible
@@ -23,24 +22,25 @@ conflicts=('olive')
source=('git+https://github.com/olive-editor/olive.git')
sha512sums=('SKIP')
-prepare() {
- # Currently, the build process fails if the OpenTimelineIO library is used
- sed -i '/find_package(OpenTimelineIO)/d' \
- "$srcdir"/$_pkgname/CMakeLists.txt
-}
-
pkgver() {
cd $_pkgname
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare(){
+ # Fix link problem with Imath library
+ echo "target_link_libraries(Imath::Imath INTERFACE OpenEXR::OpenEXR)" >> $_pkgname/cmake/FindOpenEXR.cmake
+}
+
build() {
cd $_pkgname
cmake -GNinja \
-Bbuild \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DQT_VERSION_MAJOR=6
+ -DQT_VERSION_MAJOR=6 \
+ -DOTIO_DEPS_INCLUDE_DIR=/usr/include/opentimelineio \
+ -DCMAKE_PREFIX_PATH="/usr/lib/ffmpeg4.4;/usr/include/ffmpeg4.4"
ninja -C build/
}