summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTércio Martins2020-11-22 13:53:10 -0300
committerTércio Martins2020-11-22 13:53:10 -0300
commit98be067e96865ec8d1bd25fb5a08d25d80978e3d (patch)
tree7e7f63ccf5b92495920c249ce9b0e5a5750bdcb3
parentdc4bf9bb7145f7690a97f04a8bca7e12c5c08f2e (diff)
downloadaur-98be067e96865ec8d1bd25fb5a08d25d80978e3d.tar.gz
Changed dependency from openimageio to openimageio-git
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD19
2 files changed, 7 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a873be0f0cbf..a21eefdec07a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = olive-git
pkgdesc = Free non-linear video editor
- pkgver = continuous.r35.g610f4c54
+ pkgver = continuous.r263.g32055edd
pkgrel = 1
url = https://www.olivevideoeditor.org/
arch = i686
@@ -11,7 +11,7 @@ pkgbase = olive-git
makedepends = git
makedepends = qt5-tools
depends = ffmpeg
- depends = openimageio
+ depends = openimageio-git
depends = qt5-multimedia
provides = olive
conflicts = olive
diff --git a/PKGBUILD b/PKGBUILD
index 208f4c64a719..2aea3d76049a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=olive-git
_pkgname=olive
-pkgver=continuous.r35.g610f4c54
+pkgver=continuous.r263.g32055edd
pkgrel=1
arch=('i686' 'pentium4' 'x86_64')
pkgdesc="Free non-linear video editor"
url="https://www.olivevideoeditor.org/"
license=('GPL3')
-depends=('ffmpeg' 'openimageio' 'qt5-multimedia')
+depends=('ffmpeg' 'openimageio-git' 'qt5-multimedia')
makedepends=('cmake' 'git' 'qt5-tools')
# Temporarily, the "olive-git" package is incompatible
@@ -27,17 +27,8 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- if [ -d build ]
- then
- rm -rf build
- fi
-
- mkdir build
-}
-
build() {
- cd build
+ mkdir -p build && cd build
cmake -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
../$_pkgname
@@ -47,6 +38,6 @@ build() {
package() {
cd build
make DESTDIR="$pkgdir/" install
- install -Dm755 "$srcdir/build/app/olive-editor" \
- "$pkgdir/usr/bin/olive-editor"
+# install -Dm755 "$srcdir/build/app/olive-editor" \
+# "$pkgdir/usr/bin/olive-editor"
}