summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTércio Martins2019-04-06 01:28:21 -0300
committerTércio Martins2019-04-06 01:28:21 -0300
commit9d503136743ac7cfe199e4eb7bc306c40cc97253 (patch)
treeb738f9f8f4105b6ffc62dc1ff13d571b4627d9d5
parent2cb3de646dc8f44b1e3436d40c80be961d839bd4 (diff)
downloadaur-9d503136743ac7cfe199e4eb7bc306c40cc97253.tar.gz
Update to commit 6264123: Build system changed to CMake; frei0r-plugins is now an optional dependency.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD31
2 files changed, 26 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 856177a06dab..0d7919f9da8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = olive-git
pkgdesc = Free non-linear video editor
- pkgver = continuous.r0.ga0f6299
- pkgrel = 2
+ pkgver = continuous.r0.g6264123b
+ pkgrel = 1
url = https://www.olivevideoeditor.org/
arch = i686
arch = x86_64
license = GPL3
+ makedepends = cmake
makedepends = git
depends = ffmpeg
- depends = frei0r-plugins
depends = qt5-multimedia
depends = qt5-svg
+ optdepends = frei0r-plugins
optdepends = olive-community-effects-git
conflicts = olive
- source = git+https://github.com/olive-editor/olive#commit=a0f6299
+ source = git+https://github.com/olive-editor/olive#commit=6264123
sha512sums = SKIP
pkgname = olive-git
diff --git a/PKGBUILD b/PKGBUILD
index 5580b1527ebc..b4848b6c6088 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
pkgname=olive-git
_pkgname=olive
-pkgver=continuous.r0.ga0f6299
-_commit=a0f6299
-pkgrel=2
+pkgver=continuous.r0.g6264123b
+_commit=6264123
+pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="Free non-linear video editor"
url="https://www.olivevideoeditor.org/"
license=('GPL3')
-depends=('ffmpeg' 'frei0r-plugins' 'qt5-multimedia' 'qt5-svg')
-makedepends=('git')
-optdepends=('olive-community-effects-git')
+depends=('ffmpeg' 'qt5-multimedia' 'qt5-svg')
+makedepends=('cmake' 'git')
+optdepends=('frei0r-plugins' 'olive-community-effects-git')
conflicts=('olive')
source=("git+https://github.com/olive-editor/olive#commit=$_commit")
sha512sums=('SKIP')
@@ -21,13 +21,24 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ if [ -d "$srcdir/build" ]
+ then
+ rm -rf "$srcdir/build"
+ fi
+
+ mkdir -p "$srcdir/build"
+}
+
build() {
- cd "$srcdir/$_pkgname"
- qmake CONFIG+=release PREFIX=/usr
+ cd "$srcdir/build"
+ cmake -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ "$srcdir/$_pkgname"
make
}
package() {
- cd "$srcdir/$_pkgname"
- make INSTALL_ROOT="$pkgdir" install
+ cd "$srcdir/build"
+ make DESTDIR="$pkgdir/" install
}