summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTércio Martins2019-05-02 10:28:19 -0300
committerTércio Martins2019-05-02 10:28:19 -0300
commitf315a427f914f0ccd1a0efe2753538fa202c7093 (patch)
treedbf30024f71bb4b6be24fb4add4abdd2694c1c61
parentc97604f1769f51e9d1642ed980724062fb34ce70 (diff)
downloadaur-f315a427f914f0ccd1a0efe2753538fa202c7093.tar.gz
Update to commit f81df006
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64e5b84138ce..166526d615e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = olive-git
pkgdesc = Free non-linear video editor
- pkgver = continuous.r0.gc5f63ec2
+ pkgver = continuous.r0.gf81df006
pkgrel = 1
url = https://www.olivevideoeditor.org/
arch = i686
@@ -14,8 +14,9 @@ pkgbase = olive-git
depends = qt5-svg
optdepends = frei0r-plugins
optdepends = olive-community-effects-git
+ provides = olive
conflicts = olive
- source = git+https://github.com/olive-editor/olive#commit=c5f63ec
+ source = git+https://github.com/olive-editor/olive#commit=f81df006
sha512sums = SKIP
pkgname = olive-git
diff --git a/PKGBUILD b/PKGBUILD
index dfe808cb14e2..97c6030292a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=olive-git
_pkgname=olive
-pkgver=continuous.r0.gc5f63ec2
-_commit=c5f63ec
+pkgver=continuous.r0.gf81df006
+_commit=f81df006
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="Free non-linear video editor"
@@ -12,6 +12,7 @@ license=('GPL3')
depends=('ffmpeg' 'qt5-multimedia' 'qt5-svg')
makedepends=('cmake' 'git' 'qt5-tools')
optdepends=('frei0r-plugins' 'olive-community-effects-git')
+provides=('olive')
conflicts=('olive')
source=("git+https://github.com/olive-editor/olive#commit=$_commit")
sha512sums=('SKIP')
@@ -27,14 +28,14 @@ prepare() {
rm -rf build
fi
- mkdir -p build
+ mkdir build
}
build() {
cd build
- cmake ../$_pkgname \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr
+ cmake -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ ../$_pkgname
make
}