summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruno Silva2018-09-03 14:05:23 +0100
committerBruno Silva2018-09-03 14:05:23 +0100
commit1d6d4478859db2bcb7cac50d7d6be42c39f2b1f0 (patch)
tree21b51b8c36fd3153414646f1ca1c68c269ee3009
parent705c874ebd865736fa05d8502f5eee1861dde361 (diff)
downloadaur-1d6d4478859db2bcb7cac50d7d6be42c39f2b1f0.tar.gz
Bump to 6.0pre2
-rw-r--r--Makefile.inc30
-rw-r--r--PKGBUILD28
-rw-r--r--config.status18
-rw-r--r--ver.h6
4 files changed, 25 insertions, 57 deletions
diff --git a/Makefile.inc b/Makefile.inc
index c3e27a270f3e..58d39814c541 100644
--- a/Makefile.inc
+++ b/Makefile.inc
@@ -3,9 +3,9 @@
# Your changes will be lost the next time ./configure is run.
#
OMNETPP_PRODUCT = OMNeT++
-OMNETPP_RELEASE = omnetpp-5.4
-OMNETPP_VERSION = 5.4
-OMNETPP_BUILDID = 180611-572210e
+OMNETPP_RELEASE = omnetpp-6.0pre2
+OMNETPP_VERSION = 6.0pre2
+OMNETPP_BUILDID = 180809-1548ee5f82
OMNETPP_EDITION = Academic Public License -- NOT FOR COMMERCIAL USE
#
@@ -17,8 +17,6 @@ WITH_OSGEARTH ?= no
WITH_NETBUILDER ?= yes
WITH_PARSIM ?= yes
WITH_SYSTEMC ?= no
-WITH_TKENV ?= no
-EMBED_TCL_CODE ?= yes
PREFER_SQLITE_RESULT_FILES ?= no
#
@@ -40,7 +38,6 @@ OMNETPP_LIB_DIR = $(OMNETPP_ROOT)/lib$(OUTPUT_PREFIX)
OMNETPP_OUT_DIR = $(OMNETPP_ROOT)/out$(OUTPUT_PREFIX)
OMNETPP_SRC_DIR = $(OMNETPP_ROOT)/src
OMNETPP_UTILS_DIR = $(OMNETPP_SRC_DIR)/utils
-OMNETPP_TKENV_DIR = $(OMNETPP_SRC_DIR)/tkenv
OMNETPP_UI_DIR = $(OMNETPP_ROOT)/ui
OMNETPP_DOC_DIR = $(OMNETPP_ROOT)/doc
OMNETPP_SAMPLES_DIR = $(OMNETPP_ROOT)/samples
@@ -136,12 +133,11 @@ RANLIB = ranlib
SHLIB_LD = clang++ -shared -fPIC
DLLTOOL = dlltool
STRIP = strip
-WISH =
MAKEDEPEND = opp_makedep -Y --objdirtree
LN = ln -f
MKPATH = mkdir -p
SHLIB_POSTPROCESS = opp_shlib_postprocess
-SWIG = not found
+SWIG = swig
QMAKE = /usr/bin/qmake
MOC=/usr/bin/moc
UIC=/usr/bin/uic
@@ -149,8 +145,6 @@ RCC=/usr/bin/rcc
HAVE_DLOPEN = 1
SYS_LIBS = -ldl -lstdc++
-TK_CFLAGS =
-TK_LIBS =
QT_CFLAGS = -isystem /usr/include/qt -isystem /usr/include/qt/QtCore -isystem /usr/include/qt/QtGui -isystem /usr/include/qt/QtWidgets -isystem /usr/include/qt/QtOpenGL -isystem /usr/include/qt/QtPrintSupport
QT_LIBS = -lQt5Gui -lQt5Core -lQt5Widgets -lQt5PrintSupport -lQt5OpenGL -L/usr/lib -Wl,-rpath=/usr/lib
QTENV_LDFLAGS = -Wl,-rpath-link=/usr/lib
@@ -188,7 +182,6 @@ SHARED_LIB_SUFFIX = $(SO_LIB_SUFFIX)
#
# omnetpp and system libraries linked with the simulations
#
-TKENV_LIBS = $(LDFLAG_INCLUDE)_tkenv_lib $(AS_NEEDED_OFF) -lopptkenv$D -loppenvir$D -lopplayout$D
QTENV_LIBS = $(LDFLAG_INCLUDE)_qtenv_lib $(AS_NEEDED_OFF) $(QTENV_LDFLAGS) -loppqtenv$D -loppenvir$D -lopplayout$D
CMDENV_LIBS = $(LDFLAG_INCLUDE)_cmdenv_lib $(AS_NEEDED_OFF) -loppcmdenv$D -loppenvir$D
ALL_ENV_LIBS = $(CMDENV_LIBS)
@@ -219,21 +212,6 @@ ifeq ($(WITH_QTENV),yes)
endif
#
-# flags and libraries required for Ttenv
-#
-ifeq ($(WITH_TKENV),yes)
- DEFINES += -DWITH_TKENV
- # libraries required for static linking
- ifneq ($(SHARED_LIBS),yes)
- TKENV_LIBS += $(TK_LIBS) $(ZLIB_LIBS)
- ifeq ($(PLATFORM),macosx)
- TKENV_LIBS += -framework Carbon
- endif
- endif
- ALL_ENV_LIBS += $(TKENV_LIBS)
-endif
-
-#
# Other defines
#
ifeq ($(WITH_PARSIM),yes)
diff --git a/PKGBUILD b/PKGBUILD
index 9833ca7ee971..59f3f630de05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,39 @@
# Maintainer: Bruno Silva <brunofernandes at ua dot pt>
+# Please Download latest version directly from Omnet++ Website since no direct access is possible (Captcha Protection Enable) and place it next to PKBBUILD.
+# Current link to download: https://www.omnetpp.org/component/jdownloads/summary/31-release-test-versions/2328-omnetpp60-pre2
pkgname='omnetpp-qt'
-pkgver=5.4
-_pkgver=5-4
+pkgver=6.0pre2
+_pkgver=6-0pre2
pkgrel=1
_pkgname='omnetpp'
pkgdesc='OMNeT++ Discrete Event Simulator. OMNeT++ is an extensible, modular, component-based C++ simulation library and framework, primarily for building network simulators: QT version'
url='http://www.omnetpp.org'
license=('custom')
depends=(libxml2 qt5-base tcl tk blt jdk8-openjdk openmpi libpcap doxygen graphviz clang openscenegraph)
-makedepends=(sh wget qt5-base cmake gcc bison flex perl openscenegraph)
+makedepends=(sh wget qt5-base cmake gcc bison flex perl openscenegraph blt)
+optdepends=(osgearth)
arch=('i686' 'x86_64')
provides=('omnetpp')
conflicts=('omnetpp')
-if [ $(echo "72529f945019d011aa7255f22db9e99b5eef7047943fa42e1d657ad67dabccf3b4dd557046636b8e15a29948b230984a365f282bfbf86eff6bc2297722e94231 omnetpp-5.4-src-linux.tgz" | sha512sum -c --status; echo $?) -ne 0 ];
-then
- sh download.sh
-fi
-
source=(OMNeT++.desktop
config.status
Makefile.inc
qtenv.pri
ver.h
omnetpp.sh
- download.sh
-omnetpp-${pkgver}-src-linux.tgz::https://www.omnetpp.org/component/jdownloads/send/31-release-test-versions/2331-omnetpp-${_pkgver}-linux)
+ omnetpp-${pkgver}-src-linux.tgz::https://www.omnetpp.org/component/jdownloads/summary/31-release-test-versions/2328-omnetpp60-pre2)
sha512sums=('a5772a605592ed2db839609f8298d1d71fb9141eb1b30dac584b788414dfe49b250ba803351a3a84f90c6b89f8e09e7b129a037af17c9b94c22dff2003a5edd8'
-'94f08a8e03e441a4609d0bfb35b92b4c8c702b7e3f9f39f2455572ef8e50894be781cc33792d50a730e801f232457f140b944f49931910e0d6c7f00b45d0b618'
-'325fd32ca57295ae1968e356146942753d450b167e5b506ff8e802839d525a4e45e91ed2fcbd069ba8ba23ba7903c7a938c2c8276d6eb22428d06a8670a00c97'
+'5c74d4b593006b3e93c253583ff9115b7b7da2feb48569f7bb9ae6daf45b5e85651c25b8267bb724e4ee366da163634cc1e6206be7ad05d55b8fe94570040249'
+'377a311ca1c8abbd6c141403cb418462cb3056593a392708994b52347c35ed64db969f27484e29ddacfe114e1da9156bc2d0ade23cea0519a202f3c81b07e338'
'b4d36b1104b0f341cc133111559ad9af7fb76d80a8281f61ae990e5e0e813fb7bd2ae4a1b73941c53ca87f81b14e5cf7396d1009f4a06d2066910677b73f7d21'
-'c33f06978b91b57b16244ceef7296609f93195ec4a99be98d42fdfb68f223fff26de66aacd0165e94f212bae7b9f5b622c512e92265c660a356195ca876a717d'
+'e638bff972b833c1bf6cec7fa4d36672d526312c6c29136505101fb6b6778da0515238476b1c1f815333a8fc349be9d518d60938259393591ce433d0cb179a66'
'facb711a01c41665c7909f82b4cee65ddee232e0c526f754ce1ab148dbc6c65abb9b24255f985be245fb2c33f91623365eac730ef83cb1a7c595a09726856fa1'
-'6104720105bc1bc3903e3530281cbced5ad7a973c9d3e65150ae87418316b1f9b54e02462988d040eb28709cd44adeb3ee5ca74f29e353dd55a9daa0199f52a2'
-'72529f945019d011aa7255f22db9e99b5eef7047943fa42e1d657ad67dabccf3b4dd557046636b8e15a29948b230984a365f282bfbf86eff6bc2297722e94231')
+'7515126e9a465fa1bf5a5e705df5501deb9733e9a8d1108da327fbf7f168adb60eae850a76f8f01d555039b3503fa7c2fb5948b798b53abf3061907568300cd5')
build() {
- # fix configure bug by providing pre-generated configuration file with --prefix=/opt --libdir=/opt/lib --libexecdir=/opt/lib
+ # fix configure bug by providing pre-generated configuration file with ./configure --prefix=/opt --libdir=/opt/lib --libexecdir=/opt/lib
cp config.status ${srcdir}/${_pkgname}-${pkgver}/
cp Makefile.inc ${srcdir}/${_pkgname}-${pkgver}/
cp qtenv.pri ${srcdir}/${_pkgname}-${pkgver}/src/qtenv/
diff --git a/config.status b/config.status
index 322e72bb5027..41471803669b 100644
--- a/config.status
+++ b/config.status
@@ -427,7 +427,7 @@ Copyright (C) 2012 Free Software Foundation, Inc.
This config.status script is free software; the Free Software Foundation
gives unlimited permission to copy, distribute and modify it."
-ac_pwd='/mnt/aur_appcache/AUR/omnetpp-qt/omnetpp-5.4'
+ac_pwd='/mnt/aur_appcache/AUR/omnetpp-qt/src/omnetpp-6.0pre2'
srcdir='.'
test -n "$AWK" || AWK=awk
# The default lists apply if the user does not specify any file.
@@ -592,10 +592,8 @@ S["WITH_SYSTEMC"]="no"
S["WITH_OSGEARTH"]="no"
S["WITH_OSG"]="yes"
S["WITH_QTENV"]="yes"
-S["WITH_TKENV"]="no"
S["WITH_PARSIM"]="yes"
S["WITH_NETBUILDER"]="yes"
-S["EMBED_TCL_CODE"]="yes"
S["JNILIBS_IF_POSSIBLE"]="missing-dependency"
S["AKAROA_LIBS"]="-L/usr/local/akaroa/lib -lakaroa -lfl"
S["AKAROA_CFLAGS"]="-I/usr/local/akaroa/include"
@@ -617,8 +615,6 @@ S["QTENV_LDFLAGS"]="-Wl,-rpath-link=/usr/lib"
S["QT_LIBS"]="-lQt5Gui -lQt5Core -lQt5Widgets -lQt5PrintSupport -lQt5OpenGL -L/usr/lib -Wl,-rpath=/usr/lib"
S["QT_CFLAGS"]="-isystem /usr/include/qt -isystem /usr/include/qt/QtCore -isystem /usr/include/qt/QtGui -isystem /usr/include/qt/QtWidgets -isystem /usr/include/qt/"\
"QtOpenGL -isystem /usr/include/qt/QtPrintSupport"
-S["TK_LIBS"]=""
-S["TK_CFLAGS"]=""
S["HAVE_DLOPEN"]="1"
S["LIB_PREFIX"]="lib"
S["EXE_SUFFIX"]=""
@@ -632,6 +628,7 @@ S["SHLIB_POSTPROCESS"]="opp_shlib_postprocess"
S["MKPATH"]="mkdir -p"
S["LN"]="ln -f"
S["MAKEDEPEND"]="opp_makedep -Y --objdirtree"
+S["WISH"]=""
S["STRIP"]="strip"
S["DLLTOOL"]="dlltool"
S["SHLIB_LD"]="clang++ -shared -fPIC"
@@ -655,22 +652,19 @@ S["DEFINES"]=" -DHAVE_SWAPCONTEXT -DWITH_MPI"
S["CFLAGS_RELEASE"]=" -O3 -DNDEBUG=1"
S["CFLAGS_DEBUG"]=" -g -Wall"
S["OMNETPP_EDITION"]="Academic Public License -- NOT FOR COMMERCIAL USE"
-S["OMNETPP_BUILDID"]="180611-572210e"
-S["OMNETPP_VERSION"]="5.4"
-S["OMNETPP_RELEASE"]="omnetpp-5.4"
+S["OMNETPP_BUILDID"]="180809-1548ee5f82"
+S["OMNETPP_VERSION"]="6.0pre2"
+S["OMNETPP_RELEASE"]="omnetpp-6.0pre2"
S["OMNETPP_PRODUCT"]="OMNeT++"
S["MPICXX"]=""
S["MPICPP"]="mpic++"
S["PRIVATE_JRE"]=""
S["JRE"]="java"
-S["WISH"]=""
-S["CXXCPP"]=""
-S["XMKMF"]=""
S["RCC"]="/usr/bin/rcc"
S["UIC"]="/usr/bin/uic"
S["MOC"]="/usr/bin/moc"
S["QMAKE"]="/usr/bin/qmake"
-S["SWIG"]="not found"
+S["SWIG"]="swig"
S["PERL"]="perl"
S["MAKE"]="make"
S["LEXLIB"]=""
diff --git a/ver.h b/ver.h
index 611d25abf628..a74c49dc0f69 100644
--- a/ver.h
+++ b/ver.h
@@ -13,7 +13,7 @@
*--------------------------------------------------------------*/
#define OMNETPP_PRODUCT "OMNeT++"
-#define OMNETPP_RELEASE "omnetpp-5.4"
-#define OMNETPP_VERSION_STR "5.4"
-#define OMNETPP_BUILDID "180611-572210e"
+#define OMNETPP_RELEASE "omnetpp-6.0pre2"
+#define OMNETPP_VERSION_STR "6.0pre2"
+#define OMNETPP_BUILDID "180809-1548ee5f82"
#define OMNETPP_EDITION "Academic Public License -- NOT FOR COMMERCIAL USE"