summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWil Thomason2019-11-07 15:15:42 -0500
committerWil Thomason2019-11-07 15:15:42 -0500
commit930174666fdd9ffa3a161af2244761f42c3a7b6f (patch)
tree13521137ce7bcb053ccc6a804961eb308b81ff68
parent02e38b16e6a20b60007c7b45b5fa961e2bb51f92 (diff)
downloadaur-930174666fdd9ffa3a161af2244761f42c3a7b6f.tar.gz
Restrict to compatible Boost versions for now
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a58ecdeed9f2..3ebc27e64381 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,9 +6,9 @@ pkgbase = ompl
arch = i686
arch = x86_64
license = BSD
- makedepends = boost
+ makedepends = boost<=1.69.0
makedepends = cmake
- depends = boost-libs
+ depends = boost-libs<=1.69.0
depends = python
depends = python-matplotlib
optdepends = py++: Python binding
diff --git a/PKGBUILD b/PKGBUILD
index b976f3427e1f..54016606d42b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,10 @@ pkgdesc="The Open Motion Planning Library (OMPL) consists of many state-of-the-a
arch=('i686' 'x86_64')
url="http://ompl.kavrakilab.org/"
license=('BSD')
-depends=('boost-libs' 'python' 'python-matplotlib')
-makedepends=('boost' 'cmake')
+# The restrictions on boost-libs and boost here are just until OMPL 1.50.0 is released, as it fixes
+# compatibility with boost 1.71.0 via commit 962961f
+depends=('boost-libs<=1.69.0' 'python' 'python-matplotlib')
+makedepends=('boost<=1.69.0' 'cmake')
optdepends=('py++: Python binding'
'ode: Plan using the Open Dynamics Engine'
'eigen: For an informed sampling technique')