summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatrix2022-09-28 20:52:06 +0100
committerMatrix2022-09-28 20:52:06 +0100
commit38942bafa7ee80446f4ba73bbf92ff32c48ef609 (patch)
treeb088aa8b229c0f4a5667400b3a408422d2f6a9ec
parent060240de75e638c679f8a2a571294e96794118bf (diff)
downloadaur-38942bafa7ee80446f4ba73bbf92ff32c48ef609.tar.gz
Update package + Revamp PKGBUILD
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD21
2 files changed, 18 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 87a46b344452..f25a4f4c528e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = onedrive-abraunegg
pkgdesc = Free OneDrive client written in D - abraunegg's fork. Follows the releases on https://github.com/abraunegg/onedrive/releases
- pkgver = 2.4.20
+ pkgver = 2.4.21
pkgrel = 1
url = https://github.com/abraunegg/onedrive
arch = i686
@@ -9,17 +9,16 @@ pkgbase = onedrive-abraunegg
arch = aarch64
license = GPL
makedepends = d-compiler
- depends = curl
depends = libnotify
depends = sqlite
depends = d-runtime
- provides = onedrive=2.4.20
+ provides = onedrive=2.4.21
conflicts = onedrive
conflicts = onedrive-abraunegg-git
conflicts = onedrive-bin
conflicts = onedrive-git
conflicts = onedrive-fork-git
- source = https://github.com/abraunegg/onedrive/archive/v2.4.20.tar.gz
- md5sums = 0f9f0fcf35ff40743bd0b5e222ce1b74
+ source = https://github.com/abraunegg/onedrive/archive/v2.4.21.tar.gz
+ md5sums = 51c9b0946da6fa3373fe6505cf2387ea
pkgname = onedrive-abraunegg
diff --git a/PKGBUILD b/PKGBUILD
index 54e49f9051b2..2607b4d9fd41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,9 @@
-# Maintainer: Peter Smit <peter@smitmail.eu>
-
+# Contributor: Peter Smit <peter@smitmail.eu>
+# Maintainer: Matrix <thysupremematrix@tuta.io>
_pkgname=onedrive
pkgname=$_pkgname-abraunegg
-pkgver=2.4.20
+pkgver=2.4.21
pkgrel=1
-epoch=
pkgdesc="Free OneDrive client written in D - abraunegg's fork. Follows the releases on https://github.com/abraunegg/onedrive/releases"
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
url="https://github.com/abraunegg/onedrive"
@@ -12,12 +11,21 @@ license=('GPL')
conflicts=('onedrive' 'onedrive-abraunegg-git' 'onedrive-bin' 'onedrive-git' 'onedrive-fork-git')
source=("https://github.com/abraunegg/onedrive/archive/v$pkgver.tar.gz")
provides=("onedrive=$pkgver")
-depends=('curl' 'libnotify' 'sqlite' 'd-runtime')
+depends=('libnotify' 'sqlite' 'd-runtime')
makedepends=('d-compiler')
+md5sums=('51c9b0946da6fa3373fe6505cf2387ea')
build() {
cd "$_pkgname-$pkgver"
- ./configure --sysconfdir=/etc --prefix=/usr --with-systemdsystemunitdir=/usr/lib/systemd/system --with-systemduserunitdir=/usr/lib/systemd/user --enable-notifications --enable-completions --with-zsh-completion-dir=/usr/share/zsh/site-functions --with-fish-completion-dir=/usr/share/fish/vendor_completions.d --with-bash-completion-dir=/usr/share/bash-completion/completions
+ ./configure --sysconfdir=/etc \
+ --prefix=/usr \
+ --with-systemdsystemunitdir=/usr/lib/systemd/system \
+ --with-systemduserunitdir=/usr/lib/systemd/user \
+ --enable-notifications \
+ --enable-completions \
+ --with-zsh-completion-dir=/usr/share/zsh/site-functions \
+ --with-fish-completion-dir=/usr/share/fish/vendor_completions.d \
+ --with-bash-completion-dir=/usr/share/bash-completion/completions
make
}
@@ -25,4 +33,3 @@ package() {
cd "$_pkgname-$pkgver"
make DESTDIR=$pkgdir PREFIX=/usr install
}
-md5sums=('0f9f0fcf35ff40743bd0b5e222ce1b74')