summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorj.r2021-10-27 20:14:55 +0200
committerj.r2021-10-27 20:14:55 +0200
commit69b5f5cc087d42b7ae023c74ec984c1b83af6d29 (patch)
tree619dae01774f76ae76966acffb85a20abf49824e
parent26515a8432d99cb91652fca3ba2ca7ecd4b8d307 (diff)
downloadaur-onedrive_tray-git.tar.gz
onedrive_tray-git: install binary to /usr/bin
-rw-r--r--.SRCINFO7
-rw-r--r--0001-Fix-binary-location-to-usr-bin.patch39
-rw-r--r--PKGBUILD14
3 files changed, 54 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c4ecb2645dfc..a321503243ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = onedrive_tray-git
pkgdesc = OneDrive system tray program
- pkgver = r23.68f5123
+ pkgver = r28.6883538
pkgrel = 1
url = https://github.com/DanielBorgesOliveira/onedrive_tray
arch = i686
@@ -9,10 +9,11 @@ pkgbase = onedrive_tray-git
makedepends = git
depends = qt5-base
depends = onedrive
- provides = onedrive_tray=r23.68f5123
+ provides = onedrive_tray=r28.6883538
conflicts = onedrive_tray
source = git+https://github.com/DanielBorgesOliveira/onedrive_tray.git
+ source = 0001-Fix-binary-location-to-usr-bin.patch
md5sums = SKIP
+ md5sums = dad2a29aa7d4eacb4ee9dad0bfaa8eb5
pkgname = onedrive_tray-git
-
diff --git a/0001-Fix-binary-location-to-usr-bin.patch b/0001-Fix-binary-location-to-usr-bin.patch
new file mode 100644
index 000000000000..22d4f03f248e
--- /dev/null
+++ b/0001-Fix-binary-location-to-usr-bin.patch
@@ -0,0 +1,39 @@
+From 52bed3d54b20981f85e0eabd1914442b2a348e2b Mon Sep 17 00:00:00 2001
+From: "j.r" <j.r@jugendhacker.de>
+Date: Wed, 27 Oct 2021 19:29:50 +0200
+Subject: [PATCH] Fix binary location to /usr/bin
+
+---
+ onedrive_tray.service | 2 +-
+ systray.pro | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/onedrive_tray.service b/onedrive_tray.service
+index 9b076f8..31064ed 100644
+--- a/onedrive_tray.service
++++ b/onedrive_tray.service
+@@ -5,7 +5,7 @@ After=network-online.target
+ Wants=network-online.target
+
+ [Service]
+-ExecStart=/usr/local/bin/onedrive_tray -s
++ExecStart=/usr/bin/onedrive_tray -s
+ Restart=on-failure
+ RestartSec=7
+ RestartPreventExitStatus=3
+diff --git a/systray.pro b/systray.pro
+index b5b3155..1dc5cda 100644
+--- a/systray.pro
++++ b/systray.pro
+@@ -4,7 +4,7 @@ DEPENDPATH += .
+ INCLUDEPATH += .
+
+ # Install info
+-target.path += /usr/local/bin/
++target.path += /usr/bin/
+ unitfile.path += /usr/lib/systemd/user/
+ unitfile.files = onedrive_tray.service
+ INSTALLS += target
+--
+2.33.1
+
diff --git a/PKGBUILD b/PKGBUILD
index bb60ad256015..403d5b1bba59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=onedrive_tray
pkgname=$_pkgname-git
-pkgver=r23.68f5123
+pkgver=r28.6883538
pkgrel=1
pkgdesc="OneDrive system tray program"
arch=('i686' 'x86_64')
@@ -13,8 +13,10 @@ depends=('qt5-base' 'onedrive')
makedepends=('git') # 'bzr', 'git', 'mercurial' or 'subversion'
provides=("onedrive_tray=$pkgver")
conflicts=("onedrive_tray")
-source=('git+https://github.com/DanielBorgesOliveira/onedrive_tray.git')
-md5sums=('SKIP')
+source=('git+https://github.com/DanielBorgesOliveira/onedrive_tray.git'
+ '0001-Fix-binary-location-to-usr-bin.patch')
+md5sums=('SKIP'
+ 'dad2a29aa7d4eacb4ee9dad0bfaa8eb5')
pkgver() {
cd "$_pkgname"
@@ -22,6 +24,12 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare () {
+ cd "$_pkgname"
+
+ patch -p1 -i "$srcdir/0001-Fix-binary-location-to-usr-bin.patch"
+}
+
build() {
cd "$_pkgname"
rm -rf build && mkdir -p build