summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Bernardoff2015-06-27 09:51:32 +0200
committerVincent Bernardoff2015-06-27 09:51:32 +0200
commite27c9eec4bfb546c70e2df98a546df451396e9b6 (patch)
tree10a833caa9f733bc5a377fd034ae3ccdb8e850e8
downloadaur-opam.tar.gz
Initial import
-rw-r--r--.AURINFO17
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
3 files changed, 60 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..ade374c1accf
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,17 @@
+pkgbase = opam
+ pkgdesc = OCaml Package Manager
+ pkgver = 1.2.2
+ pkgrel = 1
+ url = http://opam.ocaml.org
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = GPL
+ depends = ocaml
+ depends = aspcud
+ source = https://github.com/ocaml/opam/releases/download/1.2.2/opam-full-1.2.2.tar.gz
+ sha1sums = 415ff0506378ab8dfa428fcd0aff3aa28337d93b
+
+pkgname = opam
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ade374c1accf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = opam
+ pkgdesc = OCaml Package Manager
+ pkgver = 1.2.2
+ pkgrel = 1
+ url = http://opam.ocaml.org
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = GPL
+ depends = ocaml
+ depends = aspcud
+ source = https://github.com/ocaml/opam/releases/download/1.2.2/opam-full-1.2.2.tar.gz
+ sha1sums = 415ff0506378ab8dfa428fcd0aff3aa28337d93b
+
+pkgname = opam
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36663692ca0c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Vincent B. <vb@luminar.eu.org>
+
+pkgname=opam
+pkgver=1.2.2
+pkgrel=1
+pkgdesc="OCaml Package Manager"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url="http://opam.ocaml.org"
+license=('GPL')
+depends=('ocaml' 'aspcud')
+source=( https://github.com/ocaml/opam/releases/download/${pkgver}/opam-full-${pkgver}.tar.gz)
+sha1sums=('415ff0506378ab8dfa428fcd0aff3aa28337d93b')
+
+build() {
+ cd ${srcdir}/opam-full-${pkgver}
+ ./configure --prefix=/usr
+ make -j1 lib-ext
+ make -j1
+}
+
+package() {
+ cd ${srcdir}/opam-full-${pkgver}
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: