summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-06-09 11:41:58 -0700
committerAndy Weidenbaum2015-06-09 11:41:58 -0700
commit6a3435b74c29fa0e2e6ed09db6abb3b4ff61b697 (patch)
treef4c06516dcc60b22bbb9ec48a49b2239988133fd
downloadaur-open-transactions-git.tar.gz
Initial import
-rw-r--r--.SRCINFO47
-rw-r--r--PKGBUILD82
-rw-r--r--open-transactions.install24
3 files changed, 153 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e678b119b558
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,47 @@
+pkgbase = open-transactions-git
+ pkgdesc = Financial cryptography library
+ pkgver = 20140620
+ pkgrel = 1
+ url = https://github.com/Open-Transactions/Open-Transactions
+ install = open-transactions.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = autoconf
+ makedepends = automake
+ makedepends = gcc
+ makedepends = git
+ makedepends = gtest
+ makedepends = libtool
+ makedepends = make
+ makedepends = pkg-config
+ makedepends = swig
+ depends = msgpack
+ depends = openssl
+ depends = protobuf
+ depends = zeromq
+ depends = zlib
+ optdepends = gdc: Enable configuration for SWIG Digital Mars D Programing Language support
+ optdepends = go: Enable configuration for SWIG Go support
+ optdepends = java-environment: Enable configuration for SWIG Java support
+ optdepends = mono: Enable configuration for SWIG C-Sharp support
+ optdepends = perl: Enable configuration for SWIG Perl support
+ optdepends = php: Enable configuration for SWIG PHP support
+ optdepends = python2: Enable configuration for SWIG Python support
+ optdepends = ruby: Enable configuration for SWIG Ruby support
+ optdepends = tcl: Enable configuration for SWIG TCL support
+ provides = createmint
+ provides = open-transactions
+ provides = opentxs
+ provides = ot
+ provides = otserver
+ conflicts = createmint
+ conflicts = open-transactions
+ conflicts = opentxs
+ conflicts = ot
+ conflicts = otserver
+ source = open-transactions::git+https://github.com/Open-Transactions/Open-Transactions
+ sha256sums = SKIP
+
+pkgname = open-transactions-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4cb84264d65d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,82 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=open-transactions-git
+pkgver=20140620
+pkgrel=1
+pkgdesc="Financial cryptography library"
+arch=('i686' 'x86_64')
+depends=('msgpack' 'openssl' 'protobuf' 'zeromq' 'zlib')
+makedepends=('autoconf' 'automake' 'gcc' 'git' 'gtest' 'libtool' 'make' 'pkg-config' 'swig')
+optdepends=('gdc: Enable configuration for SWIG Digital Mars D Programing Language support'
+ 'go: Enable configuration for SWIG Go support'
+ 'java-environment: Enable configuration for SWIG Java support'
+ 'mono: Enable configuration for SWIG C-Sharp support'
+ 'perl: Enable configuration for SWIG Perl support'
+ 'php: Enable configuration for SWIG PHP support'
+ 'python2: Enable configuration for SWIG Python support'
+ 'ruby: Enable configuration for SWIG Ruby support'
+ 'tcl: Enable configuration for SWIG TCL support')
+url="https://github.com/Open-Transactions/Open-Transactions"
+license=('custom')
+source=(${pkgname%-git}::git+https://github.com/Open-Transactions/Open-Transactions)
+sha256sums=('SKIP')
+provides=('createmint' 'open-transactions' 'opentxs' 'ot' 'otserver')
+conflicts=('createmint' 'open-transactions' 'opentxs' 'ot' 'otserver')
+install=open-transactions.install
+
+# keyring can be 'flatfile', 'gnome' or 'kwallet'
+_keyring=flatfile
+
+pkgver() {
+ cd ${pkgname%-git}
+ git log -1 --format="%cd" --date=short | sed "s|-||g"
+}
+
+build() {
+ cd ${pkgname%-git}
+
+ msg 'Building...'
+ ./autogen.sh
+
+ export PERL_EXT_LDFLAGS='-avoid-version -shared'
+ export PYTHON_VERSION=2
+ ./configure \
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --libexecdir=/usr/lib/opentxs \
+ --sysconfdir=/etc \
+ --sharedstatedir=/usr/share/opentxs \
+ --localstatedir=/var/lib/opentxs \
+ --with-gnu-ld \
+ --with-keyring=$_keyring
+ #--with-csharp \
+ #--with-d \
+ #--with-go \
+ #--with-java \
+ #--with-perl5 \
+ #--with-php \
+ #--with-python \
+ #--with-ruby \
+ #--with-tcl
+ make
+}
+
+package() {
+ cd ${pkgname%-git}
+
+ msg 'Installing license...'
+ install -D -m644 docs/LICENSE-AND-CREDITS.txt "$pkgdir/usr/share/licenses/opentxs/LICENSE"
+
+ msg 'Installing...'
+ make DESTDIR="$pkgdir" install
+
+ msg 'Installing bash completion...'
+ install -D -m644 scripts/bash_completion.d/opentxs-bash-completion.sh $pkgdir/etc/bash_completion.d/opentxs
+
+ msg 'Yielding /usr/lib/libgtest.so to pkg: gtest...'
+ rm -f $pkgdir/usr/lib/libgtest.so
+
+ msg 'Cleaning up pkgdir...'
+ find "$pkgdir" -type d -name .git -exec rm -r '{}' +
+ find "$pkgdir" -type f -name .gitignore -exec rm -r '{}' +
+}
diff --git a/open-transactions.install b/open-transactions.install
new file mode 100644
index 000000000000..dd06c1d866b4
--- /dev/null
+++ b/open-transactions.install
@@ -0,0 +1,24 @@
+post_install() {
+ printf "%b\n" "$opentxs"
+}
+
+read -d '' opentxs <<'EOF'
+###########################################################################
+###########################################################################
+## ##
+## Open-Transactions ##
+## _________________ ##
+## ##
+## Extract a tarball of sample contracts, baskets, server: ##
+## ##
+## mkdir -p ~/opentxs && cd ~/opentxs ##
+## tar -xvzf /usr/share/opentxs/user-samples.tar.gz -C . ##
+## ##
+## To look at an example wallet (WARNING: resets user data): ##
+## ##
+## mkdir -p ~/.ot ##
+## cp -R ~/opentxs/ot-sample-data/* ~/.ot ##
+## ##
+###########################################################################
+###########################################################################
+EOF