summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAleksander Bobiński2021-12-04 19:31:18 +0100
committerAleksander Bobiński2021-12-04 19:31:18 +0100
commit33a8e848c6cb7f61c6bc99b57f6fe68dbb28593e (patch)
treec0c68a14e2e84a850ad2dcf138d79b72664d247b
parent6d20bece4ec2d845c83cad94b5e6da4a58a09a6d (diff)
downloadaur-33a8e848c6cb7f61c6bc99b57f6fe68dbb28593e.tar.gz
Use version 0.14.1; Fix missing dependencies
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD15
2 files changed, 18 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4b49251363e..61a3edbfc012 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = open3d
pkgdesc = A Modern Library for 3D Data Processing
- pkgver = 0.13.0
+ pkgver = 0.14.1
pkgrel = 1
epoch = 4
url = http://www.open3d.org
@@ -9,12 +9,13 @@ pkgbase = open3d
makedepends = cmake
makedepends = git
makedepends = python-setuptools
+ depends = libc++abi
+ depends = libc++
depends = eigen
depends = flann
depends = fmt
depends = glew
depends = glfw-x11
- depends = gtest
depends = jsoncpp
depends = libjpeg-turbo
depends = liblzf
@@ -29,12 +30,13 @@ pkgbase = open3d
sha256sums = SKIP
pkgname = open3d
+ depends = libc++abi
+ depends = libc++
depends = eigen
depends = flann
depends = fmt
depends = glew
depends = glfw-x11
- depends = gtest
depends = jsoncpp
depends = libjpeg-turbo
depends = liblzf
@@ -47,12 +49,13 @@ pkgname = open3d
conflicts = open3d-git
pkgname = python-open3d
+ depends = libc++abi
+ depends = libc++
depends = eigen
depends = flann
depends = fmt
depends = glew
depends = glfw-x11
- depends = gtest
depends = jsoncpp
depends = libjpeg-turbo
depends = liblzf
@@ -70,12 +73,13 @@ pkgname = python-open3d
conflicts = python-py3d-git
pkgname = python-py3d
+ depends = libc++abi
+ depends = libc++
depends = eigen
depends = flann
depends = fmt
depends = glew
depends = glfw-x11
- depends = gtest
depends = jsoncpp
depends = libjpeg-turbo
depends = liblzf
diff --git a/PKGBUILD b/PKGBUILD
index 53b88d642807..0f9317e7c888 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=open3d
pkgname=( {,python-}open3d python-py3d )
-pkgver=0.13.0
+pkgver=0.14.1
pkgrel=1
epoch=4
pkgdesc="A Modern Library for 3D Data Processing"
@@ -11,12 +11,13 @@ arch=('x86_64')
url="http://www.open3d.org"
license=('MIT')
depends=(
+ libc++abi
+ libc++
eigen
flann
fmt
glew
glfw-x11
- gtest
jsoncpp
libjpeg-turbo
liblzf
@@ -55,7 +56,6 @@ function build() {
-DUSE_SYSTEM_FMT=ON \
-DUSE_SYSTEM_GLEW=ON \
-DUSE_SYSTEM_GLFW=ON \
- -DUSE_SYSTEM_GOOGLETEST=ON \
-DUSE_SYSTEM_JPEG=ON \
-DUSE_SYSTEM_LIBLZF=ON \
-DUSE_SYSTEM_PNG=ON \
@@ -65,12 +65,13 @@ function build() {
function package_open3d() {
depends=(
+ libc++abi
+ libc++
eigen
flann
fmt
glew
glfw-x11
- gtest
jsoncpp
libjpeg-turbo
liblzf
@@ -92,12 +93,13 @@ function package_open3d() {
function package_python-open3d() {
depends=(
+ libc++abi
+ libc++
eigen
flann
fmt
glew
glfw-x11
- gtest
jsoncpp
libjpeg-turbo
liblzf
@@ -127,12 +129,13 @@ function package_python-open3d() {
function package_python-py3d() {
depends=(
+ libc++abi
+ libc++
eigen
flann
fmt
glew
glfw-x11
- gtest
jsoncpp
libjpeg-turbo
liblzf