summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlquidfire2024-04-11 21:04:53 +0200
committerlquidfire2024-04-11 21:04:53 +0200
commit1f430e17b0cc30825a17fe9945dfbfbf59341f28 (patch)
tree062e05bf9300847f670780391fe0390b42af31b2
parentfee57ea675b306c049cb2a4652961f591e944a0b (diff)
downloadaur-openarc.tar.gz
Added missing dependencies. Improved patch file.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--configure.ac.patch175
3 files changed, 183 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0cbbda6f9545..cf2c2f7d3045 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,20 @@
pkgbase = openarc
pkgdesc = Open source implementation of the ARC email authentication system.
pkgver = 1.0.0.Beta3
- pkgrel = 2
+ pkgrel = 4
url = https://github.com/trusteddomainproject/OpenARC
arch = x86_64
license = BSD-2-Clause
license = LicenseRef-Sendmail-1.1
makedepends = libmilter
makedepends = git
+ depends = sh
+ depends = glibc
+ depends = jansson
depends = openssl
depends = libbsd
optdepends = smtp-server: for using a local mail server
+ optdepends = bind: required only for signature verification (alternatives available)
source = git+https://github.com/trusteddomainproject/OpenARC.git#commit=eb430dbdeee9f502295fe7a7d5041dfca3f00745
source = configure.ac.patch
source = openarc.service
@@ -18,7 +22,7 @@ pkgbase = openarc
source = openarc.tmpfiles
validpgpkeys = 5CDD574C22FF4D2480ACABDF5254B96BC608B511
sha256sums = 51fe59502f4428e5516b31ef1e63f33bddc5b4fb9d0c7752a212ec1918b18145
- sha256sums = 29f58f63c6e683b385c1b11669055058ef2b0e6d747de9a8000983112c6f8a55
+ sha256sums = 3df10339f7f83a9b4449ee13aaeb23f78f6ba75a49d363f80f2f757d0540b6d2
sha256sums = 14c3cce4d0b78b34c79eb3f50e6b48c9fa5aa2def11593b537190dfa46ed9536
sha256sums = 31c399c0e3a69bb845b033ab5c0ad92d44cacb0fd58e0113cd1901e75900515e
sha256sums = db0f857ca6b3ef8e7210dc18b051dde26540e7ce70f611d72e2a16e6d2d71d3e
diff --git a/PKGBUILD b/PKGBUILD
index 9e30a1cf5aa1..c09defa1a21e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,15 @@
pkgname=openarc
pkgver=1.0.0.Beta3
-pkgrel=2
+pkgrel=4
_commit=eb430dbdeee9f502295fe7a7d5041dfca3f00745
pkgdesc="Open source implementation of the ARC email authentication system."
arch=(x86_64)
url="https://github.com/trusteddomainproject/OpenARC"
license=('BSD-2-Clause' 'LicenseRef-Sendmail-1.1')
-depends=('openssl' 'libbsd')
-optdepends=('smtp-server: for using a local mail server')
+depends=('sh' 'glibc' 'jansson' 'openssl' 'libbsd')
+optdepends=('smtp-server: for using a local mail server'
+ 'bind: required only for signature verification (alternatives available)')
makedepends=('libmilter' 'git')
source=("git+https://github.com/trusteddomainproject/OpenARC.git#commit=${_commit}"
configure.ac.patch
@@ -17,7 +18,7 @@ source=("git+https://github.com/trusteddomainproject/OpenARC.git#commit=${_commi
openarc.sysusers
openarc.tmpfiles)
sha256sums=('51fe59502f4428e5516b31ef1e63f33bddc5b4fb9d0c7752a212ec1918b18145'
- '29f58f63c6e683b385c1b11669055058ef2b0e6d747de9a8000983112c6f8a55'
+ '3df10339f7f83a9b4449ee13aaeb23f78f6ba75a49d363f80f2f757d0540b6d2'
'14c3cce4d0b78b34c79eb3f50e6b48c9fa5aa2def11593b537190dfa46ed9536'
'31c399c0e3a69bb845b033ab5c0ad92d44cacb0fd58e0113cd1901e75900515e'
'db0f857ca6b3ef8e7210dc18b051dde26540e7ce70f611d72e2a16e6d2d71d3e')
@@ -47,7 +48,7 @@ check() {
package() {
cd "$srcdir/OpenARC"
-
+
make -j1 DESTDIR="$pkgdir/" install
install -Dm644 "$srcdir/openarc.sysusers" "$pkgdir/usr/lib/sysusers.d/$pkgname.conf"
install -Dm644 "$srcdir/openarc.tmpfiles" "$pkgdir/usr/lib/tmpfiles.d/$pkgname.conf"
diff --git a/configure.ac.patch b/configure.ac.patch
index 2a4e55ce4f0a..4afb59f62771 100644
--- a/configure.ac.patch
+++ b/configure.ac.patch
@@ -1,13 +1,180 @@
---- configure.ac 2024-04-10 19:41:22.161731543 +0200
-+++ configure.ac.new 2024-04-10 20:10:17.749361127 +0200
-@@ -61,9 +61,8 @@
+--- configure.ac 2024-04-11 20:37:54.617501223 +0200
++++ configure.ac.new 2024-04-11 20:36:34.224776417 +0200
+@@ -12,8 +12,8 @@
+ #
+ # Package version
+ #
+-m4_define([VERSION_RELEASE], 0)
+-m4_define([VERSION_MAJOR_REV], 1)
++m4_define([VERSION_RELEASE], 1)
++m4_define([VERSION_MAJOR_REV], 0)
+ m4_define([VERSION_MINOR_REV], 0)
+ m4_define([VERSION_PATCH], 0)
+
+@@ -36,15 +36,13 @@
+ AC_CONFIG_AUX_DIR([build-aux])
+ AM_INIT_AUTOMAKE(
+ 1.11.1
+- dnl Automake version before 1.13 (when the serial-tests option was
+- dnl still the default) still defined the badly obsolete macro
+- dnl 'AM_PROG_INSTALL'.
+- m4_ifndef([AM_PROG_INSTALL], [serial-tests])
+ )
+ AC_CONFIG_HEADERS([build-config.h])
+
+ AC_CONFIG_MACRO_DIR([m4])
+
++LT_INIT
++
+ #
+ # Hexadecimal version, for use in generating dkim.h
+ #
+@@ -61,9 +59,9 @@
# Checks for programs
#
AC_PROG_CC
-AC_PROG_CC_C99
++# autoconf 2.70 deprecated this, but it might still be necessary on old versions
++m4_version_prereq([2.70], [:], [AC_PROG_CC_C99])
AM_PROG_CC_C_O
-AC_PROG_LIBTOOL
-+LT_INIT
PKG_PROG_PKG_CONFIG
+@@ -666,6 +664,7 @@
+ CPPFLAGS="$saved_CPPFLAGS"
+ LDFLAGS="$saved_LDFLAGS"
+ LIBS="$saved_LIBS"
++
+ fi
+
+ AC_SUBST(LIBCRYPTO_CFLAGS)
+@@ -795,6 +794,82 @@
+ AC_SUBST(LIBMILTER_LIBDIRS)
+ AC_SUBST(LIBMILTER_LIBS)
+
++#
++# header filtering requires libjansson
++#
++
++AC_ARG_WITH([libjansson],
++ AS_HELP_STRING([--with-libjansson],
++ [location of jansson includes and library]),
++ [janssonpath="$withval"], [janssonpath="auto"])
++
++LIBJANSSON_CPPFLAGS=""
++LIBJANSSON_LDFLAGS=""
++LIBJANSSON_LIBS=""
++
++jansson_found="no"
++if test \( x"$janssonpath" = x"auto" -o x"$janssonpath" = x"yes" \) -a \
++ x"$PKG_CONFIG" != x""
++then
++ PKG_CHECK_MODULES([LIBJANSSON], [jansson >= 2.2.1],
++ [
++ jansson_found="yes"
++ LIBJANSSON_CPPFLAGS="$LIBJANSSON_CFLAGS"
++ LIBJANSSON_LIBS="$LIBJANSSON_LIBS"
++ ],
++ [
++ jansson_found="no"
++ AC_MSG_WARN([pkg-config for libjansson not found, trying manual
++ search...])
++ ])
++fi
++
++if test x"$janssonpath" != x"no" -a x"$jansson_found" = x"no"
++then
++ AC_MSG_CHECKING([for libjansson])
++ if test x"$janssonpath" != x"auto" -a x"$janssonpath" != x"yes"
++ then
++ if test -f $janssonpath/include/jansson.h
++ then
++ AC_MSG_RESULT($janssonpath)
++ jansson_found="yes"
++ LIBJANSSON_CPPFLAGS="-I$janssonpath/include"
++ LIBJANSSON_LDFLAGS="-L$janssonpath/lib"
++ LIBJANSSON_LIBS="-ljansson"
++ else
++ AC_MSG_ERROR(not found at $janssonpath)
++ fi
++ else
++ janssondirs="/usr /usr/local"
++ for d in $janssondirs
++ do
++ if test -f $d/include/jansson.h
++ then
++ janssonpath=$d
++ AC_MSG_RESULT($d)
++ jansson_found="yes"
++ LIBJANSSON_CPPFLAGS="-I$janssonpath/include"
++ LIBJANSSON_LDFLAGS="-L$janssonpath/lib"
++ LIBJANSSON_LIBS="-ljansson"
++ break
++ fi
++ done
++ fi
++ if test x"$jansson_found" != x"yes"
++ then
++ AC_MSG_RESULT([no])
++ fi
++fi
++AC_SUBST(LIBJANSSON_CPPFLAGS)
++AC_SUBST(LIBJANSSON_LDFLAGS)
++AC_SUBST(LIBJANSSON_LIBS)
++AM_CONDITIONAL(JANSSON, test x"$LIBJANSSON_LIBS" != x"")
++
++if test x"$jansson_found" == x"yes"
++then
++ AC_DEFINE(USE_JANSSON, 1, [use libjansson to provide header field checks])
++fi
++
+ # This (below) is just for the pkg-config file openarc.pc.in
+ LIBOPENARC_LIBS_PKG="$LIBOPENARC_LIBS"
+ LIBOPENARC_INC="$LIBCRYPTO_CPPFLAGS $LIBCRYPTO_CFLAGS $LIBTRE_CPPFLAGS"
+@@ -887,23 +962,26 @@
+ # Finish up
+ #
+
+-AC_OUTPUT([ Makefile
+- docs/Makefile
+- contrib/Makefile
+- contrib/docs/Makefile
+- contrib/init/Makefile
+- contrib/init/generic/Makefile
+- contrib/init/redhat/Makefile
+- contrib/init/redhat/openarc
+- contrib/init/solaris/Makefile
+- contrib/spec/Makefile
+- contrib/spec/openarc.spec
+- contrib/systemd/Makefile
+- contrib/systemd/openarc.service
+- libopenarc/openarc.pc libopenarc/Makefile
+- libopenarc/docs/Makefile
+- openarc/Makefile openarc/openarc.8 openarc/openarc.conf.5
+- openarc/openarc.conf.simple
++AC_CONFIG_FILES([
++ Makefile
++ docs/Makefile
++ contrib/Makefile
++ contrib/docs/Makefile
++ contrib/init/Makefile
++ contrib/init/generic/Makefile
++ contrib/init/redhat/Makefile
++ contrib/init/redhat/openarc
++ contrib/init/solaris/Makefile
++ contrib/spec/Makefile
++ contrib/spec/openarc.spec
++ contrib/systemd/Makefile
++ contrib/systemd/openarc.service
++ libopenarc/openarc.pc
++ libopenarc/Makefile
++ libopenarc/docs/Makefile
++ openarc/Makefile
++ openarc/openarc.8
++ openarc/openarc.conf.5
++ openarc/openarc.conf.simple
+ ])
+- #libopenarc/tests/Makefile
+- #openarc/tests/Makefile
++AC_OUTPUT