summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrank Siegert2018-09-19 11:30:30 +0200
committerFrank Siegert2018-09-19 11:30:30 +0200
commit17fb8b85ca46ba32d9869b58a777b31158219e6b (patch)
tree77c8d4682e849f2c099b24772e0a3d79c631a02a
parent76b275ba11f869c2b3c1583378849e2ac818e832 (diff)
downloadaur-17fb8b85ca46ba32d9869b58a777b31158219e6b.tar.gz
Update to 1.4.1-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD11
-rw-r--r--ec88fc43aa96bedae1ad32d07e0237fe6fb940b1.patch23
3 files changed, 10 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb12a70dde88..11b6b009ccaf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Jun 1 11:28:55 UTC 2018
+# Wed Sep 19 09:30:30 UTC 2018
pkgbase = openboard
pkgdesc = Interactive whiteboard software for schools and universities
- pkgver = 1.4.0
- pkgrel = 3
+ pkgver = 1.4.1
+ pkgrel = 1
url = http://openboard.ch/index.en.html
arch = x86_64
arch = i686
@@ -19,17 +19,16 @@ pkgbase = openboard
depends = openssl-1.0
depends = libfdk-aac
depends = sdl
- source = https://github.com/OpenBoard-org/OpenBoard/archive/v1.4.0.tar.gz
+ depends = ffmpeg
+ source = https://github.com/OpenBoard-org/OpenBoard/archive/v1.4.1.tar.gz
source = https://github.com/OpenBoard-org/OpenBoard-ThirdParty/archive/master.zip
source = ssl10.patch
source = qchar.patch
- source = ec88fc43aa96bedae1ad32d07e0237fe6fb940b1.patch
source = openboard.desktop
- md5sums = bc04b7178828a6a76dcc7b273276ad30
+ md5sums = a1e517fcf5af4991d72d77165652ee37
md5sums = fa1ff089f0bcc15d2a510bb90cdd3002
md5sums = 9dbccb56e4079b75c606dc40c3e77f00
md5sums = bf2c524f3897cfcfb4315bcd92d4206e
- md5sums = c8c6821f192993626986e60032d2ea41
md5sums = 21d1749400802f8fc0669feaf77de683
pkgname = openboard
diff --git a/PKGBUILD b/PKGBUILD
index dc5d542309a8..921e81d720f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,21 @@
# Maintainer: Frank Siegert <frank.siegert@googlemail.com>
pkgname=openboard
-pkgver=1.4.0
-pkgrel=3
+pkgver=1.4.1
+pkgrel=1
pkgdesc="Interactive whiteboard software for schools and universities"
arch=('x86_64' 'i686')
url="http://openboard.ch/index.en.html"
license=('GPL3')
-depends=('qt5-base' 'qt5-multimedia' 'qt5-svg' 'qt5-script' 'qt5-webkit' 'qt5-tools' 'libpaper' 'bzip2' 'openssl-1.0' 'libfdk-aac' 'sdl')
+depends=('qt5-base' 'qt5-multimedia' 'qt5-svg' 'qt5-script' 'qt5-webkit' 'qt5-tools' 'libpaper' 'bzip2' 'openssl-1.0' 'libfdk-aac' 'sdl' 'ffmpeg')
source=("https://github.com/OpenBoard-org/OpenBoard/archive/v$pkgver.tar.gz"
"https://github.com/OpenBoard-org/OpenBoard-ThirdParty/archive/master.zip"
ssl10.patch
qchar.patch
- ec88fc43aa96bedae1ad32d07e0237fe6fb940b1.patch
openboard.desktop)
-md5sums=('bc04b7178828a6a76dcc7b273276ad30'
+md5sums=('a1e517fcf5af4991d72d77165652ee37'
'fa1ff089f0bcc15d2a510bb90cdd3002'
'9dbccb56e4079b75c606dc40c3e77f00'
'bf2c524f3897cfcfb4315bcd92d4206e'
- 'c8c6821f192993626986e60032d2ea41'
'21d1749400802f8fc0669feaf77de683')
prepare() {
@@ -27,7 +25,6 @@ prepare() {
cd $srcdir/OpenBoard-$pkgver
patch -p1 < $srcdir/ssl10.patch
patch -p1 < $srcdir/qchar.patch
- patch -p1 < $srcdir/ec88fc43aa96bedae1ad32d07e0237fe6fb940b1.patch
}
build() {
diff --git a/ec88fc43aa96bedae1ad32d07e0237fe6fb940b1.patch b/ec88fc43aa96bedae1ad32d07e0237fe6fb940b1.patch
deleted file mode 100644
index 12e57d1972fe..000000000000
--- a/ec88fc43aa96bedae1ad32d07e0237fe6fb940b1.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From ec88fc43aa96bedae1ad32d07e0237fe6fb940b1 Mon Sep 17 00:00:00 2001
-From: fsiegert <frank.siegert@cern.ch>
-Date: Wed, 4 Apr 2018 10:10:55 +0200
-Subject: [PATCH] Fix compilation when LIBAVFORMAT_VERSION_MICRO==100
-
-Since UBFFmpegVideoEncoder.cpp uses `avresample.h` for `LIBAVFORMAT_VERSION_MICRO<100` we have to be complementary here in the include file when including `swresample.h`.
----
- src/podcast/ffmpeg/UBFFmpegVideoEncoder.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/podcast/ffmpeg/UBFFmpegVideoEncoder.h b/src/podcast/ffmpeg/UBFFmpegVideoEncoder.h
-index 6068a369..69fa81ef 100644
---- a/src/podcast/ffmpeg/UBFFmpegVideoEncoder.h
-+++ b/src/podcast/ffmpeg/UBFFmpegVideoEncoder.h
-@@ -36,7 +36,7 @@ extern "C" {
- #include <libswscale/swscale.h>
-
- // Due to the whole ffmpeg / libAV silliness, we have to support libavresample on some platforms
--#if LIBAVFORMAT_VERSION_MICRO > 100
-+#if LIBAVFORMAT_VERSION_MICRO >= 100
- #include <libswresample/swresample.h>
- #else
- #include <libavresample/avresample.h>