summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrank Siegert2022-06-07 14:04:34 +0200
committerFrank Siegert2022-06-07 14:04:34 +0200
commit4217a10040d75114e40d87b3236d0126b25ee956 (patch)
tree8296ad17084eceb4b961df5e0d9eaa493c43d643
parentc39644d53595b4d1974460ae6318e6194f4cc4cd (diff)
downloadaur-4217a10040d75114e40d87b3236d0126b25ee956.tar.gz
Update to 1.6.2-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
-rw-r--r--poppler.patch124
-rw-r--r--quazip.patch6
4 files changed, 12 insertions, 142 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a98c53408be9..b2b34a69b1c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openboard
pkgdesc = Interactive whiteboard software for schools and universities
- pkgver = 1.6.1
- pkgrel = 6
+ pkgver = 1.6.2
+ pkgrel = 1
url = http://openboard.ch/index.en.html
arch = x86_64
arch = i686
@@ -22,19 +22,17 @@ pkgbase = openboard
depends = ffmpeg4.4
depends = quazip
depends = poppler
- source = https://github.com/OpenBoard-org/OpenBoard/archive/v1.6.1.tar.gz
+ source = https://github.com/OpenBoard-org/OpenBoard/archive/v1.6.2.tar.gz
source = openboard.desktop
source = qchar.patch
source = quazip.patch
source = drop_ThirdParty_repo.patch
- source = https://github.com/letsfindaway/OpenBoard/commit/8a3835c9139c47709358a1ec8eef9b4f816182c8.patch
source = ffmpeg.patch
- sha256sums = cf5bfb570b9ac4e61e1670c5a433f1dcaf0de1e8dbcbd544f058711690afba79
+ sha256sums = 300b440edad8aa0aeb726e4cca0565a5ea4fc9b5446ddc2bd4710be3fa9f1b7f
sha256sums = 64289f9d91cb25fa79fb988f19d43a542d67380fcf27668d0da1ee4ba1e705eb
sha256sums = b40fdab85f5921d0404c07db64628a2428a87d39193d2797bbef2e69b1d51549
- sha256sums = 0a9d037336dab3dbd99652b71934a94cd1e9801650fe5e72f4dd1de1718dd4c1
+ sha256sums = 816fc5c6bf2032fd3c2270ee9dc19d9b5b7c3419fdad68d5b16f1fe353e5707a
sha256sums = a6a9bc1f9c9bee0345b735fcf422245ae7946f96f6c34520dd63530a98978c14
- sha256sums = 8e15b88ea217a068bdd5affdcaf350ffc5c22ea6614abbfe904533127d965941
sha256sums = b2c8d92275c976af195f1b8f8df0ae1a61781a1c20ccc10b41fdc81178427bd3
pkgname = openboard
diff --git a/PKGBUILD b/PKGBUILD
index e621a1f405f8..bb6801a59c20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Frank Siegert <frank.siegert@googlemail.com>
# Contributor: bartus <arch-user-repoᘓbartus.33mail.com>
pkgname=openboard
-pkgver=1.6.1
+pkgver=1.6.2
_src_folder="OpenBoard-${pkgver}"
-pkgrel=6
+pkgrel=1
pkgdesc="Interactive whiteboard software for schools and universities"
arch=('x86_64' 'i686')
url="http://openboard.ch/index.en.html"
@@ -17,20 +17,16 @@ source=("https://github.com/OpenBoard-org/OpenBoard/archive/v${pkgver}.tar.gz"
source+=(qchar.patch)
source+=(quazip.patch)
source+=(drop_ThirdParty_repo.patch)
-source+=("https://github.com/letsfindaway/OpenBoard/commit/8a3835c9139c47709358a1ec8eef9b4f816182c8.patch")
source+=(ffmpeg.patch)
-sha256sums=('cf5bfb570b9ac4e61e1670c5a433f1dcaf0de1e8dbcbd544f058711690afba79'
+sha256sums=('300b440edad8aa0aeb726e4cca0565a5ea4fc9b5446ddc2bd4710be3fa9f1b7f'
'64289f9d91cb25fa79fb988f19d43a542d67380fcf27668d0da1ee4ba1e705eb'
'b40fdab85f5921d0404c07db64628a2428a87d39193d2797bbef2e69b1d51549'
- '0a9d037336dab3dbd99652b71934a94cd1e9801650fe5e72f4dd1de1718dd4c1'
+ '816fc5c6bf2032fd3c2270ee9dc19d9b5b7c3419fdad68d5b16f1fe353e5707a'
'a6a9bc1f9c9bee0345b735fcf422245ae7946f96f6c34520dd63530a98978c14'
- '8e15b88ea217a068bdd5affdcaf350ffc5c22ea6614abbfe904533127d965941'
'b2c8d92275c976af195f1b8f8df0ae1a61781a1c20ccc10b41fdc81178427bd3')
prepare() {
cd "$srcdir"/$_src_folder
- msg2 "poppler"
- patch -f -p1 < "$srcdir"/8a3835c9139c47709358a1ec8eef9b4f816182c8.patch
msg2 "drop_ThirdParty_repo"
patch -f -p1 < "$srcdir"/drop_ThirdParty_repo.patch || true
msg2 "qchar"
diff --git a/poppler.patch b/poppler.patch
deleted file mode 100644
index 19f7b709ea29..000000000000
--- a/poppler.patch
+++ /dev/null
@@ -1,124 +0,0 @@
-diff --git a/OpenBoard.pro b/OpenBoard.pro
-index b8a7ae5..0dcf3b8 100644
---- a/OpenBoard.pro
-+++ b/OpenBoard.pro
-@@ -3,6 +3,7 @@ TEMPLATE = app
-
- THIRD_PARTY_PATH=../OpenBoard-ThirdParty
-
-+CONFIG += c++14
- CONFIG -= flat
- CONFIG += debug_and_release \
- no_include_pwd
-diff --git a/src/pdf/XPDFRenderer.cpp b/src/pdf/XPDFRenderer.cpp
-index a3e828e..a77ee49 100644
---- a/src/pdf/XPDFRenderer.cpp
-+++ b/src/pdf/XPDFRenderer.cpp
-@@ -32,6 +32,7 @@
- #include <QtGui>
-
- #include <frameworks/UBPlatformUtils.h>
-+#include <poppler/cpp/poppler-version.h>
-
- #include "core/memcheck.h"
-
-@@ -47,11 +48,15 @@ XPDFRenderer::XPDFRenderer(const QString &filename, bool importingFile)
- {
- // globalParams must be allocated once and never be deleted
- // note that this is *not* an instance variable of this XPDFRenderer class
-+#if POPPLER_VERSION_MAJOR > 0 || POPPLER_VERSION_MINOR >= 83
-+ globalParams = std::make_unique<GlobalParams>();
-+#else
- globalParams = new GlobalParams(0);
-+#endif
- globalParams->setupBaseFonts(QFile::encodeName(UBPlatformUtils::applicationResourcesDirectory() + "/" + "fonts").data());
- }
-
-- mDocument = new PDFDoc(new GString(filename.toLocal8Bit()), 0, 0, 0); // the filename GString is deleted on PDFDoc desctruction
-+ mDocument = new PDFDoc(new GooString(filename.toLocal8Bit()), 0, 0, 0); // the filename GString is deleted on PDFDoc desctruction
- sInstancesCount.ref();
- }
-
-@@ -70,8 +75,12 @@ XPDFRenderer::~XPDFRenderer()
-
- if (sInstancesCount.loadAcquire() == 0 && globalParams)
- {
-+#if POPPLER_VERSION_MAJOR > 0 || POPPLER_VERSION_MINOR >= 83
-+ globalParams.reset();
-+#else
- delete globalParams;
- globalParams = 0;
-+#endif
- }
- }
-
-@@ -99,16 +108,28 @@ QString XPDFRenderer::title() const
- {
- if (isValid())
- {
-+#if POPPLER_VERSION_MAJOR > 0 || POPPLER_VERSION_MINOR >= 55
-+ Object pdfInfo = mDocument->getDocInfo();
-+#else
- Object pdfInfo;
- mDocument->getDocInfo(&pdfInfo);
-+#endif
- if (pdfInfo.isDict())
- {
-- Object title;
- Dict *infoDict = pdfInfo.getDict();
-- if (infoDict->lookup((char*)"Title", &title)->isString())
-+#if POPPLER_VERSION_MAJOR > 0 || POPPLER_VERSION_MINOR >= 55
-+ Object title = infoDict->lookup((char*)"Title");
-+#else
-+ Object title;
-+ infoDict->lookup((char*)"Title", &title);
-+#endif
-+ if (title.isString())
- {
-- GString *gstring = title.getString();
-- return QString(gstring->getCString());
-+#if POPPLER_VERSION_MAJOR > 0 || POPPLER_VERSION_MINOR >= 72
-+ return QString(title.getString()->c_str());
-+#else
-+ return QString(title.getString()->getCString());
-+#endif
- }
- }
- }
-@@ -172,12 +193,12 @@ QImage* XPDFRenderer::createPDFImage(int pageNumber, qreal xscale, qreal yscale,
- SplashColor paperColor = {0xFF, 0xFF, 0xFF}; // white
- if(mSplash)
- delete mSplash;
-- mSplash = new SplashOutputDev(splashModeRGB8, 1, gFalse, paperColor);
-- mSplash->startDoc(mDocument->getXRef());
-+ mSplash = new SplashOutputDev(splashModeRGB8, 1, false, paperColor);
-+ mSplash->startDoc(mDocument);
- int rotation = 0; // in degrees (get it from the worldTransform if we want to support rotation)
-- GBool useMediaBox = gFalse;
-- GBool crop = gTrue;
-- GBool printing = gFalse;
-+ bool useMediaBox = false;
-+ bool crop = true;
-+ bool printing = false;
- mSliceX = 0.;
- mSliceY = 0.;
-
-diff --git a/src/pdf/XPDFRenderer.h b/src/pdf/XPDFRenderer.h
-index 8ab200b..003a205 100644
---- a/src/pdf/XPDFRenderer.h
-+++ b/src/pdf/XPDFRenderer.h
-@@ -36,10 +36,10 @@
- #include "globals/UBGlobals.h"
-
- THIRD_PARTY_WARNINGS_DISABLE
--#include <xpdf/Object.h>
--#include <xpdf/GlobalParams.h>
--#include <xpdf/SplashOutputDev.h>
--#include <xpdf/PDFDoc.h>
-+#include <poppler/Object.h>
-+#include <poppler/GlobalParams.h>
-+#include <poppler/SplashOutputDev.h>
-+#include <poppler/PDFDoc.h>
- THIRD_PARTY_WARNINGS_ENABLE
-
- class PDFDoc;
diff --git a/quazip.patch b/quazip.patch
index 7793bf5a20bb..f807b2c3b2e6 100644
--- a/quazip.patch
+++ b/quazip.patch
@@ -6,9 +6,9 @@ diff -Naur OpenBoard-1.6.0a3.orig/OpenBoard.pro OpenBoard-1.6.0a3/OpenBoard.pro
#LIBS += -lprofiler
LIBS += -lX11
- LIBS += -lquazip5
-- INCLUDEPATH += "/usr/include/quazip"
+- INCLUDEPATH += "/usr/include/quazip5"
+ LIBS += "-lquazip1-qt5"
-+ INCLUDEPATH += /usr/include/QuaZip-Qt5-1.2/quazip
++ INCLUDEPATH += /usr/include/QuaZip-Qt5-1.3/quazip
LIBS += -lpoppler
INCLUDEPATH += "/usr/include/poppler"
@@ -41,7 +41,7 @@ diff -Naur OpenBoard-1.6.0a3.orig/plugins/cffadaptor/UBCFFAdaptor.pro OpenBoard-
-DEPENDPATH += $$THIRD_PARTY_PATH/quazip/
-INCLUDEPATH += $$THIRD_PARTY_PATH/quazip/
-include($$THIRD_PARTY_PATH/quazip/quazip.pri)
-+INCLUDEPATH += /usr/include/QuaZip-Qt5-1.2/quazip
++INCLUDEPATH += /usr/include/QuaZip-Qt5-1.3/quazip
SOURCES += \