summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVekhir2024-05-08 11:01:26 +0200
committerVekhir2024-05-08 11:16:55 +0200
commit7e976c7f2c8d058f8c179fda18f985a823df2959 (patch)
treee9d6f602bf854fa086f879e2a1710781af271c93
parent398ab35885d6745382ee8337ed414bc2d6a26118 (diff)
downloadaur-7e976c7f2c8d058f8c179fda18f985a823df2959.tar.gz
Update to 1.7.1 and switch to cmake community build
Starting with 1.7.1, OpenBoard supports building with cmake. The community build has several advantages: 1. FHS-compliant layout 2. Easy configuration of Qt version 3. Use of cmake is more common and standardised 4. Many of the patches and files become unnecessary. The unnecessary files have been removed, together with several unused dependencies.
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD58
-rw-r--r--drop_ThirdParty_repo.patch76
-rw-r--r--openboard.desktop10
-rw-r--r--qchar.patch12
-rw-r--r--quazip.patch62
-rw-r--r--qwebkit.patch12
7 files changed, 21 insertions, 231 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d95ec37f0754..5548afacf1ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = openboard
pkgdesc = Interactive whiteboard software for schools and universities
- pkgver = 1.7.0
- pkgrel = 3
+ pkgver = 1.7.1
+ pkgrel = 1
url = http://openboard.ch/index.en.html
arch = x86_64
arch = i686
license = GPL3
- makedepends = patch
+ makedepends = cmake
makedepends = qt6-tools
depends = qt6-base
depends = qt6-declarative
@@ -14,23 +14,11 @@ pkgbase = openboard
depends = qt6-svg
depends = qt6-webchannel
depends = qt6-webengine
- depends = libpaper
- depends = bzip2
depends = openssl
- depends = libfdk-aac
- depends = sdl
depends = ffmpeg
depends = quazip-qt6
depends = poppler
- source = https://github.com/OpenBoard-org/OpenBoard/archive/v1.7.0.tar.gz
- source = openboard.desktop
- source = qchar.patch
- source = quazip.patch
- source = drop_ThirdParty_repo.patch
- sha256sums = 03b5e6f728339528b8580542302f1d80567f814b10cb94b83df9c996eca125a3
- sha256sums = 64289f9d91cb25fa79fb988f19d43a542d67380fcf27668d0da1ee4ba1e705eb
- sha256sums = b40fdab85f5921d0404c07db64628a2428a87d39193d2797bbef2e69b1d51549
- sha256sums = 7e790bc63831b611a6c068d3208f16cf3fff5294b69ccd6a0592d64538c7d493
- sha256sums = a6a9bc1f9c9bee0345b735fcf422245ae7946f96f6c34520dd63530a98978c14
+ source = https://github.com/OpenBoard-org/OpenBoard/archive/v1.7.1.tar.gz
+ sha256sums = 5c9fcb54bc1598b4b7026e6ecca07137660dd3d45bda472a5710acf600a2a22f
pkgname = openboard
diff --git a/PKGBUILD b/PKGBUILD
index 2527c231f94f..c4d1059a136b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,63 +2,37 @@
# Contributor: bartus <arch-user-repoᘓbartus.33mail.com>
## Configuration env vars:
-((ENABLE_QT5)) && qt="qt5" || qt="qt6"
+((ENABLE_QT5)) && QT_VER="5" || QT_VER="6"
+qt="qt${QT_VER}"
pkgname=openboard
-pkgver=1.7.0
+pkgver=1.7.1
_src_folder="OpenBoard-${pkgver}"
-pkgrel=3
+pkgrel=1
pkgdesc="Interactive whiteboard software for schools and universities"
arch=('x86_64' 'i686')
url="http://openboard.ch/index.en.html"
license=('GPL3')
-# qt{5,6} libraries probed wiht `ldd -r /opt/openboard/OpenBoard` for both builds
+# qt{5,6} libraries probed with `ldd -r /opt/openboard/OpenBoard` for both builds
# qt5-base qt5-declarative qt5-location qt5-multimedia qt5-svg qt5-webchannel qt5-webengine
# qt6-5compat qt6-base qt6-declarative qt6-multimedia qt6-positioning qt6-svg qt6-webchannel qt6-webengine
depends+=(${qt}-{base,declarative,multimedia,svg,webchannel,webengine})
-depends+=('libpaper' 'bzip2' 'openssl' 'libfdk-aac' 'sdl' 'ffmpeg')
+depends+=('openssl' 'ffmpeg')
depends+=(quazip-${qt}) #drop internal quazip and use system one.
depends+=(poppler) #replace internal xpdf with poppler and drop freetype/xpdf from deps
-makedepends=('patch' ${qt}-tools)
-source=("https://github.com/OpenBoard-org/OpenBoard/archive/v${pkgver}.tar.gz"
- openboard.desktop)
-source+=(qchar.patch)
-source+=(quazip.patch)
-source+=(drop_ThirdParty_repo.patch)
-sha256sums=('03b5e6f728339528b8580542302f1d80567f814b10cb94b83df9c996eca125a3'
- '64289f9d91cb25fa79fb988f19d43a542d67380fcf27668d0da1ee4ba1e705eb'
- 'b40fdab85f5921d0404c07db64628a2428a87d39193d2797bbef2e69b1d51549'
- '7e790bc63831b611a6c068d3208f16cf3fff5294b69ccd6a0592d64538c7d493'
- 'a6a9bc1f9c9bee0345b735fcf422245ae7946f96f6c34520dd63530a98978c14')
-
-prepare() {
- cd "$srcdir"/$_src_folder
- echo "drop_ThirdParty_repo"
- patch -f -p1 < "$srcdir"/drop_ThirdParty_repo.patch || true
- echo "qchar"
- patch -p1 < "$srcdir"/qchar.patch
- echo "quazip"
- patch -f -p1 < "$srcdir"/quazip.patch
- echo "gcc11"
- sed 's/_serialize/serialize/g' -i src/pdf-merger/Object.{h,cpp}
-}
+makedepends=('cmake' ${qt}-tools)
+source=("https://github.com/OpenBoard-org/OpenBoard/archive/v${pkgver}.tar.gz")
+sha256sums=('5c9fcb54bc1598b4b7026e6ecca07137660dd3d45bda472a5710acf600a2a22f')
build() {
- cd "$srcdir"/$_src_folder
-# convert translations to binary form
- ((ENABLE_QT5)) || export PATH="/usr/lib/qt6/bin/:$PATH"
- lrelease OpenBoard.pro
- qmake OpenBoard.pro -spec linux-g++
- make
+ cmake -B build -S "$srcdir"/$_src_folder \
+ -DCMAKE_BUILD_TYPE=None \
+ -DQT_VERSION=${QT_VER} \
+ -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ -Wno-dev
+ cmake --build build
}
package() {
- cd "$srcdir"/$_src_folder
-
- install -Dm755 build/linux/release/product/OpenBoard -t "$pkgdir"/opt/openboard/
- cp -rp "$srcdir"/$_src_folder/resources/{customizations,etc,i18n,library,startupHints} -t "$pkgdir"/opt/openboard/
- install -Dm644 "$srcdir"/$_src_folder/resources/images/OpenBoard.png -t "$pkgdir"/usr/share/icons/hicolor/64x64/apps/
- install -Dm644 "$srcdir"/openboard.desktop -t "$pkgdir"/usr/share/applications/
- install -dm755 "$pkgdir"/usr/bin/
- ln -s /opt/openboard/OpenBoard "$pkgdir"/usr/bin/openboard
+ DESTDIR="$pkgdir" cmake --install build
}
diff --git a/drop_ThirdParty_repo.patch b/drop_ThirdParty_repo.patch
deleted file mode 100644
index 91a0b1315d01..000000000000
--- a/drop_ThirdParty_repo.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-diff -Naur OpenBoard-1.5.3/libs.pri OpenBoard-1.5.3-new/libs.pri
---- OpenBoard-1.5.3/libs.pri 1970-01-01 01:00:00.000000000 +0100
-+++ OpenBoard-1.5.3-new/libs.pri 2019-04-12 14:26:16.566266531 +0200
-@@ -0,0 +1,72 @@
-+
-+linux-g++ {
-+ SUB_LIB = "linux"
-+}
-+
-+linux-g++-32 {
-+ SUB_LIB = "linux"
-+}
-+linux-g++-64 {
-+ SUB_LIB = "linux"
-+}
-+
-+macx {
-+ SUB_LIB = "macx"
-+}
-+
-+win32 {
-+ CONFIG( debug, debug|release ) {
-+ SUB_LIB = "win32/debug"
-+ } else {
-+ SUB_LIB = "win32/release"
-+ }
-+}
-+
-+QUAZIP_DIR = "/usr"
-+LIBS += "-lquazip5"
-+
-+LIBS += "-lpoppler"
-+INCLUDEPATH += "/usr/include/poppler"
-+
-+
-+linux-g++ {
-+ LIBS += -lpaper
-+}
-+linux-g++-32 {
-+ LIBS += -lpaper
-+}
-+linux-g++-64 {
-+ LIBS += -lpaper
-+}
-+
-+win32 {
-+ INCLUDEPATH += "$$PWD/openssl/openssl-1.0.2-win32/include"
-+ QMAKE_LIBDIR += "$$PWD/openssl/openssl-1.0.2-win32/lib/static"
-+
-+ CONFIG( debug, debug|release ) {
-+ LIBS += -llibeay32
-+ LIBS += -lMsvcrtd
-+ } else {
-+ LIBS += -llibeay32MT
-+ LIBS += -lMsvcrt
-+ }
-+
-+ LIBS += -lWmvcore
-+ LIBS += -lWinmm
-+
-+ # need those link if we want to change default printer and print usind shell command
-+ LIBS += "-L$$PWD/microsoft/lib" "-lWinspool"
-+ LIBS += "-L$$PWD/microsoft/lib" "-lshell32"
-+}
-+
-+macx {
-+ LIBS += "-framework QuartzCore"
-+ LIBS += "-framework AudioToolbox"
-+ LIBS += "-framework CoreAudio"
-+ LIBS += "-framework ApplicationServices"
-+ LIBS += "-framework Cocoa"
-+
-+ LIBS += "-lcrypto"
-+}
-+
-+
diff --git a/openboard.desktop b/openboard.desktop
deleted file mode 100644
index 6a4e60050249..000000000000
--- a/openboard.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Type=Application
-Name=OpenBoard
-Comment=OpenBoard, an interactive white board application
-Exec=openboard %f
-Icon=OpenBoard.png
-StartupNotify=true
-Terminal=false
-MimeType=application/ubz
-Categories=Education;
diff --git a/qchar.patch b/qchar.patch
deleted file mode 100644
index c9f6bff1b93a..000000000000
--- a/qchar.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -u -ubr a/src/core/UBTextTools.cpp b/src/core/UBTextTools.cpp
---- a/src/core/UBTextTools.cpp 2017-05-09 15:59:42.177965830 +0200
-+++ b/src/core/UBTextTools.cpp 2017-05-09 16:00:08.547747097 +0200
-@@ -34,7 +34,7 @@
-
-
- for(int i = 0; i < _html.length(); i+=1){
-- if(_html.at(i) != '\0')
-+ if(_html.at(i) != QChar('\0'))
- clean.append(_html.at(i));
- }
- return clean;
diff --git a/quazip.patch b/quazip.patch
deleted file mode 100644
index 6ee1e8a6a04f..000000000000
--- a/quazip.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-diff -Naur OpenBoard-1.6.0a3.orig/OpenBoard.pro OpenBoard-1.6.0a3/OpenBoard.pro
---- OpenBoard-1.6.0a3.orig/OpenBoard.pro 2020-05-22 18:40:49.000000000 +0200
-+++ OpenBoard-1.6.0a3/OpenBoard.pro 2020-10-12 07:26:16.628748656 +0200
-@@ -466,11 +466,11 @@
- LIBS += -lX11
-
- greaterThan(QT_MAJOR_VERSION, 5) {
-- LIBS += -lquazip6
-- INCLUDEPATH += "/usr/include/quazip6"
-+ LIBS += -lquazip1-qt6
-+ INCLUDEPATH += "/usr/include/QuaZip-Qt6-1.4/quazip"
- } else {
-- LIBS += -lquazip5
-- INCLUDEPATH += "/usr/include/quazip5"
-+ LIBS += -lquazip1-qt5
-+ INCLUDEPATH += "/usr/include/QuaZip-Qt5-1.4/quazip"
- }
-
- LIBS += -lpopplerdiff -Naur OpenBoard-1.6.0a3.orig/plugins/cffadaptor/UBCFFAdaptor.pro OpenBoard-1.6.0a3/plugins/cffadaptor/UBCFFAdaptor.pro
---- OpenBoard-1.6.0a3.orig/plugins/cffadaptor/UBCFFAdaptor.pro 2020-05-22 18:40:49.000000000 +0200
-+++ OpenBoard-1.6.0a3/plugins/cffadaptor/UBCFFAdaptor.pro 2020-10-12 07:20:08.496096917 +0200
-@@ -13,9 +13,6 @@
- linux-g++-32: SUB_DIR = linux
- linux-g++-64: SUB_DIR = linux
-
--THIRD_PARTY_PATH = ../../../Sankore-ThirdParty
--QUAZIP_DIR = "$$PWD/../../../Sankore-ThirdParty/quazip/quazip-0.3"
--
- BUILD_DIR = build/$$SUB_DIR
- CONFIG(debug, debug|release):BUILD_DIR = $$BUILD_DIR/debug
- CONFIG(release, debug|release) {
-@@ -39,7 +36,7 @@
- QMAKE_POST_LINK += bash postScript_mac.sh "$$DESTDIR" "$$SANKORE_DIR/$$BUILD_DIR/product/Open-Sankore.app/Contents/MacOS"
- }
-
--LIBS += "-L$$THIRD_PARTY_PATH/quazip/lib/$$SUB_DIR" "-lquazip"
-+LIBS += "-lquazip1-qt5"
-
- QT += xml xmlpatterns core
- QT += gui
-@@ -51,9 +48,7 @@
-
- INCLUDEPATH += src
-
--DEPENDPATH += $$THIRD_PARTY_PATH/quazip/
--INCLUDEPATH += $$THIRD_PARTY_PATH/quazip/
--include($$THIRD_PARTY_PATH/quazip/quazip.pri)
-+INCLUDEPATH += /usr/include/QuaZip-Qt5-1.4/quazip
-
-
- SOURCES += \
---- OpenBoard-1.5.4.orig/libs.pri 2020-10-11 14:17:54.587596163 +0200
-+++ OpenBoard-1.5.4/libs.pri 2020-10-11 14:13:49.516394503 +0200
-@@ -23,7 +23,7 @@
- }
-
- QUAZIP_DIR = "/usr"
--LIBS += "-lquazip5"
-+LIBS += "-lquazip1-qt5"
-
- LIBS += "-lpoppler"
- INCLUDEPATH += "/usr/include/poppler"
diff --git a/qwebkit.patch b/qwebkit.patch
deleted file mode 100644
index 6e8d0d8887fc..000000000000
--- a/qwebkit.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -u -ubr a/resources/forms/trapFlash.ui b/resources/forms/trapFlash.ui
---- a/resources/forms/trapFlash.ui 2017-05-09 15:59:42.177965830 +0200
-+++ b/resources/forms/trapFlash.ui 2017-05-09 16:00:08.547747097 +0200
-@@ -113,7 +113,7 @@
- <customwidget>
- <class>QWebView</class>
- <extends>QWidget</extends>
-- <header>QtWebKit/QWebView</header>
-+ <header>QtWebKitWidgets/QWebView</header>
- </customwidget>
- </customwidgets>
- <resources/>