summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2019-05-24 23:13:06 +0200
committerbartus2019-10-01 22:52:41 +0200
commit1901de0828295d0fb1912818190c525d655a79cc (patch)
tree903cfee0de414c65400d0d1f66b029bf3192b244
parent536e4509007717765c4fc5d72a554bc28cbc1095 (diff)
downloadaur-1901de0828295d0fb1912818190c525d655a79cc.tar.gz
add Travis build and deploy scripts
-rw-r--r--.travis.yml34
-rw-r--r--.travis_deploy.sh8
2 files changed, 42 insertions, 0 deletions
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 000000000000..af02c9821107
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,34 @@
+sudo: required
+
+branches:
+ only:
+ - master
+
+cache:
+ directories:
+# - src
+# - AUR-repo
+
+services:
+- docker
+
+arch:
+# repos:
+# - papyros=http://dash.papyros.io/repos/$repo/$arch
+ packages:
+ # arch/aur packages
+# - python
+# - perl
+ script:
+ - "makepkg -s --noconfirm"
+
+script:
+- "curl -s https://raw.githubusercontent.com/mikkeloscar/arch-travis/master/arch-travis.sh | bash"
+- "ls $(pwd)"
+
+deploy:
+ provider: script
+ script: bash .travis_deploy.sh
+ on:
+ branch: master
+ skip_cleanup: true
diff --git a/.travis_deploy.sh b/.travis_deploy.sh
new file mode 100644
index 000000000000..ac569f54e1a4
--- /dev/null
+++ b/.travis_deploy.sh
@@ -0,0 +1,8 @@
+. PKGBUILD
+git clone https://$GITHUB_ACCESS_TOKEN@github.com/bartoszek/AUR-repo.git
+cd AUR-repo
+cp $TRAVIS_BUILD_DIR/$pkgname-$pkgver*.pkg.tar.xz $(pwd)
+git add $pkgname-$pkgver*.pkg.tar.xz
+git status
+git commit -a -m "$pkgname $pkgver" -m "build_log: $TRAVIS_BUILD_WEB_URL"
+git push