summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2019-04-13 14:14:34 +0200
committerbartus2019-04-13 14:15:21 +0200
commit809c3c63c5233294c69a5ac0f44bafd92b0b4fa4 (patch)
tree0eadfe51feaee7d0b52df856cca3b95879d07e67
parentf9c233fb5d14ae01f847f6e1c77cbed41f8fa2e3 (diff)
downloadaur-809c3c63c5233294c69a5ac0f44bafd92b0b4fa4.tar.gz
drop ThirdParty repo
-rw-r--r--PKGBUILD32
-rw-r--r--drop_ThirdParty_repo.patch88
-rw-r--r--quazip.diff29
3 files changed, 102 insertions, 47 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5ba8a3cf39e1..6fc930398f42 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,26 +9,27 @@ arch=('x86_64')
url="http://openboard.ch/index.en.html"
license=('GPL3')
depends=('qt5-base' 'qt5-multimedia' 'qt5-svg' 'qt5-script' 'qt5-webkit' 'qt5-tools' 'qt5-xmlpatterns' 'libpaper' 'bzip2' 'openssl' 'libfdk-aac' 'sdl' 'ffmpeg')
-depends+=(poppler) #replace xpdf lib with poppler, simplify the package and remove internal dep.
depends+=(quazip) #drop internal quazip and use system one.
+depends+=(poppler) #replace xpdf lib with poppler, simplify the package and remove internal dep.
source=("git://github.com/OpenBoard-org/OpenBoard.git${_fragment}"
- "git://github.com/OpenBoard-org/OpenBoard-ThirdParty.git"
qchar.patch
qwebkit.patch
- quazip.diff
- poppler.patch
https://github.com/OpenBoard-org/OpenBoard/pull/218.diff
https://github.com/OpenBoard-org/OpenBoard/pull/223.diff
- openboard.desktop)
+ openboard.desktop
+)
+source+=(quazip.diff)
+source+=(poppler.patch)
+source+=(drop_ThirdParty_repo.patch)
md5sums=('SKIP'
- 'SKIP'
'bf2c524f3897cfcfb4315bcd92d4206e'
'60f64db6bf627015f4747879c4b30fd3'
- 'a9876bd6bcf72e95203a874068d14978'
- '8b774d204501bb8515ee224651a7d624'
'f484614cc48181287607afb5a45ef644'
'04c421c140e983d41975943ede5fe61a'
- '21d1749400802f8fc0669feaf77de683')
+ '21d1749400802f8fc0669feaf77de683'
+ '30a7928f696f958d5e8f06e02c49639f'
+ '8b774d204501bb8515ee224651a7d624'
+ '879116c683374b2dde291014e44a29fe')
pkgver() {
cd $srcdir/OpenBoard
@@ -37,12 +38,7 @@ pkgver() {
prepare() {
cd $srcdir/OpenBoard
- patch -p1 < $srcdir/qchar.patch
- patch -p1 < $srcdir/qwebkit.patch
- patch -p1 < $srcdir/quazip.diff
- patch -p1 < $srcdir/poppler.patch
- patch -p1 < $srcdir/218.diff
- patch -p1 < $srcdir/223.diff
+ git apply -v $srcdir/*{diff,patch}
}
build() {
@@ -63,9 +59,7 @@ package() {
cp -rp $srcdir/OpenBoard/resources/images/OpenBoard.png $pkgdir/opt/openboard/
cp -rp build/linux/release/product/OpenBoard $pkgdir/opt/openboard/
- mkdir -p $pkgdir/usr/share/applications
- cp $srcdir/openboard.desktop $pkgdir/usr/share/applications
-
- mkdir -p $pkgdir/usr/bin
+ install -D -m 644 $srcdir/openboard.desktop $pkgdir/usr/share/applications/openboard.desktop
+ install -d -m 755 $pkgdir/usr/bin
ln -s /opt/openboard/OpenBoard $pkgdir/usr/bin/openboard
}
diff --git a/drop_ThirdParty_repo.patch b/drop_ThirdParty_repo.patch
new file mode 100644
index 000000000000..058ede8829f8
--- /dev/null
+++ b/drop_ThirdParty_repo.patch
@@ -0,0 +1,88 @@
+diff -Naur OpenBoard-1.5.3/libs.pri OpenBoard-1.5.3-new/libs.pri
+--- OpenBoard-1.5.3/libs.pri 1970-01-01 01:00:00.000000000 +0100
++++ OpenBoard-1.5.3-new/libs.pri 2019-04-12 14:26:16.566266531 +0200
+@@ -0,0 +1,72 @@
++
++linux-g++ {
++ SUB_LIB = "linux"
++}
++
++linux-g++-32 {
++ SUB_LIB = "linux"
++}
++linux-g++-64 {
++ SUB_LIB = "linux"
++}
++
++macx {
++ SUB_LIB = "macx"
++}
++
++win32 {
++ CONFIG( debug, debug|release ) {
++ SUB_LIB = "win32/debug"
++ } else {
++ SUB_LIB = "win32/release"
++ }
++}
++
++QUAZIP_DIR = "/usr"
++LIBS += "-lquazip5"
++
++LIBS += "-lpoppler"
++INCLUDEPATH += "/usr/include/poppler"
++
++
++linux-g++ {
++ LIBS += -lpaper
++}
++linux-g++-32 {
++ LIBS += -lpaper
++}
++linux-g++-64 {
++ LIBS += -lpaper
++}
++
++win32 {
++ INCLUDEPATH += "$$PWD/openssl/openssl-1.0.2-win32/include"
++ QMAKE_LIBDIR += "$$PWD/openssl/openssl-1.0.2-win32/lib/static"
++
++ CONFIG( debug, debug|release ) {
++ LIBS += -llibeay32
++ LIBS += -lMsvcrtd
++ } else {
++ LIBS += -llibeay32MT
++ LIBS += -lMsvcrt
++ }
++
++ LIBS += -lWmvcore
++ LIBS += -lWinmm
++
++ # need those link if we want to change default printer and print usind shell command
++ LIBS += "-L$$PWD/microsoft/lib" "-lWinspool"
++ LIBS += "-L$$PWD/microsoft/lib" "-lshell32"
++}
++
++macx {
++ LIBS += "-framework QuartzCore"
++ LIBS += "-framework AudioToolbox"
++ LIBS += "-framework CoreAudio"
++ LIBS += "-framework ApplicationServices"
++ LIBS += "-framework Cocoa"
++
++ LIBS += "-lcrypto"
++}
++
++
+diff -Naur OpenBoard-1.5.3/OpenBoard.pro OpenBoard-1.5.3-new/OpenBoard.pro
+--- OpenBoard-1.5.3/OpenBoard.pro 2019-04-10 09:04:25.000000000 +0200
++++ OpenBoard-1.5.3-new/OpenBoard.pro 2019-04-12 14:26:34.289438050 +0200
+@@ -45,7 +45,7 @@
+
+ INCLUDEPATH += src
+
+-include($$THIRD_PARTY_PATH/libs.pri)
++include(libs.pri)
+ include(src/adaptors/adaptors.pri)
+ include(src/api/api.pri)
+ include(src/board/board.pri)
diff --git a/quazip.diff b/quazip.diff
index b73a205ba5ec..7bc5a0f121c2 100644
--- a/quazip.diff
+++ b/quazip.diff
@@ -11,34 +11,14 @@
FORMS += resources/forms/mainWindow.ui \
resources/forms/preferences.ui \
-@@ -164,11 +162,8 @@
- LIBS += -framework CoreMedia
- LIBS += -lcrypto
-
-- LIBS += -L/usr/local/opt/quazip/lib
-- LIBS += -L/usr/local/opt/ffmpeg/lib
- INCLUDEPATH += /usr/local/opt/openssl/include
- INCLUDEPATH += /usr/local/opt/ffmpeg/include
-- INCLUDEPATH += /usr/local/opt/quazip/include
-
- CONFIG(release, debug|release):CONFIG += x86_64
- CONFIG(debug, debug|release):CONFIG += x86_64
--- OpenBoard-1.5.3/plugins/cffadaptor/UBCFFAdaptor.pro 2019-04-10 09:04:25.000000000 +0200
+++ OpenBoard-1.5.3-quazip/plugins/cffadaptor/UBCFFAdaptor.pro 2019-04-12 08:53:45.622844493 +0200
-@@ -14,7 +14,6 @@
- linux-g++-64: SUB_DIR = linux
-
- THIRD_PARTY_PATH = ../../../Sankore-ThirdParty
--QUAZIP_DIR = "$$PWD/../../../Sankore-ThirdParty/quazip/quazip-0.3"
-
- BUILD_DIR = build/$$SUB_DIR
- CONFIG(debug, debug|release):BUILD_DIR = $$BUILD_DIR/debug
@@ -39,7 +38,7 @@
QMAKE_POST_LINK += bash postScript_mac.sh "$$DESTDIR" "$$SANKORE_DIR/$$BUILD_DIR/product/Open-Sankore.app/Contents/MacOS"
}
-LIBS += "-L$$THIRD_PARTY_PATH/quazip/lib/$$SUB_DIR" "-lquazip"
-+LIBS += "-lquazip"
++LIBS += "-lquazip5"
QT += xml xmlpatterns core
QT += gui
@@ -53,10 +33,3 @@
SOURCES += \
-@@ -66,4 +63,4 @@
- src/UBCFFConstants.h
-
- RESOURCES += \
-- resources/resources.qrc
-\ Brak znaku nowej linii na końcu pliku
-+ resources/resources.qrc